High frame rates, but stuttering

Discussion in 'Technical & Support' started by waynevegas, Jul 16, 2016.

  1. waynevegas

    waynevegas Registered

    Joined:
    Jan 12, 2012
    Messages:
    42
    Likes Received:
    1
    I have been battling ongoing stuttering issues even though my frame rates are very good. I have done extensive searching for answers and have tried everything that I could find....Nvidia inspector settings (and SLI profiles), vsync, config files, etc. I have a powerful system....5960X, SSD, 1080 SLI, triple gsync 2K monitors, and running Accuforce wheel. I have been experiencing the issues for several months now....with my previous 980tis in SLI and solo as well. I have tried disabling and removing the second cards in both setups as well...along with disabling gsync. My stuttering occurs whether I'm 60fps or 120fps. Beginning to think it is a Windows 10 related issue. The stuttering is the worst when looking at objects moving on the sides of the road and very exaggerated when turning. I do get frame rate fluctuations but it is like 80-120. I really do enjoy the game, but it has become unplayable for me....so I'm at my wits end and looking for any help. Thanks.
     
    LokiD likes this.
  2. Nuno Lourenço

    Nuno Lourenço Registered

    Joined:
    Oct 19, 2010
    Messages:
    592
    Likes Received:
    63
    Have you tried to limit fps to 60 for example in json? You will probably get some tearing but...
     
  3. Richard729

    Richard729 Registered

    Joined:
    Apr 24, 2016
    Messages:
    28
    Likes Received:
    9
    I found a couple of fixes for "Scenery Judder" which cured the problem in Project Cars.
    I hadn't noticed the problem too much in rFactor 2, but the two fixes certainly made rF2 run more smoothly.

    http://forum.projectcarsgame.com/sh...ing-and-Scenery-Judder-Two-cures-on-my-system!!!
     
    Last edited by a moderator: Jun 13, 2017
  4. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    2,978
    Likes Received:
    349
    Wich gfx card you`re actual using? You`re talking about Nvidia, but you signature shows AMD...?
     
  5. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    You have similar system as I have with 3 x 144Hz monitors.

    If you are using latest Nvidia driver try this:

    Open Nvidia inspector rFactor2 profile.

    Compatibility:
    SLI comparability bits: 0x02402004

    Sync and refresh:
    Maximum pre rendered frames: 1

    Common:
    Power management mode: Prefer maximum performance.

    UserData > player folder and open player.JASON file and edit:
    "Max Framerate":0,
    "Max Framerate#":"0 to disable (note: positive numbers only, we always use the 'alternate' method now)",
    "Texture Sharpening":0,
    "Texture Sharpening#":"Sharpen textures using MIP LOD bias - 0=Off, 1=+2.0(very blurry), 2=+1.0(blurry), 3=-1.0(sharp), 4=-2.0(very sharp), 5=0.0(auto)",

    rFactor2 video settings:
    Mode > Fullscreen
    Anti Aliasing > 4
    HDR> on
    Sync > video (use this only if you have micro stutters)

    If you are still having stuttering disable g-sync and edit this line "Max Framerate":0, in your player.JASON to "Max Framerate":120, or "Max Framerate":144,

    :)
     
  6. waynevegas

    waynevegas Registered

    Joined:
    Jan 12, 2012
    Messages:
    42
    Likes Received:
    1
    Thanks for the help. I tried all the above options and the problem is still present. Seemed to help the most limiting frame rates to 60, but the stuttering while turning is still very apparent. It is almost like a force screen door effect with motion blur.
     
  7. waynevegas

    waynevegas Registered

    Joined:
    Jan 12, 2012
    Messages:
    42
    Likes Received:
    1
    Thanks. I couldn't find the 0x02402004....used 0x02402005 instead and it doesn't give good results. Ended up using 0x02D04005 (LEGO Batman 2, rFactor 2(rFactor2.exe...) with good frame rate results but with major stuttering. So the scenario that helps to make it playable is:
    Compatibility:
    SLI comparability bits: 0x02D04005

    Sync and refresh:
    Maximum pre rendered frames: 1

    Common:
    Power management mode: Prefer maximum performance.

    UserData > player folder and open player.JASON file and edit:
    "Max Framerate":60,
    "Max Framerate#":"0 to disable (note: positive numbers only, we always use the 'alternate' method now)",
    "Texture Sharpening":5,
    "Texture Sharpening#":"Sharpen textures using MIP LOD bias - 0=Off, 1=+2.0(very blurry), 2=+1.0(blurry), 3=-1.0(sharp), 4=-2.0(very sharp), 5=0.0(auto)",

    rFactor2 video settings:
    Mode > Fullscreen
    Anti Aliasing > 4
    HDR> on
    Sync > off
    Gsync enabled

    Thanks for your help. Sure do wish I could use the higher frame rates and lower latency, but just doesn't want to work with Rfactor 2. My setup works great with AC, PCars, and RR3. Here's hoping Rfactor 2 moves to a modern engine in the future as it gives me the best road feel.
     
  8. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    Sounds strange, I have np to run with locked 120 fps. If you have messed a lot with Nvidia inspector rFactor2(rFactor2.exe) profile delete that one and use rFactor2(Mod Mode.exe) Remember that you must add application to current profile (64 bit folder, rFactor2) :)Delete also config.ini from your user data folder.
     
  9. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    Ahh, this is why you have stutters, you must edit SLI comparability bits: 0x02D04005 to 0x02D04004 with your KB or use copy and paste. Gsync enambled use "Max Framerate":0,
     
  10. waynevegas

    waynevegas Registered

    Joined:
    Jan 12, 2012
    Messages:
    42
    Likes Received:
    1
    Thanks. I tried editing both the 0x02402005 to 004 and the 0x02D04005 to 004 with similar poor results. 0x02D04005 is the only scenario that nets me decent frame rates...although with stuttering. The others give poor frames and stuttering. Oddly, I just set the SLI to 0x02D04005 with Sync on Video, Max Frames 0 and just had pretty good results on a Virtua LM track (MidOhio....good frames (70-140) and little to no stuttering, but unfortunately poor results on an ISI track (Mills)....lots of stuttering but good frames again.
     
  11. nickcrete

    nickcrete Registered

    Joined:
    Sep 8, 2013
    Messages:
    66
    Likes Received:
    11
    Tried disabling all the plugins and/or try a clean rF2 installation ? Maybe the problem is not the hardware.
     
  12. waynevegas

    waynevegas Registered

    Joined:
    Jan 12, 2012
    Messages:
    42
    Likes Received:
    1
    I already tried a fresh install...but will try disabling plugins. Thanks.
     
  13. waynevegas

    waynevegas Registered

    Joined:
    Jan 12, 2012
    Messages:
    42
    Likes Received:
    1
    Thanks for the idea...tried disabling all plugins and same result unfortunately.
     
  14. Marek Lesniak

    Marek Lesniak Car Team Staff Member

    Joined:
    Oct 6, 2010
    Messages:
    1,583
    Likes Received:
    101
    Are you sure it's stuttering and not tearing? As the way you described it, sounds more like tearing to me.
    In rFconfig, try with software sync option.
     
  15. waynevegas

    waynevegas Registered

    Joined:
    Jan 12, 2012
    Messages:
    42
    Likes Received:
    1
    Yes, I'm sure it isn't tearing...I have 144hz gsync monitors. I hadn't tried the software sync variation, although it isn't completely gone the stuttering is definitely much less. Thanks for the suggestion.
     
  16. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    If you like to get rid of stuttering and tearing in rF2 you must use locked fps. I am not sure if your monitors can run without stuttering and tearing at 120 fps perhaps you must lock fps at 144 fps.
    With locked fps I mean that you game must run all the time with 120 or 144 fps +- 3 fps. (rFactor2 video settings >Mode > Fullscreen.)I bought 2 x 1080 cards last Friday and 120 fps gameplay in rF2 is still not possible with descent in game settings with triple screens, SLI or single card. If you like to play rF2 at 120/144 fps you must turn off shadows and reflection off and use rFactor2 video settings >
    > Mode > Fullscreen > Anti Aliasing > 2.
     
    ebeninca likes this.
  17. waynevegas

    waynevegas Registered

    Joined:
    Jan 12, 2012
    Messages:
    42
    Likes Received:
    1
    On some tracks I can reach 120-130 FPS, but not steady....sometimes as low as 40-50 at the start. Oddly, I get better performance with will all max settings and Anti Aliasing at 4X than I do with anything lower like 2X. I also enable FXAA and that combo seems to be doing better for me. If I lower any settings it doesn't seem to have any positive effect for me for frame rate or stutter. I also read somewhere that with SLI that Nvidia recommends pre-rendering frames equal to the number of cards. So I changed my max pre-rendered frames in the SLI profile to 2 and it seems to have helped. I have to run the 0x02D04005 profile (lego 2, not default profile)to gain any real performance. I lock my frames from 75-85 and am really satisfied with the results now. I also run with Software Sync enabled in the Rfactor video settings.
     
  18. LokiD

    LokiD Registered

    Joined:
    May 3, 2017
    Messages:
    1,282
    Likes Received:
    1,212
    hmm this is what I'm getting on a 144 monitor at the same sorta fps. Did you ever try fast sync in NVidia? Works for me and all stutter or tearing gone.
     
    Last edited: Aug 28, 2017

Share This Page