[HELP GUYS!] rF2 shutting down from nothing!

Discussion in 'Technical Archives' started by Thiago Lima, Dec 23, 2012.

  1. Thiago Lima

    Thiago Lima Registered

    Joined:
    Dec 23, 2012
    Messages:
    70
    Likes Received:
    0
    Hi guys!
    First off all, all my graphic softwares were/are updated, so rF2 134 too.

    Problem: Im running the game, racing online or single-player, and from nothing the game just close!

    The OS (W7 64 bits) keep working fine when the game close/shutt down.
    so i think its not some "kernel" problem.

    I`m a little dissapointed to race, `cause everytime I`m going to, I think the game might re-start.
    It´s very frustrating! :(

    Some friends are having the same problem as I. So I decided to report.
    It`s not something that happens everytime. Just once a day.
    But its reeeeeally frustrating!!!!



    Im using a G27 with the latest 64 bit logitech software.


    My computer is a:

    i5 2400
    4 giga DDR3 1600Mhz
    eVGA 660 ti SC
    Corsair ATX 500W 80% +


    I`m running the game with all maxed, 1080p and AA level 4.
    No Vsync or adaptative Vsync.


    Waiting for an answer! \o
     
    Last edited by a moderator: Dec 23, 2012
  2. Butch Nackley

    Butch Nackley Registered

    Joined:
    Sep 8, 2012
    Messages:
    292
    Likes Received:
    12
    Check in Event Viewer and see if there is an error message there.
    Control Panel > Administrative Tools > Event Viewer > Summary of Administrative Events > Error > scroll down and see if there is any error under Application Error or anywhere else.

    If you check there right after a crash, it should be listed under Last Hour.
     
  3. Abriel Nei

    Abriel Nei Registered

    Joined:
    Aug 7, 2012
    Messages:
    714
    Likes Received:
    37
    Did you update to build 134? If yes, then try a clean install of the latest build (save Packages, uninstall, delete any left over files, reinstall full build 134).
     
  4. Thiago Lima

    Thiago Lima Registered

    Joined:
    Dec 23, 2012
    Messages:
    70
    Likes Received:
    0
    thanks man!
    Ill try this out if the problem happens again.
    I have some mods from ISR that are not working (not installed well `cause I dont have some tracks). Do you think that it
    might be the reason of the problem?
     
  5. Thiago Lima

    Thiago Lima Registered

    Joined:
    Dec 23, 2012
    Messages:
    70
    Likes Received:
    0
    I juts bought the game recently. I downloaded the latest buid before the 134...and then updated.
    But i gotta confess that i didn`t know how to manage these "clean/install/clean etc" thing. :p
     
  6. Thiago Lima

    Thiago Lima Registered

    Joined:
    Dec 23, 2012
    Messages:
    70
    Likes Received:
    0

    Man! It hapenned again!!!OH GOSH! thers something wrong.
    I`ve taken some screens:



    Im not a computer enthusiast. but i guess theres something wrong with nvidia driver, right?
    Something about "nvd3dum.dll ", what do i do???
    PS: Its in portuguese, but the error data is the same, right?



    View attachment 5323

    View attachment 5324

    View attachment 5325
     
    Last edited by a moderator: Dec 23, 2012
  7. Abriel Nei

    Abriel Nei Registered

    Joined:
    Aug 7, 2012
    Messages:
    714
    Likes Received:
    37
    Try some other driver. Try the latest or the latest beta...or in some cases older drivers work better. I don't have nvidia so I don't know, maybe someone that has can tell you...or you can try searching these forums to se what driver are people using.
     
  8. Thiago Lima

    Thiago Lima Registered

    Joined:
    Dec 23, 2012
    Messages:
    70
    Likes Received:
    0
    Well, I`ve just searched the internet and, apparently, its something usual and happens with a lot of games.
    So, I did some things now and started Rfactor 2 multiplayer. It`s working so far.


    Things I did:
    Installed spyboot sarch and destroy end scanned/fixed things.
    Installed Dll fixer. And fixed (dã).
    Updated W7 SP1.
    And at least, but nos last I configurated rFactor2 to run with administrator and W7 compatibility (it was set for Windows Vista SP3).


    My Nvidia driver was upgraded before Rfactor2.
    so, i guess its working....lets play and wait.

    Thankx man!
     
  9. Butch Nackley

    Butch Nackley Registered

    Joined:
    Sep 8, 2012
    Messages:
    292
    Likes Received:
    12
    Are you using EVGA Precision?
    If so, try uninstalling it.
    This thread had the question:
    http://answers.microsoft.com/en-us/...tly-with/50a721df-b2b0-409c-96fa-e6c4d68d2759

    Mike a Support Engineer suggested a Clean Boot:
    http://support.microsoft.com/kb/929135

    Back to the first thread the guy with the problem reported it was EVGA Precision not getting along with Win7. So, if you are using it, maybe try removing it. Or you too do a clean boot and test some things first.

    There are a number of replies in that first thread. I didn't read them all. When I saw EVGA, I knew you had an EVGA card and stopped reading there. You may want to read more of the thread though.

    I would NOT try one of those "Fix.dll problems now" websites that keeps coming up in searches. I did not see a single person in any threads say anything about them. They sound fishy to me anyway.

    Hope this helps. If not, maybe one of the ISI team will know something about the problem. I see it is happening to a lot of people with verious games/apps, not just rF2.
     
  10. Thiago Lima

    Thiago Lima Registered

    Joined:
    Dec 23, 2012
    Messages:
    70
    Likes Received:
    0
    Im not using eVGA Precision `cause I`ve already know about the problems.
    The second one ill try if the problem happnes again.


    I have just race online and everything worked fine.
    Lets see with the time....

    Thnkx man! :D
     
  11. Butch Nackley

    Butch Nackley Registered

    Joined:
    Sep 8, 2012
    Messages:
    292
    Likes Received:
    12
    Glad you got it working.
    I guess some of those .dll fixers are okay then. I've always been a little suspicious of some of those things.
     
  12. MJP

    MJP Registered

    Joined:
    Oct 5, 2010
    Messages:
    988
    Likes Received:
    20
    I still wouldn't want to use one of those 'DLL Fixer' things. Trouble is he's done a bunch of other things too and now has no idea which one has fixed his problem or even if it has fixed it (hopefully it has).

    Not sure why he's running W7 compatibility if he's on W7, what was it doing set to Vista SP3, was there ever a Vista SP3 :confused:
     
  13. Butch Nackley

    Butch Nackley Registered

    Joined:
    Sep 8, 2012
    Messages:
    292
    Likes Received:
    12
    I just figured it was a typo and was supposed to be Vista SP2.

    As far as I know it was supposedly in the works, but I don't think it was ever released. I read somewhere that it was dropped because and Win 7 was released, which was Vista SP3 rebadged. Don't know if that is ture or not. Just something I read a while back.

    I'm on Vista Ultimate x64 SP2 and Windows update doesn't show an option for SP3.
     
  14. Thiago Lima

    Thiago Lima Registered

    Joined:
    Dec 23, 2012
    Messages:
    70
    Likes Received:
    0
    Dont be so sure about DLL`s fixer. I was desperate, so I downloaded one! hehehe

    Me too. I went to propreties and saw WVista SP3 compatibilitty and thoght " What the f*ck?!?" Than I changed to W7.

    PS: Merry Christmas guys! Lets race (and have fun) a lot on this new year!
    ;)
     
  15. CHARLIEZULUZULU

    CHARLIEZULUZULU Registered

    Joined:
    Jan 2, 2013
    Messages:
    14
    Likes Received:
    0
    Hi, I have a similar problem as Thiago Lima but I don't now how to fix it.

    While I'm playing rFactor 2, the applicartion crashes and shows the following message (it's in spanish):

    View attachment 5462

    I hope you can help e as soon as posible.
     
  16. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    124
    Charlie: If you have plugins, remove them, then if that stops the crashing, add them 1 by 1 until you find the culprit.
     
  17. CHARLIEZULUZULU

    CHARLIEZULUZULU Registered

    Joined:
    Jan 2, 2013
    Messages:
    14
    Likes Received:
    0
    Hi Tim,

    I have no plugins intalled. Don't know what can I do.

    Sorry for making troubles out here.
     
  18. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    124
    Ok, I'll just let the guys know in my next report to the devs, which should be this afternoon. I can't think of much else except system issues with directx not updated, etc.

    At what point does it crash? Does the launcher crash, or the rfactor2 window when launched?
     
    1 person likes this.
  19. CHARLIEZULUZULU

    CHARLIEZULUZULU Registered

    Joined:
    Jan 2, 2013
    Messages:
    14
    Likes Received:
    0
    It crashes while i'm playing, 20 minutes after playing or 5 or 60 minutes. You can't expect when is going to crash. But I can play with no problems till its crashes.
     
  20. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    124
    Oh, that's interesting. Maybe they can make something out of the error image you posted. Thanks for your patience.
     

Share This Page