Grass Graphic Issues...Please Help Me!

Discussion in 'Technical & Support' started by VampyPeanut, Mar 27, 2020 at 3:06 AM.

  1. VampyPeanut

    VampyPeanut Registered

    Joined:
    Friday
    Messages:
    6
    Likes Received:
    4
    I recently downloaded rFactor2 and for some reason most of my tracks the grass/gravel is multi colored. Mainly blue and red shades, fortunately the trees and distant areas of the circuit the foliage color/shading is perfectly fine. I tried many different graphic settings in-game and within launcher. I even removed and reinstalled the game and same issue.PLEASE HELP :( rFactor 2(rFactor2.exe) Screenshot 2020.03.26 - 23.01.21.11.png
    BTW CP RUNNING I9.. W/ RTX2070 SUPER
     
  2. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,399
    Likes Received:
    1,248
    Where did you download it from?
     
  3. VampyPeanut

    VampyPeanut Registered

    Joined:
    Friday
    Messages:
    6
    Likes Received:
    4
    Hey Coutie,
    Thanks for reaching out so quicky! To answer your question i downloaded the sim from Steam Store.
     
    Corti likes this.
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,083
    Likes Received:
    2,863
    Are you running latest drivers, and default settings for everything? It's like some textures aren't loading or are getting corrupted, so the blending is bringing in black or red in those shots instead of different grass or dirt textures. Based on your CPU&GPU I imagine your system specs are more than adequate so either something is malfunctioning, a setting or settings is breaking the graphics pipeline, or you have some files (game or system) that are corrupted. Is it possible you've tuned some specific settings in the past and have forgotten about them?
     
    Corti likes this.
  5. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    527
    Likes Received:
    613
    CTRL+SHIFT+WindowsKEY+B
    or
    try to clean the nvidia drivers well to do a clean installation (recommended)
     
    Last edited: Mar 27, 2020 at 10:55 PM
  6. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,399
    Likes Received:
    1,248
    It looks like its a very old version of the game trying to run a newer track, so all you see is the vertex colours on the grass.
     
  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,083
    Likes Received:
    2,863
    I think you should explain such things rather than just giving a shortcut. It also seems unlikely to fix the issue, as 'restarting the graphics driver' should happen at every reboot.

    @Coutie Some textures are showing though, it's not 'just' vertex colour. That said, @VampyPeanut have you opted out of all betas? Some new players think they need to select a beta, but that's not the case (unless you want to try the beta UI).
     
    Corti likes this.
  8. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,399
    Likes Received:
    1,248
    Yes, to be more precise, a version of the game before the terrain shader was released. VEC did a race back in the day with an old game version and a newer track, and it looked exactly like this.
     
    Lazza likes this.
  9. VampyPeanut

    VampyPeanut Registered

    Joined:
    Friday
    Messages:
    6
    Likes Received:
    4
    Thanks for the help everyone!

    @Coutie how do you suggest i download the newer version as that's the only version i see on steam store.
    @Lazza yes ive opted out of all betas
    btw i dont have this issue at all tracks but most for sure.
     
  10. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,808
    Likes Received:
    1,225
    Steam should auto update rF2 and as you said you have opted out of betas.
    If your BuildID is the same as mine, you're up to date..
    build.JPG
     
  11. VampyPeanut

    VampyPeanut Registered

    Joined:
    Friday
    Messages:
    6
    Likes Received:
    4
    Hey @ADSTA thanks for your reply! and i just checked unfortunately the BuildID is the same.
    I really think its something to do with a texture file but can figure it out. The weird thing is i go to some tracks and the distance grass texture is fine. the grass track side at most of the tracks giving me this issue.
     
  12. VampyPeanut

    VampyPeanut Registered

    Joined:
    Friday
    Messages:
    6
    Likes Received:
    4
    GREAT NEWS GUYS I FIXED IT !!! THANKS FOR ALL THE HELP! Ended up uninstalling the game from steam, deleting the rfactor2 folder in steamapps file. Reinstalled, this time selecting V1117. under betas tabs which seem to be the latest. rFactor 2(rFactor2.exe) Screenshot 2020.03.29 - 23.38.54.64.png
     
    Corti and Marisa like this.
  13. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,083
    Likes Received:
    2,863
    The latest is 'opt out'.
     
  14. VampyPeanut

    VampyPeanut Registered

    Joined:
    Friday
    Messages:
    6
    Likes Received:
    4
    @Lazza I switched over "Opt Out" and everything is still working correctly. :D Thanks!
     
    ADSTA likes this.

Share This Page