Gmotor 2 errors crash game while loading - currently unplayable

Discussion in 'Technical & Support' started by mephisto, Nov 16, 2015.

  1. mephisto

    mephisto Registered

    Joined:
    Nov 16, 2015
    Messages:
    6
    Likes Received:
    0
    New player here. I purchased Rfactor 2 through Steam. I tried forcing 32bit mode through the launcher, I've tried reinstalling and verifying game files. I also tried disabled Steam overlay yet the errors persist.

    Once loading screen to track starts, game minimizes to desktop and I'm met with multiple Gmotor 2 Errors which appear as follows:

    Gmotor 2 Error: Error creating vertex shader ( repeat x9 )
    Gmotor 2 Error: Error loading mesh file NO_VISOR.GMT to memory
    Gmotor 2 Error: Error creating vertex shader
    Gmotor 2 Error: Error getting stats for texture MULTICAR2011.DDSError loading texture MULTRICAR2011 for material MULTICAR
    Gmotor 2 error: Error loafing global material MULTICAR
    Gmotor 2 Error: Error loading global material MULTICAR

    Then rFactor 2 crashes. Oddly enough the demo works perfectly.

    I'm on 64bit Windows 7.
    i5-4690k
    AMD r9 r390
    16gb RAM
     
  2. Vintook

    Vintook Registered

    Joined:
    Jan 15, 2012
    Messages:
    51
    Likes Received:
    0
    I also get these Gmotor2 mesh errors with the steam version but so far it only seems to happen with the Joesville track. I've tried a couple other tracks and they load fine.
     
  3. cabelo3d

    cabelo3d Registered

    Joined:
    Nov 15, 2015
    Messages:
    7
    Likes Received:
    0
    I am getting mostly this error:
    Mesh c6-wipers-b: Bone WIPPERRIGHTBONE01 could not be found in anim file WIPER.ANM
    Followed by rFactor has stopped working.
    This is a random error and sometimes the same track/car combo loads just fine. However it crashes my pc and it is really annoying.
    Waiting for a good soul to help us fixing this..
     
  4. dylbie

    dylbie Registered

    Joined:
    Oct 25, 2012
    Messages:
    367
    Likes Received:
    508
    Which car/mod are you using? GMT errors are a result of missing 3D objects, DDS are missing materials/textures, and the last problem suggests the animation file for the wipers is missing.

    I suggest perhaps re-downloading what ever car it is you're trying to use. If that doesn't work, use the GMT2 program in the support/tools folder to extract the files and then see if you can dig through the files to see if something is missing.
     
  5. jaapjanjoost

    jaapjanjoost Registered

    Joined:
    Nov 17, 2015
    Messages:
    2
    Likes Received:
    0
    I am also a new player and installed the rF2 game through my steam account. No mods installed!!! Only Vanilla game.
    I am running the 64bit versions of the game.

    When start the game it halts on the following error (twice, I have to ok two times to clear the message):

    I tried 2 circuits and several cars. All closed wheel cars no formula cars.
    It seams that the version steam is offering is corrupt.
     
  6. jaapjanjoost

    jaapjanjoost Registered

    Joined:
    Nov 17, 2015
    Messages:
    2
    Likes Received:
    0
    I did a complete erase and reinstall of the game through steam. But the results only become worse. Even with open wheel cars I get the message:

    And now also a bunch of DDS files are missing.

    Now also no mods installed, only the Vanila game. Downloaded from steam.
     
  7. mephisto

    mephisto Registered

    Joined:
    Nov 16, 2015
    Messages:
    6
    Likes Received:
    0
    Deleting rfactor 2 from Steam or Control Panel does NOT remove all the game files from your computer.

    Some rfactor 2 folders & files were still in "My Documents" and in Steam's default install directory: steam/steamapps/common/rfactor 2 . Make sure you've deleted all files.

    So far this has solved my problem. Now, only the first time I load a map does it have errors and crash my game. Once I restart the game and retry the game loads perfect and I'm able to play.

    It took me two re-installs to realize this. Hopefully ISI figures out a way to fix or avoid this from happening in the future.
     
  8. yenclas

    yenclas Registered

    Joined:
    Nov 16, 2015
    Messages:
    6
    Likes Received:
    0
    Same problem here with fresh install from steam (bought yesterday).

    Help Please
     
  9. cabelo3d

    cabelo3d Registered

    Joined:
    Nov 15, 2015
    Messages:
    7
    Likes Received:
    0
    The problems I'm having are also with a fresh install from Steam.. we need help.
     
  10. mephisto

    mephisto Registered

    Joined:
    Nov 16, 2015
    Messages:
    6
    Likes Received:
    0
    My solution

    I listed my fix in my last post: Some Rfactor 2 folders & files were still in "My Documents" and in Steam's default install directory (steam/steamapps/common/rfactor 2) even after uninstalling game through control panel. Make sure you've deleted all files from computer before reinstalling. If this doesn't fix it I suggest contacting ISI
    I still experienced errors and crashes but only on the first time loading a track or car after installing it. Afterwards there should be no issues loading any track or car.

    EDIT: Giving administrator privilege to "Launch rfactor.exe" found in steamapps/common/rfactor2/Launcher seems to aid some Gmotor Mesh Wiper and Bone errors but not all. Complete wipe then reinstall still recommended

    Be aware the game will usually crash if you alt+tab out back onto desktop during a race. Hopefully ISI is aware of this issue as well
     
    Last edited by a moderator: Nov 19, 2015
  11. tuuliaki

    tuuliaki Registered

    Joined:
    Jun 26, 2014
    Messages:
    14
    Likes Received:
    0
    I have this same gmotor 2 error ( " wiper anim etc. " ). It started today, I moved to Steam couple of weeks ago. I've owned rFactor 2 two years, but now it's suddenly unplayable.

    Help ISI!!
     
  12. matf1

    matf1 Registered

    Joined:
    Dec 27, 2011
    Messages:
    671
    Likes Received:
    1
    In session settings, uncheck all opponents and select only a few.

    Sent from my Nexus 4 using Tapatalk
     
  13. BullGod

    BullGod Registered

    Joined:
    Jan 15, 2012
    Messages:
    14
    Likes Received:
    6
    Following-up:
    I was able to get everything working as expected. No more GMotor errors, no more wiper.anm issues, no more issues with downloading the new (purchased) content. I removed everything related to RF2, everything. Deleted the Steam DL cache, the RF2 folder in Steam, as well as all data related to the app ID 365960
    -----------------
    As another post read:
    Uninstall rF2 through Steam.
    Go to where your Steam is installed, open the Steam folder and a search: 365960 (Important in my experience)
    Delete everything it finds, (The above references: ~\Steam\steamapps\shadercache\365960) - i deleted this folder as well.
    Delete ~\Steam\steamapps\common\rFactor 2
    You could also go to your Steam settings and clear the download cache
    ------------------
    Doing the above, as well as re-downloading, and running the Sim so it updates my chosen content, then running it successfully. Once I was able to add multipul cars and classes to a session without any errors, I then restored my UserSettings from a backup, and ALL IS WELL!

    For the first time, in a long time, I am able to run RF2 in all of its glory and bliss!!!
    -BullGod
     

Share This Page