G27 Shifter Issue

Discussion in 'Technical & Support' started by Moe Faster, Mar 6, 2019.

  1. Moe Faster

    Moe Faster Registered

    Joined:
    Oct 28, 2010
    Messages:
    111
    Likes Received:
    14
    I am an exclusive Clutch & H shifter racer. My old G27 Shifter has seen better days, & its latest trick is to shift from 3rd into 1st (without going thru Neutral) when I first touch or simply bump the shifter, in the direction of 1st (ie to the left), pretty much an instantaneous shift from 3rd to 1st & back to 3rd again. The result is a banana peal type race track disaster.
    The existing "Repeat Shifts":1, in the player.json may help but it does not fix the issue.
    Can the player. or the controller. json file be told to ignore this shift ??
     
  2. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    806
    Likes Received:
    477
    The "Repeat Shifts" parameter is to avoid the rebounds in a sequentiel or paddles shift.
    In a H Shifter the 3rd and the 1st gears are in different places. I think that the problem is in the shifter. It's possible that it has some clearance (I don't know if this term is correct in english).
     
  3. Rastas

    Rastas Registered

    Joined:
    Feb 17, 2017
    Messages:
    290
    Likes Received:
    542
    I have same problem a few months ago,solution was to disassemble the shifter and clean the potenciometers frist whit brake cleanear,and then put a bit of electrical contact cleaner spray,is like new,also check the metal plate for wear :)
     
    dylbie and lagg like this.
  4. dylbie

    dylbie Registered

    Joined:
    Oct 25, 2012
    Messages:
    254
    Likes Received:
    192
    I'm using an old G25 shifter with a bodnar box, and I'm having a similar issue where if I touch the stick when it's in 3rd, it jumps out of gear and into neutral. As I mainly race older cars, I was pretending to myself that rFactor2 was simulating worn synchros!

    But, alas, seems like I'll have to strip it and give it a clean!
     
  5. Moe Faster

    Moe Faster Registered

    Joined:
    Oct 28, 2010
    Messages:
    111
    Likes Received:
    14
    been inside the shifter a few times for dusting & cleaning, doesn't seem to change anything. I was hoping for a software related fix for this, seems like this would be in the realm of the old rF1 Grinding Tranny Mod where all gear changes have to go thru Neutral, otherwise they are ignored.
    Our gear is getting older & not everyone can afford to replace hardware at the flip of a bit. A fix like this would benefit many of us vintage racers.
     
  6. Moe Faster

    Moe Faster Registered

    Joined:
    Oct 28, 2010
    Messages:
    111
    Likes Received:
    14
    hey dylbie . . . that could be the top cover over the shaft binding up, there's a plastic bushing at the top . . . you decide.
     
  7. GaetanL

    GaetanL Registered

    Joined:
    Mar 14, 2012
    Messages:
    289
    Likes Received:
    24
    Have you try with higter values, you can put 2,3,4 or 5, I don't know what's for 5 but to my shifter I put 4 and works better than 1, this set the milliseconde where you shifter is desactivated after an push or pull (example 4 desactive shifter for 250 millisecondes) ;)
     
  8. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    5,557
    Likes Received:
    1,708
    I don't think the repeat shifts option can fix an issue like this, it's meant to reduce/eliminate multiple sequential shifts. Even if it does affect a shifter (which holds each gear) it won't fix the issue, as if anything it would hold you in the lower gear for longer rather than skipping it. This needs a hardware fix.
     
  9. Kelju_K

    Kelju_K Registered

    Joined:
    Sep 1, 2013
    Messages:
    203
    Likes Received:
    133
    I had similar problem. When in 5th gear i got the shifter suddenly shift to 3rd momentarily. Did open it and spray isopropanyl alcohol to the pots, but didnt get it fixed. What eventually fixed it was unplugging the wheel, then used usbdeview software to uninstall everything logitech related (right click and select uninstall selected devices). Then after reboot plugged the controller back in and after the initial calibration (wheel goes left to right) i moved the shifter trough all gears including reverse.
    That fixed it!
    I think its problem with the shifter calibration (its a 2 axis joystick really) and the center of it had shifted.
    Uninstalling the device with usbdeview after it was unplugged cleared that false center calibration and replugging and moving the stick troughout its range centered it again correctly.
    Had allmost lost hope and was getting a new shifter, but this method saved me!
    Maybe it could do the same for you as your problem sounds very similar to mine, ie x axis centering issue? Could be good idea to clean the pots still as them being dirty propably caused the center to get off in the first place.
     
    Last edited: Mar 25, 2019 at 2:24 AM

Share This Page