FANATEC CSW 2.5 Not recognized. HELP !

Discussion in 'Technical & Support' started by Ludo21, Aug 6, 2019.

  1. Ludo21

    Ludo21 Registered

    Joined:
    Aug 6, 2019
    Messages:
    9
    Likes Received:
    1
    Hi, i'm new here, but old in the Game! And sorry for my english, i'm French....
    I have big trouble with my Fanatec CSW 2.5 since 3 days.
    Since i verified integrated files in steam. I lost my fanatec in game.
    I reinstalls Completely RF2 !! But nothing!?
    I am very sad for the moment...
    My Fanatec work in Windows 10, recognized by drivers and other games (ACC, Dirt ok!)....
    Message in the game: "no connected controller detected"....
     
    Last edited: Aug 7, 2019
    chisco85 likes this.
  2. Ludo21

    Ludo21 Registered

    Joined:
    Aug 6, 2019
    Messages:
    9
    Likes Received:
    1
    One week and still not back...!!??
    My fanatec work in ACC or Dirt....
    Just on RF2 by one week....? A last W10 update?
    I don't knox but i'm very dissapointed....
    After many years in RF 2, you think that i must give up....
    PLEASE HELP!!! (it's the first time for me : problem with my fanatec and RF2....)
     
    Last edited: Aug 11, 2019 at 11:58 AM
  3. Ludo21

    Ludo21 Registered

    Joined:
    Aug 6, 2019
    Messages:
    9
    Likes Received:
    1
    I'm fed up!!
    People do not answer me! I did no find any solutions.
    I have tried everything.
    RĂ©install old W10, ans Fanatec drivers, and rf2...etc....Nothing works
    S397, HELP !!!
    My Csw work with Assetto corsa Comp....
     
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,229
    Likes Received:
    2,162
    Did you remove files when you reinstalled rF2? If not, try moving out your controller.json to create a new one.

    Have you tried manually assigning controls?
     
    JimmyT likes this.
  5. Ludo21

    Ludo21 Registered

    Joined:
    Aug 6, 2019
    Messages:
    9
    Likes Received:
    1
    Yes i tried this....But nothing...
     
  6. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    464
    Likes Received:
    245
    As @Lazza said, if you close steam then move the controller.json out of rF2 directory and put it somewhere not in Steam then restart steam and rF2 it will rebuild your controller.json and you should be able to re-configure your CSW. I use a CSW 2.5 and have no problems in rF2.
     
  7. Ludo21

    Ludo21 Registered

    Joined:
    Aug 6, 2019
    Messages:
    9
    Likes Received:
    1
    Hello, and thank you for your answer.
    I already tried this.
    And last night, i reinstalled completely RF2......But no.... :(
    And today, i am really sad and angry. I use my fanatec and Rf2 for two years without problems.
    My fanatec work with ACC.
    So what, i'm the only one in this situation? I drop RF2??!!
    W10 update?
    Please, S397, help!!
     
  8. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    464
    Likes Received:
    245
    I had a similar issue way back and found that I had to re-install the fanatec driver for it to work. Not sure if this will help but worth a try.
    If that fails just try plugging the CSW into a different USB
     
    Last edited: Aug 16, 2019 at 2:01 PM
  9. Ludo21

    Ludo21 Registered

    Joined:
    Aug 6, 2019
    Messages:
    9
    Likes Received:
    1
    Yes i already tried, and nothing works......
    it's a crazy story.....
    Abd i just took the two news cars, i can not even try them....
    :(
     
    Last edited: Aug 16, 2019 at 4:49 PM
  10. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,229
    Likes Received:
    2,162
    @Ludo21 It's really hard to find a solution, or to know what went wrong. Why did you verify the files in steam? Was something not working?
     
  11. Ludo21

    Ludo21 Registered

    Joined:
    Aug 6, 2019
    Messages:
    9
    Likes Received:
    1
    Hello.
    You will laugh...But that's the first thing i try.
    And of course, it does not work.....!
    I thing i tried everything
    S397 HELP...!!!!
    i feel a little lonely in this situation....
    :(
     
  12. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,229
    Likes Received:
    2,162
    Sorry, I thought from your first post that this problem appeared after verifying the files - so I was wondering why you were verifying the files (if you had a problem already). If this wheel problem appeared, and your first step was to try verifying the files, then there are no extra clues there.


    Obviously is it difficult to find a solution, because your wheel does work with the game, and others continue to use it. So it would seem something on your system has changed, but it can be very hard to find what it is and how to fix it.


    Just to be clear, because I asked 2 questions earlier and you answered one "yes" - have you tried assigning controls manually, rather than detecting the controller?
     
  13. Ludo21

    Ludo21 Registered

    Joined:
    Aug 6, 2019
    Messages:
    9
    Likes Received:
    1
    Yes, i tried assigning controls manually, many times!!
    I tried everything....It's just a crazy story...!
    For the moment, i use ACC.....Sorry S397. I become infidel!
    Ans above very dissapointed.
    I think it comes an update W10, and why only me? And of course I've already tried a backtrack on W10 !
     

Share This Page