External Mod (Packages) Error

Discussion in 'Technical & Support' started by Jwizzlesquiggles, Jan 16, 2022.

  1. Jwizzlesquiggles

    Jwizzlesquiggles Registered

    Joined:
    Dec 22, 2020
    Messages:
    7
    Likes Received:
    0
    I have been playing rFactor 2 on the old beta version for a while until Steam recently forced me to update. All my workshop files are loading fine but none of my external mods works. Everything is stored on the same hard-drive so there should be no issues there, I have only had this issue with the new UI.

    When I go into rF2 and go to "content" the "packages" button is coloured out in grey however I can still click it, but when I do it is just all the Workshop files. They all work fine but I really want to make use of some of the external mods I have paid for, its a real shame, can anyone help, please?

    I have tried the following so far:
    • Reinstalling all the mods after verifying game cache,
      • Nothing changed
    • Reinstalling rFactor 2 as a whole,
      • Nothing changed
    • Using Modmgr,
      • Modmgr won't pick up any of the mods in the "Packages" folder or any folder I link it to, when I refresh after setting it up to go to a file where my mods are, there is about 1/2 a second on-screen where I see them in the programme and then the programme crashes and when I reopen it, the directory has reset itself and I have to link it back to the folder.
    • Reverting back to the old beta,
      • Steam just forced me to use the normal version.
     
  2. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,049
    Likes Received:
    2,900
    You say that everything is stored on the same HDD, but are the rfcmp from your "external" Mods stored in the proper Packages Folder:
    ...\rFactor 2\Packages
    ?
     
  3. Jwizzlesquiggles

    Jwizzlesquiggles Registered

    Joined:
    Dec 22, 2020
    Messages:
    7
    Likes Received:
    0
    Yes that's right, all on the same SSD. I have tried with the mods being in a separate file on the SSD and with the mods being in packages. Both had the same crashing result.
     
  4. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,049
    Likes Received:
    2,900
    Have you tried to start with only 1 rfcmp, that you put into the empty ...\rFactor 2\Packages Folder?
    Maybe it's just 1 corrupted File that causes the Crashes, even if it seems to be unlikely.
     
  5. Jwizzlesquiggles

    Jwizzlesquiggles Registered

    Joined:
    Dec 22, 2020
    Messages:
    7
    Likes Received:
    0
    Yeah I've tried an individual file and it still has the same issue.
     
  6. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,049
    Likes Received:
    2,900
    Hmm, sounds strange.
    Try this:
    before you start the Game, rename the Folder
    ...\rFactor 2\UserData
    into
    UserData_Backup
    then start the Game and check if that helped.
     
  7. Jwizzlesquiggles

    Jwizzlesquiggles Registered

    Joined:
    Dec 22, 2020
    Messages:
    7
    Likes Received:
    0
    Still nothing, any other ideas?
     
  8. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,049
    Likes Received:
    2,900
    Currently no, sorry.
    It's always hard to help in such Cases, when you can not try it directly at the PC, that has the Problem(s).
     
  9. From my point of view, if modmgr is crashing while accessing the "external mod" file, only, than those files are corrupted or something like that (I have doubts they could have be bound to a specific rF2 version or UI version).

    If modmgr is crashing just while opening it and have it pointing to another packages directory than it could have something to do with the accessed folder (do you have permissions to read the folder e.g.).

    Also in the last months I had two people which did have comparable problems and it turned out that their SSDs were dying ... so backed up data was corrupted which could not be recognized because the backed data was not accessed for a long time (this could also happen in case of your extermal mods, which you are now copying from a specific folder to rf2/packages).

    So ... to make long things short: does rf2 run without any problems when NOT copying the external mods into rf2/packages?

    Regards, Stone
     
  10. Coutie

    Coutie Moderator Staff Member

    Joined:
    Oct 5, 2010
    Messages:
    3,796
    Likes Received:
    2,249
    Something you could try, subscribe to something on the workshop, have it download, then copy the file it downloaded somewhere other than its current folder. Then un-subscribe to that item, then you know that you have something that will at least work. Try putting only that into the packages folder and see if it still crashes.
     

Share This Page