Encountered an improper argument with mas2

Discussion in 'Technical & Support' started by Postipate, Jan 14, 2017.

  1. Postipate

    Postipate Registered

    Joined:
    May 15, 2012
    Messages:
    960
    Likes Received:
    1,543
    Hello!

    Everytime I try to pack mas files I got:

    "Encountered an improper argument"

    Happens with any file.

    Already deleted all rf2 files from steam folder and reinstalled.. Did not help me.

    Is there any idea what is causing this one?

    rf1 mas utility is working like it should be.

    using win10
     
  2. SmellySkidmark

    SmellySkidmark Registered

    Joined:
    Jan 11, 2012
    Messages:
    383
    Likes Received:
    110
    Hi Postipate try this it works whenever the mas2 stops making rfmods so it should fix your problem.
    Look in Users\name\appdata\roaming\. pkginfo.dat. . You should be able to delete that file and the MAS tool will work again.

    SS
     
    Juergen-BY likes this.
  3. KRO

    KRO Registered

    Joined:
    Nov 6, 2018
    Messages:
    15
    Likes Received:
    0
    up
    Nope, sorry but have this problem actually, perhaps i use a file name who make this error...
     
  4. KRO

    KRO Registered

    Joined:
    Nov 6, 2018
    Messages:
    15
    Likes Received:
    0
    really boring data processing..
    No computer no problem...
    perhaps if i burn it or bake it at 150° 15mn, it resolve the problem
     
  5. KRO

    KRO Registered

    Joined:
    Nov 6, 2018
    Messages:
    15
    Likes Received:
    0
    ok i find how , it s windows 10... execute with admin and it s working. for the moment..
     
  6. roberteker

    roberteker Registered

    Joined:
    Mar 13, 2019
    Messages:
    20
    Likes Received:
    3
    I get this error as well on a machine with Windows 7, and I don't have the file mentioned in my appdata folder, and if I launch the utility as administrator, I can't even drag and drop files into it.

    EDIT: Just tried on a different machine with Windows 10, and that works. So the current version of the utility requires Windows 10.
     
    Last edited: Jun 5, 2019

Share This Page