DX 11 beta FPS dropped 100 FPS

Discussion in 'Technical & Support' started by BoothJoe, May 2, 2017.

  1. BoothJoe

    BoothJoe Registered

    Joined:
    Oct 12, 2015
    Messages:
    202
    Likes Received:
    8
    I subscribed to the latest NOLA track and ran it with USF2000 and get around 145FPS on an AMD RX480 (stock Sapphire settings) using eyefinity at 5900x1080 using the standard DX9 RF2 version.
    I downloaded the DX11 beta. No matter what the Post Effects settings I use (none to ultra) my FPS is below 30 and is consistently about 22.
    With a 100FPS loss there must be some setting somewhere that I'm not catching.
     
  2. blaknift

    blaknift Registered

    Joined:
    Jan 6, 2012
    Messages:
    90
    Likes Received:
    1
    Im having a similar problem. I am running a lower frame rate with the game on its absolute worst settings than I did with it maxed. Same, Rx 480, I5-6600k. 16 Gigs of ram running 1080p
     
  3. BlackGoku

    BlackGoku Registered

    Joined:
    Dec 2, 2016
    Messages:
    116
    Likes Received:
    47
    All people with AMD are having FPS issues and all people with nvidia are having +20 fps with DX11.
    Did Studio 397 decided to do the same as Project CARS? Lets hope they don't and they are just beta problems.
     
  4. Brent

    Brent Registered

    Joined:
    Nov 5, 2015
    Messages:
    179
    Likes Received:
    72
    AMD here and having issues. 17 fps with DX11, max 24. Was 60+fps with DX9
    CPU i7 920 2.70 Ghz 12GB ram
    Video Card:
    AMD Radeon R9 390 series 8GB GDDR5, updated to the latest recommended AMD drivers 17.4.3.

    I notice under Video Settings in the RF2 launcher, it's still listing DirectX 9.0c (4.09.00.0904)
    Why DX9?
    AMD Radeon R9 390 Series -24 MB
    Why 24 MB? It's 8GB ram video card. Using dxdiag, Device is reporting approx total memory 3816 MB

    Also dxdiag, under System Information it says I have DirectX Version DirectX 11 installed
     
    BlackGoku and gRaider like this.
  5. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    People with nvidia a re also reporting problems. Stop generalizing.
    I am with Nvidia and I lost 40% fps and full screen doesn't work for me It doesn't scale.
     
    Rui Santos likes this.
  6. Christos Segkounas

    Christos Segkounas Registered

    Joined:
    Feb 14, 2017
    Messages:
    424
    Likes Received:
    378
    Massive FPS drop here as well.
    From 80+ down to 25-35 FPS.
    Post processing set to "none".
    Also the UI is too bright,for example in the car "tuning" menu the "back" button becomes impossible to see unless you accidentally mouse over it and it gets highlighted.
    The new font makes some information in the car settings that has very small letters difficult to read, almost corrupted.
    Of course many mods have gone broken, like my Apex GT 3 mod but I expect the modders to fix these soon enough.
     
  7. Yugo

    Yugo Registered

    Joined:
    Dec 19, 2016
    Messages:
    2
    Likes Received:
    0
    Same problem.
     
  8. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,581
    Likes Received:
    3,859
    I have AMD and 4 days ago I got better FPS in the dx11 beta. I wouldn't read much into it, it's a beta, things change.

    The video settings program is an entirely separate program to the game itself. Its only purpose is to write the config file the game uses. If it hasn't been updated recently (and pretty sure it hasn't) it won't know what dx11 is. Also it reporting wrong video ram isn't an issue. The game itself is what matters.
     
  9. BluesAdam

    BluesAdam Registered

    Joined:
    Apr 18, 2017
    Messages:
    55
    Likes Received:
    31
    They probably did the testing using only nvidia gpu. I don't think they did what PC did.
     
  10. demerzel

    demerzel Registered

    Joined:
    Aug 30, 2015
    Messages:
    197
    Likes Received:
    127
    No, BlackGoku's statement is horseshit. He pulled out from his ass.

    This is not an AMD related issue. People across the board reported back performance issues. Even with i7 with 1080 nvidia.

    https://cdn.discordapp.com/attachments/253557076645773312/308694835848675328/IMG-20170501-WA0012.jpg
    https://cdn.discordapp.com/attachments/253557076645773312/308694277066850304/Cattura.PNG
     
    Rui Santos likes this.
  11. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    286
    Likes Received:
    950
  12. Paulfield

    Paulfield Registered

    Joined:
    Feb 18, 2012
    Messages:
    165
    Likes Received:
    185
    The new open beta stable version in steam works a treat. Full settings 20 x usf2000 on nola 89 fps at race start then up to 117 fps.
    That is everything on max ,except post on medium.
    Multiview at start 61 fps to 102fps.
    i5-7600k/ z270 ausu/ddr4 2133hz/msi gtx 1080
     
  13. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    286
    Likes Received:
    950
    @Paulfield sorry on which steam branch are you?
     
  14. Paulfield

    Paulfield Registered

    Joined:
    Feb 18, 2012
    Messages:
    165
    Likes Received:
    185
    Australia in the drop down menu for beta version there is now another to beta to choose.
     
  15. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    286
    Likes Received:
    950
    @Paulfield that branch is the fallback branch if something bad happens with the latest updates.
    This means it has not received modification from the release on monday
     
    Rui Santos likes this.
  16. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    286
    Likes Received:
    950
    Hi guys i just updated the main build with a performance improvement.
    On my AMD card i had a good improvement in performance, fell free to try it out and let me know whenever you can
     

Share This Page