Detect Plugin load failures

Discussion in 'Plugins' started by stevo.zilik, Oct 21, 2015.

  1. stevo.zilik

    stevo.zilik Registered

    Joined:
    Jan 27, 2013
    Messages:
    34
    Likes Received:
    0
    Hi,

    is there any logs that describe what plugins is rFactor 2 trying to load (say on start of dedicated server), and logs any failures?

    My plugin is not loading on a specific setup and it's difficult to track down why.

    Thanks,
    Stevo
     
  2. cosimo

    cosimo Registered

    Joined:
    Apr 14, 2013
    Messages:
    823
    Likes Received:
    94
    On build 1008 you can go to the Options screen, there is a new "Plugins" tab, you will see which plugins have been loaded and/or which are turned on/off.
    Otherwise, you can start rF2 with "+trace=10" option (this is done through the launcher, "cog" icon, in the "Command line interface parameters").
    A log file will be produced in the Log folder, and a trace of plugins being loaded will be there.
     
  3. Wawotsch

    Wawotsch Registered

    Joined:
    Jan 19, 2012
    Messages:
    9
    Likes Received:
    1
    Seems I have a similar problem: my plugin is loading fine on one computer, and rejected on the other (same Windows and rF2 versions). Trace 10 is quite concise: Could not load plugin. Any way to get more information?
     
  4. Wawotsch

    Wawotsch Registered

    Joined:
    Jan 19, 2012
    Messages:
    9
    Likes Received:
    1
    Found the reason, finally: I use VS2015 now, and even the small plugin needs vcredist2015 installed to work.
     

Share This Page