[REL] Delta Best plugin for rFactor 2

Discussion in 'Other' started by cosimo, Apr 20, 2014.

  1. cosimo

    cosimo Registered

    Joined:
    Apr 14, 2013
    Messages:
    824
    Likes Received:
    96
    Yes, I believe one should not easily dismiss the usefulness of the bar.
    It tells you exactly where you are losing time.

    The time text is also colored, but color there has a different meaning, telling you if up to that moment you are being faster than your session best lap time or not.
    It's another bit of information that adds value to the plugin concept.
     
  2. cosimo

    cosimo Registered

    Joined:
    Apr 14, 2013
    Messages:
    824
    Likes Received:
    96
    v9 is released! First post updated.

    I think this will end up being the final release, if no bad bugs come up.
    I really want to start working on the race engineer plugin now :)
     
  3. John.Persson

    John.Persson Registered

    Joined:
    Oct 17, 2011
    Messages:
    944
    Likes Received:
    12
    Will you clean it up and try to optimize it? Just curious, remember you stating it was a bit messy coded :)

    I love the work!
     
  4. cosimo

    cosimo Registered

    Joined:
    Apr 14, 2013
    Messages:
    824
    Likes Received:
    96
    I cleaned up quite a lot from then and made sure the code is simpler and performs well.
     
  5. ViSo

    ViSo Registered

    Joined:
    Feb 25, 2013
    Messages:
    316
    Likes Received:
    0
    Wow, thats incredible, many thanks !!

    Enviado desde mi Note 3 con tapatalk
     
  6. GauchoRS

    GauchoRS Registered

    Joined:
    Nov 23, 2011
    Messages:
    471
    Likes Received:
    9
    really fantastic ! I wonder, how I could have driven without this plugin ! Thats awesome.

    Something I noticed. The best lap from practice and qualify is kept for race. Esp. in qualy I have less fuel and special setup settings to achive the best lap time. But in race configuration the setup normaly is different. So laptimes will be different as well.

    I would suggest a ``reset`` function to start a (race) session with a new best lap. Let the driver decide, if he want to keep older session best lap times.
     
  7. WiZPER

    WiZPER Member

    Joined:
    Oct 5, 2010
    Messages:
    1,521
    Likes Received:
    186
    As a team manager I'd love to be able for my drivers to share laps, so you would know exactly where you were loosing time compared to your team mates lap - can a delta-lap be saved/shared somehow ?

    Nice work btw! :)
     
  8. cosimo

    cosimo Registered

    Joined:
    Apr 14, 2013
    Messages:
    824
    Likes Received:
    96
    It certainly can, but that functionality must be programmed :)
     
  9. speed1

    speed1 Banned

    Joined:
    Jul 26, 2012
    Messages:
    1,858
    Likes Received:
    0
    Thank you, I've been missing the whole time something, seems I've gotten used to over the years, since all singleplayer, also on consoles, offered this option. :)
     
  10. WiZPER

    WiZPER Member

    Joined:
    Oct 5, 2010
    Messages:
    1,521
    Likes Received:
    186
    That was kinda my point ;)
     
  11. petibonome

    petibonome Registered

    Joined:
    Feb 21, 2014
    Messages:
    28
    Likes Received:
    0
    Thank you VERY much for this work :)
     
  12. Marc Collins

    Marc Collins Registered

    Joined:
    Jan 11, 2012
    Messages:
    3,168
    Likes Received:
    162
    cosimo--thanks so much for this plugin! It is one of the best features in iRacing so great to have it over here.

    I can't seem to get mine to display, though. Yours is the only plugin I have installed. I now get the plugin icon in the top left corner. I get the initial message telling me that it is available with Ctrl+D (I left all settings at default in my revised .ini file). But when I press Ctrl+d (or Ctrl+D) I get nothing??? Ctrl+f for frame rate display works fine. What could I be doing wrong?
     
    Last edited by a moderator: May 9, 2014
  13. Mr.Thor

    Mr.Thor Registered

    Joined:
    May 25, 2013
    Messages:
    239
    Likes Received:
    30
    Dont press Ctrl+d after Start. It is already started. Drive some laps and you will See it.
     
  14. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,552
    Likes Received:
    1,873
    Many thanks for this plug in, works a treat :)
     
  15. Marc Collins

    Marc Collins Registered

    Joined:
    Jan 11, 2012
    Messages:
    3,168
    Likes Received:
    162
    Doh! Thanks! It works beautifully!

    I love the transparent background implementation, too (rather than a defined and coloured rectangular strip).
     
  16. McFlex

    McFlex Registered

    Joined:
    Feb 23, 2012
    Messages:
    751
    Likes Received:
    191
    Bug? Here i have one i think :D

    [​IMG]

    I don't have a moving bar but a moving time :D I tried several settings with and without .ini file.

    Any idea?
     
  17. cosimo

    cosimo Registered

    Joined:
    Apr 14, 2013
    Messages:
    824
    Likes Received:
    96
    If you disable the bar (Enabled=0 in the [Bar] section in the .ini file) then the time is supposed to be centered.
    Otherwise, the time will move around, like in the iRacing version.

    From the screenshot, it looks like you disabled the bar?
    Any chance you could upload a short video?

    Does it happen all the time or just in some specific conditions?

    Anyway, bugs are indeed possible :)
     
  18. McFlex

    McFlex Registered

    Joined:
    Feb 23, 2012
    Messages:
    751
    Likes Received:
    191
    Hi. It happens all the time. I enabled the bar i the .ini but maybe i did something wrong. Maybe wrong location? I put it in the plugin folder. Will the numbers or the bar move? A video would be a little bit of work. But you would not see anything else than the moving numbers.

    Can you post an example of a working .ini file please?
     
  19. Mr.Thor

    Mr.Thor Registered

    Joined:
    May 25, 2013
    Messages:
    239
    Likes Received:
    30
    hi cosimo, i am using norton internet security. all version until v8 worked fine for me. but now with v9 i get a message from nis that your dll contains: "suspicious.Cloud.7.F" ... i don't think nis is true! i googled and found some pages, where nis got a false positive of that suspicious cloud thing...
    what did you change in your great plugin since v8? ;-)
     
  20. Mr.Thor

    Mr.Thor Registered

    Joined:
    May 25, 2013
    Messages:
    239
    Likes Received:
    30
    did you also copy the png file to your plugins folder? maybe that one is missing, don't know what happens if it is not there?!
     

Share This Page