Crashing when assigning wheel controls

Discussion in 'Technical & Support' started by darren boulton, Jul 7, 2017.

  1. darren boulton

    darren boulton Registered

    Joined:
    May 2, 2017
    Messages:
    7
    Likes Received:
    1
    Every time I try to assign my wheel control (turning left/right) the game crashes.

    I have tried multiple installs and two different wheels still the fault happens, when loading preset profiles left is highlighted in red and I am unable to assign without crashing the game.

    All my drivers/firmware are up to date and I've tried every possible USB combination that I can think of, I also tried both DX9 and DX11 which made no difference

    Any advice will be greatly appreciated as I am now getting very frustrated.
     
  2. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,996
    Likes Received:
    1,341
    Some ideas...
    First thing to try is to "Verify Integrity of Game Files" in Steam. If you don't know how... in your Steam library, right click rFactor2, select Properties then select the Local Files tab.
    See if that finds any missing files and fixes your problems, if not.
    Disconnect and turn off anything to do with VR.
    Disconnect all USB controllers except of coarse keyboard and mouse.
    Delete the Controller.JSON found in "wherever your Steam is installed\steamapps\common\rFactor 2\UserData\player".
    Start rF2 and load the keyboard profile.
    If that works then shut down rF2 and plug in one controller, wheel first into a USB 2 port, some controllers don't like USB 3.
    Test that and continue on.
    I've also heard of issues involving Steam Big Picture, don't know anything about that as I've never used it.
    I have 6 USB controllers working, from 5 different vendors so there is nothing wrong on the rFactor 2 side of things.
    Good luck. :cool:
     

Share This Page