[SOLVED] Cannot manually start engine

Discussion in 'Technical & Support' started by Mark Krus, Feb 15, 2021.

  1. Mark Krus

    Mark Krus Registered

    Joined:
    Sep 15, 2020
    Messages:
    19
    Likes Received:
    3
    I assign the starter and ignition, but instead of the ignition working it changes the vehicle status or pit status display (whatever is up at the time) to say 'Vehicle Status Unavailable' and it toggles back and forth between that and whatever display panel I had up and DOES NOT start my engine. This happens in all cars. I have tried keys and buttons on my wheel, nothing works. So at the moment I just cannot start my engine if I kill it for instance.
     
    Last edited: Feb 16, 2021
  2. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,720
    Likes Received:
    1,367
    Which car? Some can't be started unless in the pitlane. Also, make sure you push the clutch in.
     
  3. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,587
    Likes Received:
    2,535
    The digital display 'should' only work once the ignition(electrics) button is pressed. Then you can use the starter button. If you replaced your player.json file recently it may have reset the default where the engine is magically started without any input from you. If you have the car in gear without the clutch being pressed, it will stall.
    dig into the player.json and look for these lines:
    "Start Engine":True,
    "Start Engine#":"Whether to automatically start engine",
    Change the True to false. Make sure you don't accidentally erase the : or the ,
     
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,440
    Likes Received:
    4,458
    Ignition is not the same as Starter.
     
  5. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,587
    Likes Received:
    2,535
    That is why I mentioned the ignition first.
     
  6. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,440
    Likes Received:
    4,458
    I was responding to the first post.
     
  7. Mark Krus

    Mark Krus Registered

    Joined:
    Sep 15, 2020
    Messages:
    19
    Likes Received:
    3
    I had already tried both true and false values for start engine in the player.json file. If it's false, it means I can't drive any car because I can't start them. This happens in neutral, clutch fully in, in the pit lane, all cars. I just took out the Corvette C6 road car to confirm (confirmed, I couldn't start it) and something I noticed was that it toggles the windshield display on and off (as well as the other display and instead of starting my car).

    The starter does seemingly nothing (as it is just turning on your ability to use ignition I believe), and it is the ignition that is toggling my displays.
     
    Last edited: Feb 16, 2021
  8. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,440
    Likes Received:
    4,458
    Other way round.

    You need ignition (power, hence displays) first. This is always on unless you turn it off, normally.

    THEN you use Starter to start the engine.

    *and full sympathy here: I don't know why they called it ignition. It's always confusing.
     
  9. Mark Krus

    Mark Krus Registered

    Joined:
    Sep 15, 2020
    Messages:
    19
    Likes Received:
    3
    Oh my gosh this was my problem. I had tried starter, ignition, starter, ignition and I thought it wasn't working, but I think I was cutting ignition before the engine started.
     
  10. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,587
    Likes Received:
    2,535
    And that is WHY I mentioned ignition first and even gave the Euro term as well. ;)
     
  11. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,440
    Likes Received:
    4,458
    It's ok, you can have my points for this one.
     
    davehenrie likes this.

Share This Page