Cadillac DPi 1.15 update

Discussion in 'Bug Reports' started by Team Dano, Nov 30, 2023.

  1. Team Dano

    Team Dano Registered

    Joined:
    Dec 27, 2010
    Messages:
    67
    Likes Received:
    24
    After todays update, when I chose a race only using the Cadillac DPi's, I get a mixed ai field of DPi's and Cadillac Hypercars. When I chose a race only using the Hypercars, I still get a mixed ai field of DPi's and Hypercars. Also, I lost all my setups and the ai DPi's and Hypercars still don't have enough top gear at Lemans.
     
    Last edited: Nov 30, 2023
  2. Coutie

    Coutie Moderator Staff Member

    Joined:
    Oct 5, 2010
    Messages:
    3,805
    Likes Received:
    2,262
    Can you show a screenshot of the race setup? They are different classes, so it shouldn't happen. That would also be why your setup doesn't show, you can toggle that in the setup screen.
     
  3. Coutie

    Coutie Moderator Staff Member

    Joined:
    Oct 5, 2010
    Messages:
    3,805
    Likes Received:
    2,262
    Just FYI, the skins are the exact same on both Hypercar and DPi.
     
  4. Team Dano

    Team Dano Registered

    Joined:
    Dec 27, 2010
    Messages:
    67
    Likes Received:
    24
    I know the skins are the same, but on the timing screen I get mixed classes of ai Cadilacs when I only want Hypercars or only DPi's.
     
  5. Bernat

    Bernat Registered

    Joined:
    Jun 15, 2020
    Messages:
    785
    Likes Received:
    612
    It's working well for me. Are you sure there are no other classes selected? Or maybe some other mod is affecting the selection?
     
  6. atomed

    atomed Member

    Joined:
    Jul 9, 2019
    Messages:
    1,344
    Likes Received:
    1,359
  7. Team Dano

    Team Dano Registered

    Joined:
    Dec 27, 2010
    Messages:
    67
    Likes Received:
    24
    I manually select opponents from the DPi and GTE classes (all Studio357 content), that's when the bug shows up.
     
  8. Coutie

    Coutie Moderator Staff Member

    Joined:
    Oct 5, 2010
    Messages:
    3,805
    Likes Received:
    2,262
    There are two new classes Cadillac_DPi and Cadillac_HYP, so if you select both, that's the only way both should show.
     
  9. Team Dano

    Team Dano Registered

    Joined:
    Dec 27, 2010
    Messages:
    67
    Likes Received:
    24
    I'm not selecting both, just one Cadillac class and GTE class, try it you'll see.
     
  10. Coutie

    Coutie Moderator Staff Member

    Joined:
    Oct 5, 2010
    Messages:
    3,805
    Likes Received:
    2,262
    I did yesterday, it only showed DPi for me.
     
  11. Team Dano

    Team Dano Registered

    Joined:
    Dec 27, 2010
    Messages:
    67
    Likes Received:
    24
    It seems to only happen when opponents are selected manually. If you let the game select opponents 1 class race only, it seems to work.
     
  12. atomed

    atomed Member

    Joined:
    Jul 9, 2019
    Messages:
    1,344
    Likes Received:
    1,359
    Team Dano likes this.
  13. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    758
    Likes Received:
    246
    Hello, i looked on the veh files of the official Cadillac Dpi 1.15. We can see two classes :
    Classes="Cadillac_HYP" and Classes="Cadillac_DPi"

    If you only want Cadillac_DPi, in theory, you need to select only Cadillac_Dpi when setting the server/event and only this category like > Capture.PNG

    But i think there is a bug ... If it randomly selects the #06 car, this car has the two classes, because there are two cars with the same #06 description. So you can have a Cadillac_HYP even if you selected only Cadillac_DPi.

    Another mod probably wrongly done with two cars with same description, which should not happen, imo, but software probably only uses "Description" and not real "Classes" when adding an Ai ... causing what you see here.

    The only way to solve that is to make an upgrade of the mod, and remove all HYPercars if you don't want them at all. Or "in game", single, kick the wrong classes and add other ones until you get what you want ...

    At some point you will only have Cadillac_DPi.

    And you can easilly force the same class of all skins/car in one mod by using the Upgrade.ini and adding at the top :
    DisplayClassOverride="Cadillac_DPi"

    (even veh with Cadillac_HYP will appear as Cadillac_DPi, which is probably only a string to display and nothing really differentiating it to the others unless upgrade.ini HYP is different).
     

    Attached Files:

  14. Team Dano

    Team Dano Registered

    Joined:
    Dec 27, 2010
    Messages:
    67
    Likes Received:
    24
    I only use Studio357 cars but recently added the Advanced Simulation Ferrari/Porche Hypercars. I uninstalled the mods just to test and they don't seem to interfere with adding opponents. This appears to be a Rfactor 2 bug.
     
    DanRZ likes this.
  15. Coutie

    Coutie Moderator Staff Member

    Joined:
    Oct 5, 2010
    Messages:
    3,805
    Likes Received:
    2,262
    It's probably the team names, I just left them the same to avoid unwanted issues, next update I can modify the names to hopefully solve the problem.
     
    Team Dano likes this.
  16. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    758
    Likes Received:
    246
    Maybe try also to use different Description for each car ... There are Two #06 ...
     
    Team Dano likes this.
  17. Miquel Ramos

    Miquel Ramos Registered

    Joined:
    Sep 21, 2013
    Messages:
    94
    Likes Received:
    100
    @Coutie Aero packages on Chassis page setup don't work. There are several options for front or rear: LDF, MDF, HDF, HDF +10 gurney.... But with different aero, you get same result and same top speed.
    I remember an issue that you can not save your setup with an aero package, always saves HDF +10mm, but I think in the past some aeros worked, or maybe is only for Hypercar version. Could you ask developers?
     
  18. Coutie

    Coutie Moderator Staff Member

    Joined:
    Oct 5, 2010
    Messages:
    3,805
    Likes Received:
    2,262
    I'm pretty sure this has always been an issue, I think it was the first one I logged when I started working here. I can ask about it, but it won't be looked at until lmu is finished.
     

Share This Page