SOLVED Black rain drops

Discussion in 'Bug Reports' started by DanRZ, Jan 31, 2022.

  1. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    215
    Likes Received:
    50
    Hello, when in rain, i have black rain drops in my windshiled :

    rFactor2 2022-02-01 00-37-05-43.jpg

    I tried modifying the rain parameters ans shaders but still black rain drops.
    Is it normal ? Or what parameter can i change ?

    If somebody knows ...
    Thanks.
     
    Last edited: Feb 1, 2022
  2. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,786
    Likes Received:
    1,571
    Is the Window Texture painted in black or another dark Color?
    If yes, use white Color.
    If that doesn't help, check the Mapping (is the 4th Texture Slot mapped to Channel 2 and all other to Channel 1?) and also the Material Settings, especially Ambient and Specular Colors.
    And you can also check the Vertex Painting, if the Vertex Illumination and not the Vertex Color is painted with the correct Colors for the Different Windows.
     
  3. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    215
    Likes Received:
    50
    Sorry, i don't understand, i don't have those parameters and channels ...
    But the drops are clearly black.
     
  4. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,786
    Likes Received:
    1,571
    To setup the mentioned Things properly, you have to use 3DSMax.
    Maybe it also can be done with Blender, but i don't use Blender, so i can not judge it.
    Does it happen with all Cars?
    If not, with which Car do you have that Problem?
     
  5. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    215
    Likes Received:
    50
    Hello. All cars have this issue.
    I'm not a modder i just want to know if those black drops are linked to some parameter i can change "in game".
     
  6. Alex Sawczuk

    Alex Sawczuk Registered Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    724
    Likes Received:
    767
    Most likely it is due to a bug in the track. Does it happen on Studio 397 tracks?
     
    redapg likes this.
  7. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    215
    Likes Received:
    50
    Thanks, good point, i only tested it on laguna seca which is not an official map ...
     
  8. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    215
    Likes Received:
    50
    You were right, looks like it's a track issue of Laguna Seca. Is it possible to correct that without modifying the map ?
     
  9. Coutie

    Coutie Moderator Staff Member

    Joined:
    Oct 5, 2010
    Messages:
    3,268
    Likes Received:
    1,725
    Probably not, if I'm not mistaken, that track is pretty old. Your best bet is to contact the person who made it.
     
    DanRZ likes this.
  10. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    215
    Likes Received:
    50
    Just did it ...
     
  11. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    215
    Likes Received:
    50
    Not the track, everything is okay with another cars.
    Looks like it's a bug/feature of the cayman mod car ... i asked on its post here.
     
  12. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,786
    Likes Received:
    1,571
    I maybe have the Solution for the Problem, because a User reported it for one of our (SMMG) Mods.
    And the Problem with our Car is, that the Windscreen Inside Shader doesn't have the Live Mapper activated.
    We did make it in that Way, also with other Mods, to avoid unwanted Windscreen Reflections in Cockpit View and it worked properly in the Past.
    So the "Bug" is probably caused by the latest Rain related Game Code Modifications.
     
  13. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    215
    Likes Received:
    50
    It remains playable with those black drops, but with what you said, maybe we can hope some correction ...
     
  14. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,786
    Likes Received:
    1,571
    Hopefully @Frederick Alonso did notice your Post. :)
     
    Frederick Alonso likes this.
  15. Frederick Alonso

    Frederick Alonso Registered

    Joined:
    May 29, 2020
    Messages:
    327
    Likes Received:
    2,025
    I investegated the issue but it seems to be track related. On all official tracks I have no issues. All cars I did also have the right colors on the window maps, so front, left, right and rear also respond to gravity.


    [​IMG]
     
  16. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    215
    Likes Received:
    50
    Hello, i really see more and more people having this same issue on streams.
    Are there some kind of action to refresh things like shaders and get back white translucid water effects ?
     
  17. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,786
    Likes Received:
    1,571
    As we have talked about it in other Threads already, the Problem is caused by the Reflection Mapper Setup of Car Windows and/or Tracks (if there are no Entries in the scn File).
    So both have to be checked, when the black Drops appear.
     
  18. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    215
    Likes Received:
    50
    So i can't do anything and need to wait for S397 or modders to solve the issue ...
     
  19. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,786
    Likes Received:
    1,571
    You can create your own private Version or an own Update for a Car or Track, if you have the needed Knowledge to do it.
    If not, inform the Creators of the Track/Car, that they fix it.
    I would suggest to start with the Tracks, if a Car works properly on latest S397 Tracks.
    In most of the Cases, fixing the Track will solve the Problem already.
     
  20. Nick9320

    Nick9320 Registered

    Joined:
    Feb 8, 2012
    Messages:
    267
    Likes Received:
    1,977
    Try to play with normals or polys
    Seems like you need to reverse normals to make it shine from the inside and not from outside
     

Share This Page