Always Check your Video Settings

Discussion in 'Technical & Support' started by davehenrie, Oct 17, 2019.

  1. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    2,390
    Likes Received:
    1,424
    rF2 does not always save the video card information correctly and defaults back to a selection of AUTO which may not perform as well as your dedicated video card.
    So follow these arrows EVERY FREAKIN' TIME you boot up rF2 to ensure you are getting the correct video choice.
    1. Choose the Gear Icon.
    2. Then the Video Settings button.
    3. Then look at the name of the video card shown by the arrow to the far right.
    upload_2019-10-16_16-50-36.png
     
    Last edited: Oct 17, 2019
    2ndLastJedi and JuanP006 like this.
  2. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    246
    Likes Received:
    939
    I do it without thinking about it's just habit now. I found it only changes to auto when windows updates, new video drivers installed or some sort of steam update. I can't understand all the whinging about it, it's so easy to do, just three mouse button presses, done.
     
  3. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,596
    Likes Received:
    987
    I do it every time also and it is always on Auto if my PC has been restarted. No really an issue but just have to remember every time I load rF2.
     
  4. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,608
    Likes Received:
    1,108
    @davehenrie
    You might like too add to your post that there is no need to worry about the info such as the Video Driver and Windows versions listed being incorrect.
     
  5. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,118
    Likes Received:
    1,238
    There is no reason to do this procedure every time. Actually you can check what content is saved in the file \SteamApps\common\rFactor 2\UserData\Config_DX11.ini. If parameters inside this text file change by themselves between the runs, then it would prove something is actually changing. I don't think that is the case, so this is a redundant exercise.
     
  6. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    2,390
    Likes Received:
    1,424
    It is true the information does not always change. But it is random enough that I just do it, as stated above, out of habit. And I reminded of this by a new user not being able to start the full sim when the demo worked fine. Just another page to have on standby when somebody breaks part of rF2.
     
  7. Seven Smiles

    Seven Smiles Registered

    Joined:
    Oct 5, 2010
    Messages:
    720
    Likes Received:
    765
    FWIW I have 3 versions of config_DX11.ini saved so I can switch between my 2 monitors or VR. Each time I start rFactor I have a batch file which copies the appropriate one.
     
  8. Filip

    Filip Registered

    Joined:
    Feb 9, 2017
    Messages:
    885
    Likes Received:
    687
    If setting defaults to AUTO doesn't that mean it will use whatever is selected in Nvidia control panel as preffered gpu for rfactor2.exe?
    If that is the case one could set correct gpu in nvidia panel once and don't care for rf2 video setting.
    Can anybody confirm this?
     
    lagg likes this.
  9. sherpa25

    sherpa25 Registered

    Joined:
    May 14, 2015
    Messages:
    216
    Likes Received:
    23
    Can this be resolved, pls? Recently back to triples (60Hz), using surround, and settings are never saved. Running borderless because of Simhub overlays. Maybe someone can suggest how to address the issue as I have to keep entering values: At startup of Video Settings: Resolution is blank, Multiview is unchecked, Refresh Rate is at 50Hz.
     
  10. sherpa25

    sherpa25 Registered

    Joined:
    May 14, 2015
    Messages:
    216
    Likes Received:
    23
    Where is the 'Multiview' option saved, as I don't see it in the Config_DX11.ini file?
     
  11. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,608
    Likes Received:
    1,108
    Here is my DX11 config using triples.
    The line Subviews=2 is the multiview.
    Your 2 side monitors are the subviews
    Make sure your DX11config is not set to "read-only" in it's properties.
    Also, do you use the in game triple screen setup app?
    If you haven't you should.
    My settings are always saved but I do check the proper video card is selected as I have two cards.
    Code:
    //[[gMa1.002f (c)2016    ]] [[            ]]
    [COMPONENTS]
    LanguagesFile=GAME.DIC
    ObjDetail=3
    TexDetail=2
    VideoGUID=00001B80-0000-0000-0000-000000000000
    VideoDriver=0
    VideoMode=51
    VrSettings=0
    EPostProcessingSettings=1
    VideoRefresh=1
    WindowedMode=0
    Borderless=0
    RunBenchmarks=0
    FSAA=34
    VSync=0
    UseFXAA=0
    ShaderLevel=0
    SubViews=2
    UseSubViewParams=1
    WorkaroundFlags=0
    ViewParams=(0.528, 0.297, 0.595, 60.000, 0.006) // screen width (m), screen height (m), eye distance (m), side angle (deg), bezel gap (m)
    LeftView=(0.528, 0.297, 0.595, 60.000, 0.006)
    RightView=(0.528, 0.297, 0.595, 60.000, 0.006)
    PreferredGPU=38917
    WidescreenUI=1
    WidescreenUIWidth=5760
    WidescreenHUD=1
    CustomVidRes=(0, 0)
    VRMirrorWindowVidRes=(1920, 1080)
    VRUIScale=(1.000, 1.000, 1.000)
    MinimumVidRes=(800, 600)
    MaximumVidRes=(99999, 99999)
    
    [INSTALL]
    InstallFrom=
    InstallTo=
    
    [AUTOLAUNCH]
    Mode=Off
    LaunchTime=600
    
    [VERSION]
    Version=-1.000000
    
     

Share This Page