[SOLVED] AI still not using custom skins.

Discussion in 'Bug Reports' started by Highlandwalker, Feb 26, 2019.

  1. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    365
    Likes Received:
    1,161
    The AI GT cars will still not use custom skins. They show in car list and showroom, and you can drive them but the AI still does not use them when you go to track to race. Hope this gets sorted soon, very frustrating.
     
  2. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,249
    Likes Received:
    1,829
    agree +1
     
    mr.Sw1tchblade and Bostrom like this.
  3. Bostrom

    Bostrom Registered

    Joined:
    Jul 1, 2018
    Messages:
    94
    Likes Received:
    435
    That's really annoying. :mad:
     
    Rogger likes this.
  4. bears

    bears Registered

    Joined:
    Apr 4, 2015
    Messages:
    393
    Likes Received:
    1,432
    Yes very annoying
     
  5. Adnanso

    Adnanso Registered

    Joined:
    Jul 25, 2017
    Messages:
    2
    Likes Received:
    0
  6. bhendrik

    bhendrik Registered

    Joined:
    Mar 22, 2014
    Messages:
    199
    Likes Received:
    81
    agree
     
  7. Bostrom

    Bostrom Registered

    Joined:
    Jul 1, 2018
    Messages:
    94
    Likes Received:
    435
    Has not changed after the last update. (Build ID 3646315)

    I put together an IMSA 2018 (25 vehicles) Season in the vehicle selection. If I now hire 24 AI opponents and go on the track all AI vehicles have the same skins. The custom skins are simply ignored.

    But if I go with 0 KI opponents on the track and then load the opponent individually by hand, the custom skins of the individual vehicles work properly.

    This mistake exists already since the beginning of the year and annoys totally ! ! ! :mad:
     
    Rogger likes this.
  8. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    137
    Likes Received:
    52
    Can you add AI in single player or do I have to use a dedicated server?
    If I can, how to do that?

    edit, and +1 on the issue...
     
  9. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,249
    Likes Received:
    1,829
    You can only get the new PBR skins in the game on AI cars IF you add them individually once you are at the track. When you view the defualt menu, at the lower right is an option add or delete There also is a small arrow pointing to the left => Click on that arrow and you can choose which cars to add from your list set up in the menu before loading the track.
     
  10. bhendrik

    bhendrik Registered

    Joined:
    Mar 22, 2014
    Messages:
    199
    Likes Received:
    81
    Solution for skins not working. Go to tuning page in the garage. Write down the veh name of the first car ( original skin when the gt3 cars first were released) for example the white, black, red Porsche. Replace the veh name In the rcd file from the skin you want with the veh name of the original car. They will now show up in game and a1 will drive theme when you ad ai manualy. Repeat this for next skin and so on. Takes some time. Good luck
     
  11. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    137
    Likes Received:
    52
    Not sure how I missed the AI menu so thank you for that tip @davehe, but the whole point @bhendrik is that this was not needed a short while ago, and it work ok for other cars like the Mclaren M23 and custom skin. Not sure when it stopped working.

    I have also noted I can't install any rfcmp files, they just not visible in the packages handler??
     
  12. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,249
    Likes Received:
    1,829
    It stopped working with the release of the PBR shaders for the three DLC packs. I'm assuming they have tried a couple of what were supposed to be fixes but have found the issue more difficult than expected.
     
    Bostrom likes this.
  13. bhendrik

    bhendrik Registered

    Joined:
    Mar 22, 2014
    Messages:
    199
    Likes Received:
    81
    I know it was not needed a while ago. Let’s hope they get it sorted out soon and this is just a temporary workaround
     
  14. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    365
    Likes Received:
    1,161
    The AI bug seems to be sorted now, my RF2 updated yesterday and the GT3, GTE and Endurance pack AI are now using custom skins on all the cars I have tried so far. Oreca, Aston Martin, Audi, Bentley, Corvette and both BMWs. Hope this info is of help to you all.
     
    F1Aussie and Marcel Offermans like this.
  15. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    137
    Likes Received:
    52
    Have you tried "non PBR" skins, with json fix? When I tried today non of these skin was loaded when I let rF2 select. I can still view and load them manually as mention above. Do you know if I have to create a new json to make these load?
     
  16. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    365
    Likes Received:
    1,161
    If the skin is not using the regions part of the system, the json file is not required, only the dds files for the body and windows etc. I have 45 Oreca skins installed and only one uses the json file because it is using the regions part of the system to get a chrome effect. You don't have to use the regions part of PBR system to paint a car, only required if you want a specific affect on the car, chrome, metal flake etc. Hope this is helpful.
     
  17. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    137
    Likes Received:
    52
    Then I might ask if something has changed before I remove the json added :confused:

    Older skin when the PBR was released you got a bleeding from the base car used in the rcd file. This was fix by using a json where all "colors" was set to "car paint". One could also copy the dds to a _region.dds and you got a similar result even if that gave some effect to the old skin.

    I have a mix of old and new skin and all work perfect in "tuning" menu or if I add them manually on track, not sure if the AI is using new skins and just skipping the old ones :confused:.
     
  18. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    365
    Likes Received:
    1,161
    The Oreca, Corvette and Callaway has not got the bleed problem so the json file fix is not required but the Bentley, Porsche GTE, Mercedes GT3 and McLaren 650 has the bleed problem from the base car, it's a bug in these three cars so the fix with the json file is the only way around the bug. I apologies if I may have misled you about the json file. If you have the latest updates the AI now use custom skins provided the rcd file has the correct veh name. I have found that if the skin in the folder is a single mas file the AI does not use that skin even if it shows in the showroom. I extracted all my skins from the single mas file and just used the dds files and changed the skin line in the rcd file from mas to dds. Hope my explanation is understandable and best of luck
     
    Last edited: Apr 24, 2019
  19. bears

    bears Registered

    Joined:
    Apr 4, 2015
    Messages:
    393
    Likes Received:
    1,432
    That’s some good news highlander I will test it on the weekend this whole skin fiasco has been very disappointing will be good to put it behind us hopefully
     
  20. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    137
    Likes Received:
    52
    Thank you, you might add the Radical to the bleed list as well. I have made all skins into mas files so that would explain the AI not using the skins after all. I would however still consider that being a bug, even if extracting all the files into the skin folder a decent workaround for offline and random AI race. But does that mean the skin will not download correct in multiplayer, maybe :confused::D
     

Share This Page