AI Difficulty locked at 60%

Discussion in 'Technical & Support' started by Michael 1187, Mar 20, 2021.

  1. Michael 1187

    Michael 1187 Registered

    Joined:
    Mar 20, 2021
    Messages:
    3
    Likes Received:
    0
    Hi, I am new here and fairly new to rF2.

    I used to love this game...
    Now after setting the AI Difficulty to 60%, I am unable to restore it to 98%... There seems to be no SAVE option after tweeking the Difficulty settings. All else works fine but the AI drivers are like Snails!

    I have thought about Uninstalling the game and then reinstalling... Might this help???

    Please help me.

    Cheers,
    Mick
     
  2. JamesB

    JamesB Registered

    Joined:
    Dec 28, 2020
    Messages:
    222
    Likes Received:
    147
    There are 2 places where you can set it, one is somewhere in the general settings, will try to add to this when I have the game in front of me, the other is in the session settings under opponents? One will override the other although I can't remember which way round it is. So check that both these have the appropriate number you are after and you should then be ok.
     
  3. Michael 1187

    Michael 1187 Registered

    Joined:
    Mar 20, 2021
    Messages:
    3
    Likes Received:
    0
    Thanks for your reply JamesB,
    Adjusting these settings till the cows come home but still the same. Game has AI Locked at 60%
    I am at a loss with what to do.
    There seem to be different versions of rFactor 2 from what I have read on the forums. I got mine through Steam.
    The UI is coloured orangy red, pale blue an grey... is your the same? Very strange indeed
    Mick.
     
  4. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,252
    Likes Received:
    2,368
    What car and track? Is "All Tracks & Cars" selected above the listing for which car or track has been chosen? The Web based UI described by you is the new UI. You can check in Steam under the beta tab. At the Library screen, click on rFactor2 and then choose Properties then betas. The latest non-beta version is selected when NONE is in the selection box. Release Candidate is a testing Beta, Old UI is a verified version. Using the Deprecated version takes you back to the old brown UI. (some newer features will not work with this version)
     
    Last edited: Mar 22, 2021
  5. Michael 1187

    Michael 1187 Registered

    Joined:
    Mar 20, 2021
    Messages:
    3
    Likes Received:
    0
    Thanks Davehemrie, thanks for your reply, however that all does not address the problem I am having with not being able to reset the "AI Difficulty".
    Any ideas? I can adjust the slider, but when i reenter the gane it is back to 60%. Which is very anoying.
    Would uninstalling the game and reinstalling it fix things?
    Cheers,
    Mick
     
  6. JamesB

    JamesB Registered

    Joined:
    Dec 28, 2020
    Messages:
    222
    Likes Received:
    147
    Have you found BOTH places where you can adjust it? Did you check that they are both set to the same value?
     
  7. Type88B

    Type88B Registered

    Joined:
    May 4, 2019
    Messages:
    6
    Likes Received:
    5
    Hi, I've the same problem: with the new UI I can't modify the AI strenght and AI aggression.

    I've tried to modify them in general settings and in race settings (same values), but when I start the race the AI settings are back to the "locked" values and this is confirmed when I check the main settings menu after the race.

    I've also tried to modify the player.json, but when I launched rF2 again, the AI settings are back to the previous "locked" ones.

    Last rF2 build with new UI, no RC or beta.

    Thanks
     
  8. JamesB

    JamesB Registered

    Joined:
    Dec 28, 2020
    Messages:
    222
    Likes Received:
    147
    Ah, that was going to be the next suggestion, to modify the json file, but if that does not work, I don't know.
     
  9. Type88B

    Type88B Registered

    Joined:
    May 4, 2019
    Messages:
    6
    Likes Received:
    5
    After some testing, it seems I have found a solution.
    It appears that setting the AI to 100 resets the problem.
    Steps to try:
    - set AI to 100
    - enter a race
    - exit the race and set the desired level
    Now when you exit rF2 and then restart it you should be able to find your latest AI settings.
     
    davehenrie likes this.
  10. MB99

    MB99 Registered

    Joined:
    Feb 7, 2021
    Messages:
    7
    Likes Received:
    0
    I have the same problem.. locked at 120%… which means I can only get a race at Donington… everywhere else I race the AI is CRAZY fast.. impossible late braking.. I have tried all the tips on this thread.. to no avail..
    I have a server which has th AI set at 100% and it’s fine.. but I can’t use the rest of RFactor… SO ANNOYING… can anyone help?
     

Share This Page