windows 10 update

Discussion in 'Technical & Support' started by fragghetto, Mar 12, 2018.

Tags:
  1. fragghetto

    fragghetto Registered

    Joined:
    Feb 24, 2017
    Messages:
    6
    Likes Received:
    0
    Hi,
    after updating to Win 10 Home, I cannot lauch the game.
    Actually the rFactor launcher seems to work properly, but after launching the game (single or MP) after some seconds of the rFacor loading splash screen, I'm prompt back to the launcher, no errors, no messages from sys, nothing at all.
    I'm not running any antivirus while gaming.

    Inter i7 - 4790 CPU, 16 B mem, GeForce GTX 770, DX 12.0, driver 391.01 (latest)
    Please help :)
     
  2. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    598
    Likes Received:
    201
    install all the Redistributables in the rFactor2/Support/Runtime folder
     
  3. fragghetto

    fragghetto Registered

    Joined:
    Feb 24, 2017
    Messages:
    6
    Likes Received:
    0
    Hi ceecee,
    I reinstall all :
    vcredist_2012_x64
    vcredist_2012_x86
    vcredist_2013_x64
    vcredist_2013_x86

    ...but the problem is still there, after launching game it returns to launcher..
     
  4. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    598
    Likes Received:
    201
    Verify your rFactor 2 installation files in Steam Launcher, then try launch the game.
    Right click rFactor 2 in Steam, select Properties, select Local Files tab and verify installation files.
    If still not successful then check your video settings in rFactor 2 Launcher and run trace=5 in Command Line Interface Parameters.
    This will produce a trace file in the LOG folder, post this.

    upload_2018-3-13_8-7-32.png
     
    Last edited: Mar 13, 2018
  5. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,909
    Likes Received:
    1,160
    If you upgraded your windows 7/8 to 10 your best option is to back up your data, format, and install windows 10 clean :D

    Ok, I'm half joking, but you might want to do a clean install of your graphics drivers at least (using DDU) as things might get messed up during the upgrade.
     
    ceecee likes this.
  6. fragghetto

    fragghetto Registered

    Joined:
    Feb 24, 2017
    Messages:
    6
    Likes Received:
    0
    I just got the Content Inventory, and not a sort of video settings log.
    I'm doing something wrong or is that one you mean?
    thx
     
  7. fragghetto

    fragghetto Registered

    Joined:
    Feb 24, 2017
    Messages:
    6
    Likes Received:
    0
    Thx, I'm gonna try this.
     
  8. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    598
    Likes Received:
    201
    Lazza has a good point !
    Re read my bold text above, there are two Launchers, one from Steam, one from rFactor2
    Also check if you have opted out of Betas

    upload_2018-3-13_8-26-17.png
     
  9. fragghetto

    fragghetto Registered

    Joined:
    Feb 24, 2017
    Messages:
    6
    Likes Received:
    0
    Hi ceecee & Lazza, thx for helping.
    I'll vanilla install the drivers now, hope it helps.
    Find as attachem,ent the windows crash report of rFactor, perhaps it helps.
     

    Attached Files:

  10. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    598
    Likes Received:
    201
    Using DDU is one option, the Windows log does not tell much besides there is still quite a bit of Windows 8 code on your system.
    Using trace=5 will tell you more about the reason for rFactor 2 crashing.
    Lazza gave the best advice and to do a fresh clean Windows 10 installation.
    If you have a Windows 7 or 8 Product Key (sometimes a sticker on the side of the desktop) then the best option would be to backup your data and install Windows 10 clean using that key.
    You can download a W10 installation onto a USB stick (at least 8GB) from here :
    https://www.microsoft.com/en-us/software-download/windows10.
    If you need a list of the presently installed software then run Belarc Advisor and save the HTML (you might get the installed Windows Product key here as well)
    http://www.belarc.com/Programs/advisorinstaller.exe
     
  11. fragghetto

    fragghetto Registered

    Joined:
    Feb 24, 2017
    Messages:
    6
    Likes Received:
    0
    Hi guys,
    here is my trace log, perhaps you can see something interesting...
     

    Attached Files:

  12. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    598
    Likes Received:
    201
    The last line :
    15.37s vidman.cpp 717: Video configuration may have changed. Try running rF Config.
    Seems to be an error with your video card (driver).
    Maybe time to run DDU
    1. Download and run DDU ( https://www.wagnardsoft.com/DDU/download/DDU v17.0.8.4.exe) .
    Select Restart in Safe Mode (look in DDU menu for this setting) and Remove all drivers.
    2. On Restart in Normal Mode, install new nVidia driver
    3. Empty Shaders and Bash folders
    4. Go to Settings tab on rFactor 2 Launcher and select and configure your video card.
     
  13. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    397
    Likes Received:
    152
    Hello, i am no expert with windows 10 but in the attached crash report is only the microsoft edge browser mentioned and not rfactor 2.
    Did you attach the right crash report?
    And in your trace file, the last line says 'Video configuration may have changed. Try running rF Config.'
    Did you check and select the correct driver in the video settings, by clicking on the video settings button in the launcher?
    As last question, have you tried to run the launcher as administrator?
    Problems can always be caused by too low windows user rights
     

Share This Page