[SOLVED] Windows 10 / Steam Performance

Discussion in 'Technical & Support' started by Frenz, May 15, 2016.

  1. Frenz

    Frenz Registered

    Joined:
    Aug 15, 2013
    Messages:
    27
    Likes Received:
    0
    I recently upgraded my PC to Windows 10 and transferred to the Steam version of rf2. After these changes I have lost 40-50 fps at my preferred graphics settings.

    Has anyone else experienced such a drastic performance decrease after upgrading to 10 or switching to steam? Unfortunately I got rid of my old, non-steam installation so I can't compare the two. Other games are unaffected.

    Graphics hardware is:
    GTX 670 x2 sli (365.10 WHQL)

    I run triple screens spanned with surround @ 6000x1080.
    Same settings as before in inspector and nvidia CP.

    Edit: I was able to get most (but not all) of my frames back in fullscreen mode by using the following settings from WhiteShadow's post below:

    In NVIDIA Profile Inspector:
    SLI compatabiliy bits: 0x02402004
    Number of GPUs to use on SLI rendering mode: SLI_GPU_COUNT_TWO
    NVIDIA predefined number of GPUs to use on SLI rendering m...: SLI_PREDEFINED_GPU_COUNT_TWO

    Thanks to all who posted!
     
    Last edited by a moderator: May 19, 2016
  2. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,181
    Likes Received:
    1,292
    Steam installation shouldn't affect your FPS in any way since you are basically playing the same core game bundled a different way (hence why people with non-Steam can join Steam servers, same mods can be installed in both non-Steam and Steam, etc.) So the only cause would be a build update or rF2 graphic settings (player.JSON) changes.
     
  3. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,401
    Likes Received:
    3,095
    I can only say that I switched to windows 10 and had no performance loss at all, and this was the same for many people I know and many reports on this forum; and, I've seen reports of people switching to Steam with no performance loss too, and am now seeing the same among league members. So whatever it is, it's not Steam or Win10.
     
  4. Frenz

    Frenz Registered

    Joined:
    Aug 15, 2013
    Messages:
    27
    Likes Received:
    0
    Well I got around 20 frames back by switching from fullscreen to windowed mode. I'd like to see someone explain that one.

    Edit: vehicle set steering range no longer works, wonderful.
     
    Last edited by a moderator: May 16, 2016
  5. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,401
    Likes Received:
    3,095
    Painful as it might be, you'll just to have to try and work out what you need to do to get things working again. Again Steam doesn't cause windowed FPS to be higher, for nearly everyone the game runs exactly like it did non-steam, and in Win10 (non-steam) I get better performance fullscreen as do most I'm sure.

    I've had issues with vehicle set steering since Win10 I *think*, I don't bother trying anymore. So can't help with a resolution there.
     
  6. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    Current CP is from 09.11.2011 and it is badly outdated. 365.10 WHQL (05.02.201)> Nvidia SLI PCI-E @3.0 x8 x8 > 40-50% GPU loads > +-40 fps.
     
  7. Frenz

    Frenz Registered

    Joined:
    Aug 15, 2013
    Messages:
    27
    Likes Received:
    0
    When I say nvidia cp I mean the configuration tool included in the driver which is only a few weeks old. All I have in inspector is sli compatability bits: I tried the default and the one for lego batman that's been thrown around.

    I'll check my gpu utilization when I get the chance. That does seem to be the most likely cause
     
  8. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    Sorry I meant Nvidia profile is from 09.11.2011 and it is badly outdated, not Nvidia inspector. Lego, Batman...bits don`t work anymore it works only with 353.30 WHQL.
     
  9. Ho3n3r

    Ho3n3r Registered

    Joined:
    Feb 18, 2012
    Messages:
    526
    Likes Received:
    96
    I switched to both Win10 and Steam in February, and it is performing better than before.
     
  10. Frenz

    Frenz Registered

    Joined:
    Aug 15, 2013
    Messages:
    27
    Likes Received:
    0
    That's great, but why are you posting in this thread? I asked if anyone else had had a decrease in performance. I'm also well aware that this is not a common problem and that I will be the one to have to fix it. Posting 'worksforme' and other comments in that vain is not helpful.
     
  11. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    Nvidia pure SLI performance is known issue in rFactor2 and it is not Windows 10 or Steam issue.The last Nvidia profile is from 2011 and produces 40-50% GPU loads +-30 fps in sli versus 60 fps for a single card.
    SLI performance is not being only based in GPU drivers but the game programming as well. It is easy to understand when NVidia profile (rFactor2 Mod Mode.exe, rFactor2.exe) is created 2011-09-22. gMotor2 has been updated many times after 2011-09-22 with additional SLI optimizations etc. and the latest build of the rF2 executable`s has never been submitted Nvidia so that an updated working SLI profile can be created Nvidia SLI don`t work as it should.

    Here is the fix.

    Open Nvidia inspector rFactor2 profile.

    Compatibility:
    SLI comparability bits: 0x02402004

    Sync and refresh:
    Maximum pre rendered frames: 1

    Common:
    Power management mode: Prefer maximum performance.

    UserData > player folder and open player.JASON file and edit:
    "Max Framerate":60,
    "Max Framerate#":"0 to disable (note: positive numbers only, we always use the 'alternate' method now)",
    "Texture Sharpening":0,
    "Texture Sharpening#":"Sharpen textures using MIP LOD bias - 0=Off, 1=+2.0(very blurry), 2=+1.0(blurry), 3=-1.0(sharp), 4=-2.0(very sharp), 5=0.0(auto)",

    rFactor2 video settings:
    Mode > Fullscreen
    Anti Aliasing > 3-6
    HDR> on

    http://isiforums.net/f/showthread.php/26985-New-NVIDIA-SLI-profile?p=395650&viewfull=1#post395650

    :)
     
    Last edited by a moderator: May 17, 2016
  12. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,401
    Likes Received:
    3,095
    There's anti-steam sentiment in the air, people will probably jump on anything they think proves Steam sucks, and your posts sounded like you were blaming steam or at least suspecting it. And though I can't really help, often just having someone else posting occasionally helps to bump the thread up and get more reads, which can help find some good help. But message received.
     
  13. Frenz

    Frenz Registered

    Joined:
    Aug 15, 2013
    Messages:
    27
    Likes Received:
    0
    That's true, point taken.
     
  14. Frenz

    Frenz Registered

    Joined:
    Aug 15, 2013
    Messages:
    27
    Likes Received:
    0
    Thanks for this I'll try it out soon. After looking into it a bit more last night I believe windowed and border less modes are performing normally and only in full screen mode am I missing around 50 fps. It could very well be the power saving mode...
     
  15. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,181
    Likes Received:
    1,292
    I doubt it's the power saving mode, changing that would probably only make your GPU draw more power in desktop mode. rF2 is totally hit and miss with SLI performance, it works well for some users and some bit configs and not for others. In general advice seems to be to run rF2 with SLI off, even ISI hinted that somewhere. There is no guarantee it will work with the next Nvidia driver update even if you somehow manage to find good bits with the current one.
     
  16. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    As long as ISI don`t update gMotor 2.5 or Nvdia releases faulty driver bits 0x02402004(Single GPU)is going to work with NVidia profile (rFactor2 Mod Mode.exe, rFactor2.exe)created 2011-09-22 and PCI-e @ 3.0 x8 x8. However I would love to see NVidia profile updated and this old profile makes me to wonder why products from the world's largest graphics card manufacturer are not proper supported by ISI:confused:.

    This are Nvidia default bits:

    0x02402001 - 2 Way SLI AFR (Alternate Frame Rendering)
    0x02402002 -SFR (Split Srame Rendering) (needs a minimum of 2 cards)
    0x02402003 - AFR-SFR (AFR of SFR gets around the 3 frame buffer limit of DX9)
    0x02402004 - Single GPU
    0x02402005 - 4 Way SLI AFR (This is rFactor2 bits.)
    0x02402006 - 3 Way SLI AFR

    :)
     
  17. atlantakat

    atlantakat Registered

    Joined:
    Jun 3, 2012
    Messages:
    66
    Likes Received:
    12
    Thanks you for sharing your settings WS. After updating to the latest nVidia drivers with Build 1084, my SLI framerate had dropped to 10-15 fps but I am back to 50-60 with your various changes.

    One question, should we use SLI compatibility bits: 0x02402005 or 2004? If its 0x02402004, I get an error message in Profile Inspector. How do you get Inspector to recognize and save the 2004 setting?

    Thanks in advance.
     
  18. atlantakat

    atlantakat Registered

    Joined:
    Jun 3, 2012
    Messages:
    66
    Likes Received:
    12
    I got the 2004 bits working in Inspector and picked a couple more frames. Thx again.
     
  19. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    Yes you should use sli bits 0x02402004. You can download and use Nvidia inspector: http://www.techspot.com/downloads/5077-nvidia-inspector.html
     
  20. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    If you have messed whit Nvidia Inspector settings can be hard to reset and many times only replacing rFactor2.exe with rFactor2 Mod Mode.exe is resetting you game profile back to default again or next time you install new ver. of Nvidia driver do clean install and use settings from my post #11 and you get good fps in rFactor2.
     

Share This Page