[SOLVED] [Windows 10/nVidia] rFactor 2 won't start

Discussion in 'Technical & Support' started by wolkenschieber, Jun 30, 2018.

  1. wolkenschieber

    wolkenschieber Registered

    Joined:
    Jun 30, 2018
    Messages:
    18
    Likes Received:
    1
    Hi,

    just purchased rFactor 2 in the Steam Summer Sale. Unfortunatelly the game doesn't start.
    When opening single player mode from the launcher, the splash appears for some seconds, then the launcher is presented again.

    I'm running Windows 10 with the latest updates installed. The graphic card is a nVidia 770, also with the latest driver installed.

    The games logs following messages through parameter `trace=100`:

    ```

    TRACE LEVEL = 100
    0.61s tracelog.cpp 218: Command line: "+path=".." trace=100"
    0.61s main.cpp 509: Version=1.1110 Build=1110
    0.61s main.cpp 510: FPU=0x0008001f
    1.01s game.cpp 1424: Setting Mod Path "Packages" 1 0
    1.21s game.cpp 1806: Entered Game::Enter()
    1.21s osman.cpp 962: Entered OSMan::Enter()
    1.23s osman.cpp 1024: exe is 64-bit
    1.23s hwinput.cpp 7633: Entered HWInput::Enter()
    1.23s hwinput.cpp 7634: HKL=0x04070407
    1.25s plrfile.cpp 2853: Entered PlayerFile::Enter()
    1.26s game.cpp 1023: Setting RFM "All Tracks & Cars"
    1.65s setup.cpp 3864: WARNING: Unable to find track-specific gdb file for: C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\Installed\Locations\Zandvoort_2017\0.20\VEGETATION.scn
    2.98s setup.cpp 2187: Duplicate vehfile detected & deleted from VehMan lists: C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\Installed\Vehicles\CorvettePC\1.0\CORVETTEPC.VEH
    2.98s setup.cpp 2187: Duplicate vehfile detected & deleted from VehMan lists: C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\Installed\Vehicles\Clio_PC\1.0\CLIO_PC.VEH
    6.84s tire_manager 1372: done with tires
    6.92s plrfile.cpp 2037: Attempting to save to C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\UserData\player\player.TMP
    6.98s plrfile.cpp 2061: Retcode: 0 for renaming to C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\UserData\player\player.JSON
    6.98s PluginManage 336: Analyzing plugin "KnockoutQualifying.dll"
    6.98s PluginManage 363: Successfully loaded plugin "KnockoutQualifying.dll"
    6.98s PluginManage 336: Analyzing plugin "SteamPlugin.dll"
    6.98s PluginManage 363: Successfully loaded plugin "SteamPlugin.dll"
    6.98s PluginManage 336: Analyzing plugin "StockCarRules.dll"
    6.98s PluginManage 363: Successfully loaded plugin "StockCarRules.dll"
    6.98s PluginManage 336: Analyzing plugin "TrackIR_rF2_Plugin.dll"
    6.98s PluginManage 363: Successfully loaded plugin "TrackIR_rF2_Plugin.dll"
    6.98s PluginManage 1031: Unloading plugin "KnockoutQualifying.dll" because it is disabled according to custom plugin settings
    6.98s PluginManage 1031: Unloading plugin "StockCarRules.dll" because it is disabled according to custom plugin settings
    6.98s vidman.cpp 2103: Entered VidMan::Enter()
    7.15s vidman.cpp 742: Video configuration may have changed. Try running rF Config.
    ```

    Any advice how to cope the issue?

    Thanks in advance.
     
  2. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,303
    Likes Received:
    893
    "7.15s vidman.cpp 742: Video configuration may have changed. Try running rF Config."

    When you are at the launcher click on the gear cog icon and select Video Settings.
    Check to see if everything is set how you want.
    Set GPU: to your GPU, not AUTO
    Check that Resolution matches your monitor's resolution.
    Also, with your gtx 770 graphics card, don't use any Post Effects and AA start at 1, you may even have to go with none.

    If you get into the in-game graphics settings start with everything on Low.
    Keep AI car numbers to a minimum, in fact have none at the start.
     
  3. wolkenschieber

    wolkenschieber Registered

    Joined:
    Jun 30, 2018
    Messages:
    18
    Likes Received:
    1
    I've selected the GPU in in the video setting and disabled any option, respective set it to the lowest value. Still I can't get past the splash screen.

    Interestingly the log message stays the same. What may cause the video configuration to change? Can I verify that the settings are stored properly?
     
  4. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,303
    Likes Received:
    893
    Yes. At the bottom of the Video Settings is the directory path to the file.
    I'm not at my pc so that's all I can tell you.
     
  5. wolkenschieber

    wolkenschieber Registered

    Joined:
    Jun 30, 2018
    Messages:
    18
    Likes Received:
    1
    Ah, it's right there. It seems to be modified as the settings are changed.

    However log still reports
    vidman.cpp 742: Video configuration may have changed. Try running rF Config.
    on each start.
     
  6. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    913
    Likes Received:
    431
    Can you post the whole trace file please?
     
  7. wolkenschieber

    wolkenschieber Registered

    Joined:
    Jun 30, 2018
    Messages:
    18
    Likes Received:
    1
    The trace from the last try to start is trace_2018_07_02_18_37_07-84.txt:
    Code:
    TRACE LEVEL = 100
       0.35s tracelog.cpp  218: Command line: "+path=".."  trace=100"
       0.35s main.cpp      509: Version=1.1110 Build=1110
       0.35s main.cpp      510: FPU=0x0008001f
       0.76s game.cpp     1424: Setting Mod Path "Packages" 1 0
       0.96s game.cpp     1806: Entered Game::Enter()
       0.96s osman.cpp     962: Entered OSMan::Enter()
       0.98s osman.cpp    1024: exe is 64-bit
       0.98s hwinput.cpp  7633: Entered HWInput::Enter()
       0.98s hwinput.cpp  7634: HKL=0x04070407
       1.00s plrfile.cpp  2853: Entered PlayerFile::Enter()
       1.01s game.cpp     1023: Setting RFM "All Tracks & Cars"
       1.42s setup.cpp    3864: WARNING: Unable to find track-specific gdb file for: C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\Installed\Locations\Zandvoort_2017\0.20\VEGETATION.scn
       2.78s setup.cpp    2187: Duplicate vehfile detected & deleted from VehMan lists: C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\Installed\Vehicles\CorvettePC\1.0\CORVETTEPC.VEH
       2.78s setup.cpp    2187: Duplicate vehfile detected & deleted from VehMan lists: C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\Installed\Vehicles\Clio_PC\1.0\CLIO_PC.VEH
       6.57s tire_manager 1372: done with tires
       6.67s plrfile.cpp  2037: Attempting to save to C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\UserData\player\player.TMP
       6.73s plrfile.cpp  2061: Retcode: 0 for renaming to C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\UserData\player\player.JSON
       6.73s PluginManage  336: Analyzing plugin "KnockoutQualifying.dll"
       6.73s PluginManage  363: Successfully loaded plugin "KnockoutQualifying.dll"
       6.73s PluginManage  336: Analyzing plugin "SteamPlugin.dll"
       6.73s PluginManage  363: Successfully loaded plugin "SteamPlugin.dll"
       6.73s PluginManage  336: Analyzing plugin "StockCarRules.dll"
       6.73s PluginManage  363: Successfully loaded plugin "StockCarRules.dll"
       6.73s PluginManage  336: Analyzing plugin "TrackIR_rF2_Plugin.dll"
       6.73s PluginManage  363: Successfully loaded plugin "TrackIR_rF2_Plugin.dll"
       6.73s PluginManage 1031: Unloading plugin "KnockoutQualifying.dll" because it is disabled according to custom plugin settings
       6.73s PluginManage 1031: Unloading plugin "StockCarRules.dll" because it is disabled according to custom plugin settings
       6.73s vidman.cpp   2103: Entered VidMan::Enter()
       6.92s vidman.cpp    742: Video configuration may have changed. Try running rF Config.
    My current video configuration in Config_DX11.ini is
    Code:
    //[[gMa1.002f (c)2016    ]] [[            ]]
    [COMPONENTS]
    LanguagesFile=GAME.DIC
    ObjDetail=1
    TexDetail=1
    VideoGUID=00001184-0000-0000-0000-000000000000
    VideoDriver=0
    VideoMode=0
    VrSettings=0
    AggressiveThread=0
    EPostProcessingSettings=1
    VideoRefresh=0
    WindowedMode=0
    Borderless=0
    RunBenchmarks=0
    FSAA=0
    VSync=0
    UseFXAA=0
    ShaderLevel=0
    SubViews=0
    UseSubViewParams=1
    WorkaroundFlags=0
    ViewParams=(0.540, 0.340, 0.600, 15.000, 0.037) // screen width (m), screen height (m), eye distance (m), side angle (deg), bezel gap (m)
    LeftView=(0.540, 0.340, 0.600, 15.000, 0.037)
    RightView=(0.540, 0.340, 0.600, 15.000, 0.037)
    PreferredGPU=51291
    WidescreenUI=0
    WidescreenUIWidth=-1
    WidescreenHUD=1
    CustomVidRes=(0, 0)
    VRMirrorWindowVidRes=(1920, 1080)
    VRUIScale=(1.000, 1.000, 1.000)
    MinimumVidRes=(800, 600)
    MaximumVidRes=(99999, 99999)
    
    [INSTALL]
    InstallFrom=
    InstallTo=
    
    [AUTOLAUNCH]
    Mode=Off
    LaunchTime=600
    
    [VERSION]
    Version=-1.000000
    
     
  8. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,303
    Likes Received:
    893
    I would delete that DX11 config file and start rF2 again.
     
  9. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    913
    Likes Received:
    431
  10. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    692
    Likes Received:
    284
  11. wolkenschieber

    wolkenschieber Registered

    Joined:
    Jun 30, 2018
    Messages:
    18
    Likes Received:
    1
    Did that, too. The file is created again with same content and the game doesn't start.

    Strange enough this is rFactor specific issue as other games are having trouble.

    I did reinstall the graphics driver by performing a full installation. Also with no effect. Those clearer tools are highly suspect to me. They fiddle around in windows internals to make something happen. I tend to avoid those.

    Unfortunatly I can't. The forum says: You have insufficient privileges to post here.
     
  12. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    692
    Likes Received:
    284
    I am sure many users here will vouch for Display Driver Uninstaller DDU.
    Over time and many video driver updates a lot of old files get left behind and can cause problems.
    Display Driver Uninstaller DDU is specifically designed to clean this up and allow one to start fresh with a new video driver installation.
    I have used it for years on client computers without any problems, this is not a destructive program like a registry cleaner, it is designed to do exactly what its name says.
    Your problems seem to be video driver related (as in rF Config having problems recognising your video card) so it would be worth a try.
     
  13. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,559
    Likes Received:
    2,436
    Have you tried windowed mode?

    Also, do you have a single screen only? If multiple, try selecting a different Monitor in the config.
     
  14. wolkenschieber

    wolkenschieber Registered

    Joined:
    Jun 30, 2018
    Messages:
    18
    Likes Received:
    1
    You have a point here and if you vouch for the the tool, what can go wrong?

    I removed the drivers and reinstalled those. Amazingly the nvidia driver is now 500MB in size. But rFactor behaviour stays the same: The splash screen is briefly shown, then the launcher is opened again. Also log message is identical.

    Same thing happens in windowed mode. I've only one monitor.

    I've just noticed, that in the video settings the driver version and windows version are wrong. The driver version changes on any video settings opening, respective change of video card. Also it reports Windows 8 as OS, instead of Windows 10.

    [​IMG]

    [​IMG]

    Edit: Also Steam verifies the game's files.
     
  15. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    692
    Likes Received:
    284
     
  16. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    692
    Likes Received:
    284
    Do you mean you uninstalled your nVidia drivers or you used DDU ?
    Yes, video drivers are pretty big now, quite ridiculous really !
     
  17. wolkenschieber

    wolkenschieber Registered

    Joined:
    Jun 30, 2018
    Messages:
    18
    Likes Received:
    1
    Yes, I uninstalled and reinstalled them, with DDU :)
     
    ceecee likes this.
  18. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,559
    Likes Received:
    2,436
    Unfortunately the 'wandering' driver version and wrong windows in the config doesn't mean anything, that's normal.
     
  19. wolkenschieber

    wolkenschieber Registered

    Joined:
    Jun 30, 2018
    Messages:
    18
    Likes Received:
    1
    Wandering driver version and Video configuration may have changed feels kind of connected.
     
  20. wolkenschieber

    wolkenschieber Registered

    Joined:
    Jun 30, 2018
    Messages:
    18
    Likes Received:
    1
    Also worth noting: Other games on this computer don't have issue with video card. For instance Assetto Corsa runs fine on highest graphic settings. I was hoping for rFactor 2 and its better racing AI.
     

Share This Page