What do you think can cause the "semi-freezing/jumpy" display

Discussion in 'Technical & Support' started by suryaprihadi, Jul 21, 2017.

  1. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    827
    Well, you have claimed that SLI does work before but when I asked you to help others and post your settings in this post: https://forum.studio-397.com/index.php?threads/gtx-1080-ti-struggles.56872/page-5#post-905095 you have been silent. I know that SLI is working but I doubt that you have micro-stutter, stutter free game experience. To proof me wrong all you have to do is post your settings and we see if SLI is working as it should or not. If you don`t just zip it please. o_O
     
  2. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,286
    Likes Received:
    1,402
    Are those chipsets all using PCIe 3.0 @ x16? Interesting to see there is so much variation in CPU and bus usage. The 40-50% is a lot, I had my PCIe in wrong mode and at 50-60% it already started bottlenecking. When I tried to OC my GPU with the PCIe bottleneck, it wouldn't add any more FPS to the game (with 20 cars on grid, the more opponents, the more PCIe bottlenecks).
     
  3. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    827
    Yes all chips are using PCI-e @x16 Test is done with in-game max settings, PP medium and 22 AI. I was using single GFX card, Z77>780Ti, Z87>980Ti and X99>1080Ti.
     
  4. suryaprihadi

    suryaprihadi Registered

    Joined:
    Apr 16, 2017
    Messages:
    87
    Likes Received:
    32
    SLI, If single 2560x1440 monitor ...yes it works decent for me too, but not when 7680x1440p. Dont ask me why, me dont understand :)
     
  5. suryaprihadi

    suryaprihadi Registered

    Joined:
    Apr 16, 2017
    Messages:
    87
    Likes Received:
    32
    Ari,
    My GPU bus is the same as your, never exceeding 20%.
    I did remove the PCIE>>USB card for a while to test, but I can't yet get the problem if Bodnar Config Software is not running.
    So need more test.
     
  6. Daniel Surace

    Daniel Surace Registered

    Joined:
    Dec 7, 2015
    Messages:
    208
    Likes Received:
    219
    Hi Ari,

    What frame rates were you getting with these 2 systems. An obvious observation is that PCIE BUS goes up quiet a bit when the system is struggling with FPS.

    A brief test i did, was stressing with a RACE start 24 cars at Nola with some 4k skins. when riding with car at front of grid PCIE bus would drop down to 20-30% region with frames 70-100fps. riding at the back of the field PCIE usage would shoot up to 50% and fps down to 47-58fps

    as @stonec pointed out there seems to be a large communication with system RAM, but also with Virtual Ram. my usage figures were around 3-4gb VRAM, System ram 7.6gb and a Wopping 11gb of Virtual RAM (paging)

    I do wonder if this is all a limitation of the game engine and how it handles loading in textures, shaders etc

    I will post a more depth reply after doing more testing.
     
  7. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,651
    Likes Received:
    2,577
    Well, just to throw a little water on things, I do NOT have any Bodnar boards/circuits/etc that I know of.
     
  8. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    827
    My test was done In Silverstone with GT500, max in-game settings, weather raining, 22 AI. Video settings, AA 5 and PP medium. Monitor resolution 3440x1440. Reason I was using PP at medium is that 780Ti has 3Gb of memory and High and Ultra is simply too high to that size of memory when all other settings are at the maximum.

    ASRock Z77 Extreme 6, CPU: I7 3770k @3,5 Ghz, GTX 780Ti > 40-70 fps
    ASRock Z87 OC Formula, CPU: I7 4770k @3,5Ghz, GTX 980Ti > 60-90 fps
    Asus X99 WS-E/10G, CPU: i7-5960X @3,5 Ghz, GTX 1080Ti > 160-190 fps

    Z77 and Z87, PC ram usage is close and it is almost similar ~ 5,2 GB, Virtual ram ~ 8,1 GB.
    Z77, 780Ti >VRAM usage 2,8-2,9 GB
    Z87, 980Ti > VRAM usage, 3,4-3,5 GB
    It is bit unfair to compare my Asus X99 WS-E/10G, CPU: i7-5960X @3,5 Ghz, GTX 1080Ti with my two other PC`s becourse it has
    2x Vapochill Lightspeed - Vapor Compression Cooling , not cooling only CPU but also north and south bridge, 3x 1080Ti and temps are all the time round -30C. Test was made with single 1080Ti and to remove two 1080Ti was a huge task which I am not going to do again in near future and the same applies to my Z77 and Z87 which has also two-way SLI and are water cooled.:oops:
    X99, PC ram usage ~4,4 GB, Virtual ram 6,8 GB.
    VRAM usage, 4,2-4,4 GB

    With single screen I can not see that there is a problem with performance if S397/ISI content and reasonable in game and video settings are used with ordinary PC. Z77 and Z87 GPU loads are 90-100% and X99 98-100% with S397/ISI content. However if triple screens are used there is not so much headroom to wet weather racing no mater how powerful PC is used. Would be nice to have SMP support to 10xx cards which could give 15-30% better performance to triple screen users but it seems that S397 is ignoring larger group off users and giving all the attention to VR users and does not realize that not everybody can use VR becourse of health issues or simply becourse VR is too expensive to many who already has triple screens and 10xx gfx card. I doubt Monitoring Steam stats gives the right picture how man of rFactor 2 users has 10xx card.
    The biggest problem is rF2 3p content which is not optimized to DX11. When fps drops GPU load does not increase it drops below monitor hz to ~40% and GPU load goes up first when fps does increase above monitor hz but it don`t never go higher then ~70%. I can not understand why GPU load is dropping when hardware does not bottleneck.

    Any toughs?
     
    Last edited: Aug 7, 2017
  9. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,286
    Likes Received:
    1,402
    Interesting. I wonder if it's still duplicating GPU VRAM in main RAM (+virtual memory), as that would explain the huge system RAM requirements and the bus load. DX9 has mandatory duplication of everything, but it becomes very impractical these days when we have GPU's with 11 GB VRAM to move anything to system RAM. When I run other sims like Assetto Corsa on my 4 GB GPU, there is hardly any system RAM usage going on, and anyway system RAM is always order of magnitude slower than VRAM.

    All this might explain why frame rate drops so much when there is lots of content on the screen (worst case scenario start, lots of AI cars and rain spray). If the game is dependent on the BUS and CPU speed to move things, then not even the strongest GPU will help much.
     
  10. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,651
    Likes Received:
    2,577
    What were those settings and what did you change them to?
     
  11. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    827
    I can see from your earlier posts that you have performance problem. Are you 100% sure that rF2 is in fullscreen mode ?
     
  12. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    827
    Look here guys this is with GT500 at Silverstone v1.6
    X99, PC ram usage ~4,4 GB, Virtual ram 6,8 GB.
    VRAM usage, 4,2-4,4 GB

    This is with new MClaren at Silverstone v1.6
    X99, PC ram usage ~6,1 GB, Virtual ram 10,2 GB.
    VRAM usage, 3,7 GB-3,8 GB

    Lower VRAM usage but so much higher PC-and Virtual ram usage.
    How can it be like this?
     
  13. hitm4k3r

    hitm4k3r Registered

    Joined:
    Jun 15, 2016
    Messages:
    989
    Likes Received:
    2,105
    I have exactly the same issue as the OP, but on my end it is clearly a problem with the CPU utilization, same as shown in our posted graphs btw. It is quite easy to see that CPU 1 reaches 100% quite a few times and that's the point when the game is running out of real time and starts warping.
     

Share This Page