[WIP] VW Polo G40 Cup

Discussion in 'Vehicles' started by Alex V., Apr 30, 2020.

  1. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,509
    Likes Received:
    747
    Because you know as best who is the "packaging man" here, here is the animated wiper that can be tested.
    I guess you know which entries in the gen files it needs to get it working in outer and also cockpit view.
    There are some more things to do as i have seen, for example the windows, that i will separate from the body and prepare them for the rain effects and some other things.
    I can do that in the next days, i guess.
    And when you test it, think at, that the static wiper is still mounted to the body. ;)
     

    Attached Files:

    zxd1997 likes this.
  2. Alex V.

    Alex V. Registered

    Joined:
    Sep 25, 2012
    Messages:
    32
    Likes Received:
    60
    Do you prefer to have the ModDev files?

    Edit: gmt's are not loading in Dev Mode...what the hell?
     
    Last edited: Jan 24, 2021
  3. Alex V.

    Alex V. Registered

    Joined:
    Sep 25, 2012
    Messages:
    32
    Likes Received:
    60
    Night build with working wipers thanks to @Bernd : https://we.tl/t-ZFdEfaji0a

    Do you guys want me to reduce the package file while we're working on it (removing a bunch of skins temprarily)?
     
  4. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,509
    Likes Received:
    747
    @Alex V. I often see that people have problems to build a working devmode version.
    If it's ok for you, i would like to upload a working version, that can be used for all further development.

    EDIT In the meantime, i did make some more editing, like these so far:
    starter sound fixed (was still there permanently)
    adjustable mirrors
    new L+R mirror glasses
    adjusted mirror position in cockpitinfo.ini
    separated windows with rain effects
    wccarbody material now with rain and removed double sided tag
    added textures and json for rain/ripples effect (must be repainted to match the G40 mapping)
    new driver, still not perfect

    So i guess it would be good when i upload the whole package in devmode version later, that you have all the changes as the new basis.
    Do you agree?
     
    Last edited: Jan 25, 2021
    pkelly, Mauro, atomed and 4 others like this.
  5. Haris1977

    Haris1977 Registered

    Joined:
    Nov 25, 2019
    Messages:
    288
    Likes Received:
    138
    Wipers do work but..

    I started a race in Autodrom Most, in 24th position. After the start this is what i saw in the tarmac

    Untitled.png

    It looks like it is a "leftover" from a car.

    edit: same thing for Brands Hatch circuit. In other tracks (Muggelo, Nurburgring, Sebring etc) no such problem. Maybe track / car combination problem?

    (With other cars no Autodrom glitch)
     
    Last edited: Jan 25, 2021
  6. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,509
    Likes Received:
    747
    I remember that happening in rfactor 1 too sometimes, where it was a graphical glitch, i guess.
    Maybe the driver belt wasn't fixed properly? :)
    Can you see where the driver is coming from or "what happens", in a replay?
     
    Alex V. likes this.
  7. Haris1977

    Haris1977 Registered

    Joined:
    Nov 25, 2019
    Messages:
    288
    Likes Received:
    138
    Here is the replay file. I am not 100% sure but i think i saw the driver that was laying down from the start of the race?

    Edit 1: It seems that the driver is in the right side of the car #24 of the 1991 class (even before the start of the race)
     

    Attached Files:

    Last edited: Jan 25, 2021
  8. Haris1977

    Haris1977 Registered

    Joined:
    Nov 25, 2019
    Messages:
    288
    Likes Received:
    138
    Edit 2: It seems that is not the same car in every race: Here in this pic for example:

    Untitled1.png
    This is the dash cam of the 2nd driver in the grid (#27) even before the start of the race.

    In this example the driver lies near the car #17 (from the 91 class). So it seems that the driver is always at the start line? Hmm...

    And here same pic from the 1rst driver on Brands Hatch (driver lies not on the right side but exactly on the start-finish line)

    Untitled2.png
     
    Last edited: Jan 25, 2021
  9. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,509
    Likes Received:
    747
    I have installed the rfcmp version 0.623 now and tested on 2 tracks, without any driver sitting on the track. :)
    Do you maybe still have former versions installed too?
    When Alex agrees, i will upload the new devmode folder, that he can package and release it.
    I use a new driver, that still is not perfect, but he at least sits behind of the steering wheel. :)
    I don't want to release that new version packaged as a rfcmp, because that should do only 1 person, to avoid any version crossings.
    BTW What i would change too, is the entry in the menu.
    If i install a VW Polo, i search for it under VW or Volkswagen or Polo, but not under T, like "Trofeu". ;)
     
  10. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,509
    Likes Received:
    747
    I did install Most too, to watch your replay and there the driver indeed sits there at the start already.
    Same when i start a race at most.
    So i will package my version now, to check if it happens with it too, that i can fix it before it gets released to you.
     
    Haris1977 likes this.
  11. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,509
    Likes Received:
    747
    OK, driver on track is gone.
    But the outside windows are not transparent in the main game, while they look as they should in devmode.
    I will try to fix that.
    But i hate that, when the things in devmode and main game behave different.
    To repackage the whole rfcmp, each time you have made a small adjustment only, is not how it es meant to be.
    Devmode, for me, means that i can develop the things there.
     
  12. Alex V.

    Alex V. Registered

    Joined:
    Sep 25, 2012
    Messages:
    32
    Likes Received:
    60
    @Bernd Yeah, you can upload the Dev Mode files :) That reduces the time to check for small adjustments.
    The outside windows problem exists here too (when it was working), can't find the problem.
     
  13. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,509
    Likes Received:
    747
    It's fixed too. ;)
    It simply was the material name "windows", that is not unique enough.
    When a track uses that name too, the material from the track gets used for the car too, because the track gets loaded first.
    i have renamed it to wcwindows now.
    Here is the list of what has changed (some minor things are not mentioned).

    starter sound fixed (was still there permanently)
    adjustable mirrors
    new L+R mirror glasses
    faked mirrors for the outside view
    adjusted mirror position in cockpitinfo.ini
    separated windows with rain
    wccarbody material now with rain and removed double sided tag
    added texture and json for rain/ripples effect
    new driver, still not perfect
    fuel level gauge fixed
    material windows renamed to wcwindows, to avoid conflicts with track material names

    In the devmode version that i will upload now, are the 3 folders.
    "_removed", where i have put all things in that are not used anymore.
    "driver", that contains everything that belongs to the driver and helmet, that another possible change of the driver can be made easier.
    And the folder "material_JSON", where the JSON files get stored, that the webbased material editor generates.
    I will inform you in a few minutes, when the zip file is uploaded.
    Is it ok to post the download link here, or better by private conversation?
     
    McFlex and pkelly like this.
  14. Alex V.

    Alex V. Registered

    Joined:
    Sep 25, 2012
    Messages:
    32
    Likes Received:
    60
    Cool stuff!
    Yeah you can post it here, it's basically the 3 of us at this point.
    For minor changes we can use PM to avoid clutter in the thread.

    Btw this is the new dashboard that I will add later:
    dash1.jpg
     
    pkelly, zxd1997, Manfredk2 and 2 others like this.
  15. Haris1977

    Haris1977 Registered

    Joined:
    Nov 25, 2019
    Messages:
    288
    Likes Received:
    138
    @Bernd can you also move the dashcam (i always use that camera when i race) "eyepoint / driver eyes" a little more to the "down" direction?

    Now (as it is by default) i sit a little high inside the car (of course i can fix this by seat up / down assigned buttons, but it would be better to be a little "down")
     
  16. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,509
    Likes Received:
    747
    That looks nice.
    Hopefully you 'll find the best shader with settings, to get it looking great in game. ;)
    Since S397 encrypts all the good things, it's hard to try to find out what they use to get it looking great.

    The package is uploaded.
    It has to be extracted into the devmodes vehicles folder.
    AND, please remove all former versions, mas files, files, folders.... from that car, before you extract and use it. ;)
    One last thing.
    As i have said, there are some textures that have to be painted for the rain effects.
    They are in the teams folder.
    The only 2 files that i could paint are the alpha 0 and 1 arc files, that define the wiped area.
    The rest has to be painted by someone else.
    Here is the link.
    https://www.dropbox.com/s/uxzo94fcrbrldpa/PoloG40Cup.zip?dl=1
     
    Last edited: Jan 25, 2021
  17. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,509
    Likes Received:
    747
    oops crossed posts.
    Do you mean the angle of the view or just the vertical height?
     
  18. Alex V.

    Alex V. Registered

    Joined:
    Sep 25, 2012
    Messages:
    32
    Likes Received:
    60
    Still crashes to desktop... Reminds me of the good old days of rF1 when we had CTD for absolutely no reason!
     
  19. Mauro

    Mauro Registered

    Joined:
    Oct 14, 2011
    Messages:
    1,864
    Likes Received:
    2,975
    i copy here some generic useful rf2 devmod tips :)

    About devmod
    Make sure you haven't .Mas files in your vehicles and locations folder
    -If you have a mas like brmGMT.mas and brm\GMT\ files too
    devmod crash
    -same logic with all other files
    -i have only sound.Mas in my devmod
    So move your mas files out of devmod

    I saw that if i have only one mas file like above
    Devmod could crash always with all cars and all tracks

    if your devmod still not work:
    -try to move off all your projects (cars and tracks)
    -keep in devmode only skipbarber and Loch Drummond contents
    -delete moddev/userdata/ dir and files
    -then try skipbarber at Loch Drummond
     
    Alex V. and Bernd like this.
  20. Alex V.

    Alex V. Registered

    Joined:
    Sep 25, 2012
    Messages:
    32
    Likes Received:
    60
    Well this is new!

    upload_2021-1-25_12-39-5.png
     

Share This Page