VM LiveView Lite for rFactor & rFactor2

Discussion in 'Plugins' started by Frank Geyer, Feb 20, 2012.

  1. Knuelle

    Knuelle Registered

    Joined:
    Oct 11, 2012
    Messages:
    1
    Likes Received:
    0
    Hallo Frank,
    ich bin echt langsam am verzweifeln. Ich find dein Tool echt genial aber ich hab echt Probleme damit.
    Ich möchte das Tool auf einem Server 2 mal einsetzen, da auf meinem Server 2 rfactor Dedicated Server gestartet werden.
    Nun habe ich es geschafft das ich das Tool für einen rfactor Dedicated Server zum laufen gebracht habe.
    Ich bringe aber keinen 2. rfactor dedicated server zum laufen. Der Monitor etc. funktioniert nur kommen keine Daten da rein!

    Ich hab das nun einige male nach Anleitung hier im ersten Thread gemacht aber keinen Erfolg dabei gehabt.
    Ich bin der Meinung das der SL die Verbindung mit dem Dedicated Server nicht hat, da der SL nichts macht wenn ich den Dedicated Server starte.

    Evtl. hört sich das alles etwas verwirrend an, aber mir fällt nichts anderes ein wie ich es erklären könnte.
    Ich hoffe dennoch das ihr mir helfen könnt.

    Vielen Dank schon mal im vorraus.
     
  2. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Hi Knuelle,

    kannst Du mir mal bitte 2 Screenshots von jedem der beiden Session Loader posten bzw. per PM schicken. Da Du ja 2 Instanzen vom rFactor Dedicated Server abbilden möchtest, gehe ich jetzt mal davon aus, dass Du 2 Datenbanken eingerichtet hast die jeweils von einem separaten Loader befüllt werden ... entscheidend dabei ist der Verweis auf das jeweilige "..\VMHotlaps" - Verzeichnis des jeweiligen Loaders, der wiederum dann auch die Daten in die dazugehörig konfigurierte Datenbank schreibt.

    Gruß
    Frank
     
  3. iZzy

    iZzy Registered

    Joined:
    Oct 26, 2012
    Messages:
    1
    Likes Received:
    0
    Hey Frank,

    hast eine PN :>
     
  4. LCCMarc

    LCCMarc Registered

    Joined:
    May 16, 2012
    Messages:
    56
    Likes Received:
    0
    Hello Frank,
    When do you think to download the new version? or, you might get files to accept quotes?

    Thank you in advance, Marc
     
  5. ~IsR~Barabba

    ~IsR~Barabba Member

    Joined:
    Oct 6, 2010
    Messages:
    1,157
    Likes Received:
    37
    Hello everyone I installed the inofficial version of this nice plugin.
    I just get this error Can you help me figure out what to change.
    Thanks in advance


    by the time I installed the official version and the new version works will wait


    [​IMG]

    Babs;)
     
    Last edited by a moderator: Nov 1, 2012
  6. Killer

    Killer Registered

    Joined:
    Nov 8, 2012
    Messages:
    2
    Likes Received:
    0
    HI Babs,

    i just help Frank a little bit here. This error message indicates that you did not update the SQL Database to the new Versions. The Scripts for this are in the MySql Folder of the Download.

    Daniel
     
  7. ~IsR~Barabba

    ~IsR~Barabba Member

    Joined:
    Oct 6, 2010
    Messages:
    1,157
    Likes Received:
    37
    Thx Killer
    as soon as I find some free time I'll try to look at these folders.
    Could it be that I have overwritten the file,rather than replacing in whole folders.

    Babs
     
  8. Killer

    Killer Registered

    Joined:
    Nov 8, 2012
    Messages:
    2
    Likes Received:
    0
    Are you firm with phpmyadmin? you have to update the database with this tool. You also can start from fresh with a new database (delete the old one) and run setup.php again, should work....
     
  9. Valbuena72

    Valbuena72 Registered

    Joined:
    Dec 23, 2011
    Messages:
    194
    Likes Received:
    0
  10. grumete

    grumete Registered

    Joined:
    Dec 26, 2011
    Messages:
    19
    Likes Received:
    0
    Nice job...
    I like use this for my league but I don't know how.
    We have a windows web server 2008 whit rFactor1, but I never use mysql or Apache and I don't know how.

    Is possible prepare Tutorial or Video for people how like rFactor but don't know nothing about APM??
    Thanks
     
    Last edited by a moderator: Nov 21, 2012
  11. JuanPollo

    JuanPollo Registered

    Joined:
    Nov 22, 2012
    Messages:
    4
    Likes Received:
    0
    How is set to appear at the circuit map track.php calling routine? Where do I specify the path of the files. Gbd and. Aiw for the circuit? Apologies if this has already been discussed in this thread, but I have been unable to see it.
     
  12. Valbuena72

    Valbuena72 Registered

    Joined:
    Dec 23, 2011
    Messages:
    194
    Likes Received:
    0
    Same problem, track not import in the drop-down list [​IMG]
    http://upload.stabland.fr/images/img114/sans_titre-1715211.jpg

    In the folder rFactorSL, there is Subfolder "trackdata" with readme :
    Step 3, I do not understand how to import it into the database with rFactorSL
    Thank's
     
  13. DerKutscher

    DerKutscher Registered

    Joined:
    Sep 13, 2011
    Messages:
    139
    Likes Received:
    1
    Hi,

    ich habe ein Problem! Dieses Plugin lief bei mir wunderbar. Jetzt sind wir auf einen neuen Root umgestiegen. Ich habe alles wieder so angelegt wie auf dem alten. Datenbank wird beschrieben, habe es kontrolliert. Aber wenn ich jetzt den Monitor aufrufe bekomme ich die Meldung" Database connection error!. Ich finde keinen Fehler, alles korrekt eingetragen und editiert. Und wie gesagt, die Datenbank wird beschrieben. Ich weis nicht mehr weiter.

    Gruß

    Mike
     
  14. hoser70

    hoser70 Registered

    Joined:
    Jan 14, 2012
    Messages:
    716
    Likes Received:
    7
    using "localhost" as the Database Writer Connectivity Host" and I get the following error:
    Seems to be throwing an extra p: in there for some reason?
     
  15. ennimann

    ennimann Registered

    Joined:
    Dec 28, 2011
    Messages:
    74
    Likes Received:
    2
    Hallo Mike,

    lässt Dein neuer Hoster auch das Schreiben in seine Datenbanken zu? Bei den meisten ist diese Funktion Option.
     
  16. hoser70

    hoser70 Registered

    Joined:
    Jan 14, 2012
    Messages:
    716
    Likes Received:
    7
    Is there anyone that has this working that might be able to walk me through this?

    Here's what I've done so far:

    1. Uploaded all files to our Apache server that were in the htdocs folder.
    2. Manually created my MySQL datbase and then imported the vmliveview.db.manual.setup.sql file, which created 8 tables.
    3. Configured the inc.mysqli.conn.php file as such:
    Code:
    <?php
       $pageNameIO = "inc.mysqli.conn.php";
       
       // -- connect to mysql server
       $dbHost='localhost';
       $dbReader='datbase_user';
       $dbReaderPass='database_password';
       $dbName='database_name';
       $dbPort='3306';
       
       $mySQLiConn = @new mysqli( $dbHost, $dbReader, $dbReaderPass, $dbName, $dbPort);
       
       $mySQLiConnError = "";
       if($mySQLiConn->connect_error){
          $mySQLiConnError = "<div class='break6'></div>\n" .
                             "<div class='red'>Database connection error.</div>\n" .
                             "<div class='break6'></div>\n" .
                             "<a href='" . $siteURL . "/monitor.php'>Try again</a>\n";
          
          writeErrorLog($pageNameIO, "Connect to SQL Server", "Error No: (" . $mySQLiConn->connect_errno . ") Error Msg: (" . $mySQLiConn->connect_error . ")");
       }else{
          if(!$mySQLiConn->set_charset($dbCharSet)){
             writeErrorLog($pageNameIO, "Set connection character set", "Error Msg: (" . $mySQLiConn->error . ")");
          }
       }
    ?>
    4. Edited the rFactorSL.exe.xml file as such:
    Code:
    <?xml version="1.0" encoding="windows-1252"?>
    <rFactorSL>
       <Common>
          <EventName>Your Event Name</EventName>
          <CycleTimeout>269</CycleTimeout>
          <Chill>0</Chill>
       </Common>
       <CurrentScoringSource>
          <xmlURL>C:\rFactor\vmliveview\VMHotlaps\CurrentScoring.xml</xmlURL>
       </CurrentScoringSource>
       <MySQL>
          <sqlHost>localhost</sqlHost>
          <sqlPort>3306</sqlPort>
          <dbName>database_name</dbName>
          <dbWriter>database_user</dbWriter>
          <dbWriterPass>database_password</dbWriterPass>
          <sslMode>None</sslMode>
       </MySQL>
       <DedicatedServer>
          <connPrefix>rfactor</connPrefix>
          <connAddress>209.xxx.xx.xx</connAddress> ([I]not sure i need this as everything is on the dedicated server[/I])
          <connPort>30000</connPort>
       </DedicatedServer>
       <Hotlaps>
          <LogAI>0</LogAI>
       </Hotlaps>
    </rFactorSL>
    5. I've copied the files from the rfactorSL folder to the server and placed them under a directory I named vmliveview as seen in the screenshot below:
    [​IMG]

    6. Dropped VMHotlaps.dll into the rFactor2 Plugins directory.
    7. I then start the rFactorSL.exe application and click "Start" on it.
    8. Then I start the rFactor2 dedicated server.

    At this point nothing seems to happen. rFactorSL.exe just says: SQL Connection State: Closed and nothing appears to happen.

    Do I need to have files in very specific directories? What really has me baffled is how rFactorSL.exe knows when or where the rFactor2 dedicated server is?

    Anyway, I'm a bit lost since there's no documentation and was wondering if someone who has this working could have a look at my setup and tell me where I've gone wrong.

    Thanks.
     
  17. DerCarsten

    DerCarsten Registered

    Joined:
    May 22, 2012
    Messages:
    4
    Likes Received:
    0
    Hi ennimann,
    ich arbeite mit dem ollen Mike zusammen ;) und es ist so das die Daten zwar in der Datenbank geschrieben werden, nur lassen sie sich nicht über die Homepage aufrufen.
    View attachment 4861

    Gruß
    Carsten
     
  18. ennimann

    ennimann Registered

    Joined:
    Dec 28, 2011
    Messages:
    74
    Likes Received:
    2
    Welcher Version nehmt Ihr? Wir haben hier die letzte inoffizielle im Einsatz und da geht es, außer beim IE!!!! Da wird nur die Überschrift angezeigt und keine Daten. Bei FF und co geht es aber dann einwandfrei. Trotzdem muss beim Hoster explizit der Zugriff auf die externe Datenbank erlaubt sein, es sei denn, Ihr habt das alles auf einem Windowsserver laufen, also rFactor, Homepage usw.
    Auch ist der Typ bei SSL gaaanz wichtig. Bitte dort nochmal genau in die Beschreibung vom Hoster schauen.
    Habt Ihr Euch die Daten mal genau angesehen, die in der DB einlaufen? Sind die auch lesbar mit myAdmin?
     
  19. DerKutscher

    DerKutscher Registered

    Joined:
    Sep 13, 2011
    Messages:
    139
    Likes Received:
    1
    Hi, der Witz ist ja wir haben alles wieder auf einen Root. die sl.exe findet die datenbank auf dem Root unter localhost, wie man sieht im Bild von Carsten, schreibt er ja in die Datenbank. Aber wenn ich die Monitorphp aufrufe, wie gesagt alles auf einem Root, da findet er die Datenbank nicht. Das verstehe ich nicht.

    Siehe hier: http://old-man-racing.eu/vmliveview01/monitor.php

    wie man sieht, er findet alles ausser die Datenbank!

    Gruß

    Mike

    PS.: Schreibfehler bitte übersehen, hatte gestern Weinprobe!
     
  20. DerKutscher

    DerKutscher Registered

    Joined:
    Sep 13, 2011
    Messages:
    139
    Likes Received:
    1
    PS.: sorry bergessen, ja wir haben auch die letzte version drauf!
     

Share This Page