VM LiveView Lite for rFactor & rFactor2

Discussion in 'Plugins' started by Frank Geyer, Feb 20, 2012.

  1. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Ja, dann sollte es eigentlich passen!
     
  2. Dan AccretionRacing

    Dan AccretionRacing Registered

    Joined:
    Feb 5, 2012
    Messages:
    24
    Likes Received:
    0
    Great Work Frank
     
  3. TestDriver

    TestDriver Registered

    Joined:
    Dec 29, 2011
    Messages:
    31
    Likes Received:
    0
    Hi Guys,
    Does anyone know if this plugin will work with "1and1" as my host?

    If yes, then I have these questions...
    Ive created my data base and now need to import, what file?

    I tried importing the "setup.php" from ...vmlive/apache/htdocs/vmliveview/setup.php" however, I get this error

    " MySQL said: Documentation
    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'max_connections=200
    query_cache_size=32M

    ### away from defaults ###
    query_c' at line 2
    "

    Can someone post up a more detailed installation process as I have a "self taught" approach to databases etc...

    Cheers in advance...
     
  4. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Hi Test,

    for a manual setup of the database u need to run/import a file called vmliveview.db.manual.setup.sql from the mysql directory of the package ...

    Cheers
    Frank
     
  5. rafalgt

    rafalgt Registered

    Joined:
    Jan 4, 2012
    Messages:
    51
    Likes Received:
    8


    I removed the file vmliveview.db.manual.setup.sql is: USING BTREE




    Frank what is wrong? LINK
     
  6. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Hi rafalgt,

    I thought it would be a good idea that not every remote user is able to access and/or use some pages:

    Code:
       // -- as a precaution only allow localhost to request this page
       $illegalRemoteAddr = false;
       if($_SERVER["REMOTE_ADDR"] != "127.0.0.1" && $_SERVER["REMOTE_ADDR"] != "::1"){
          $illegalRemoteAddr = true;
       }
    
    You can either comment out the line $illegalRemoteAddr = true; or you could add your IP to the if phrase like:

    if($_SERVER["REMOTE_ADDR"] != "127.0.0.1" && $_SERVER["REMOTE_ADDR"] != "::1" && $_SERVER["REMOTE_ADDR"] != "YOUR.IP.ADD.RESS"){

    Hope this helps ...

    Cheers
    Frank
     
  7. rafalgt

    rafalgt Registered

    Joined:
    Jan 4, 2012
    Messages:
    51
    Likes Received:
    8
    TXS Frank
     
  8. LCCMarc

    LCCMarc Registered

    Joined:
    May 16, 2012
    Messages:
    56
    Likes Received:
    0
    Hello Frank,

    I have this as an error:

    "10.09.2012 21:44:06.015";"SQL Error";"sqlSlotsInsert() Msg: (You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '06','0 ','0','0','3659.7','-1','-1','-1','-1','0','0','0','0','-1','-1','0','0',' at line 1) Query: (INSERT INTO `slots` (`SlotID`,`DriverName`,`Vehicle`,`Laps`,`Sector`,`FinishStatus`,`LapDist`,`BestS1`,`BestS2`,`BestS3`,`BestLap`,`LastS1`,`LastS2`,`LastS3`,`LastLap`,`CurS1`,`CurS2`,`Pitstops`,`Penalties`,`IsPlayer`,`Control`,`InPits`,`LapStartET`,`Place`,`VehicleClass`,`TimeBehindLeader`,`LapsBehindLeader`,`TimeBehindNext`,`LapsBehindNext`,`VehicleSpeed`,`PosX`,`PosY`) VALUES ('1','Rogerio BR','R. Pilve, Baltic GT '06','0 ','0','0','3659.7','-1','-1','-1','-1','0','0','0','0','-1','-1','0','0','0','2','0','0','11','Endurance','1.63','0','0.218','0','0','-2.503','824.576'))"

    I use the mod "Megane Trophy v2.0", and the vehicles have an apostrophe in their name eg: Artman Racing '06

    I did not know anything regarding the scripts, would it be possible to do something because I'd really like to put this plugin on my server.

    Excuse me for my English, but I use a translator.
    Thank you in advance.
     
  9. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Hi Marc,

    yes, u are right. The apostrophe in the vehicle's name is what's causing the break of the sql statement and thus causing it to fail. Which version of the LV are u using currently?

    Cheers
    Frank

    PS: Do you have a link to this mod for me pls?
     
    Last edited by a moderator: Sep 11, 2012
  10. LCCMarc

    LCCMarc Registered

    Joined:
    May 16, 2012
    Messages:
    56
    Likes Received:
    0
  11. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Hi there,

    due to some encouragement by MaXyM and the fact that the single quote "'" always has been an issue in the live timing, I switched the whole character sets and encodings over to UTF-8.

    Here is an example of the current build: http://vxracing.de/vmliveview/monitor.php

    @Marc: I checked it against the rFactor1 Megane Trophy V2 mod. So far it looks all good. I leave it running for a couple of days to be sure that everything is doing ok and get back to you when I release the next build ...

    Cheers
    Frank
     
    Last edited by a moderator: Sep 12, 2012
  12. LCCMarc

    LCCMarc Registered

    Joined:
    May 16, 2012
    Messages:
    56
    Likes Received:
    0
    Ok Franc
    Again thank you to you for this work
     
  13. Valbuena72

    Valbuena72 Registered

    Joined:
    Dec 23, 2011
    Messages:
    194
    Likes Received:
    0
  14. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Hi Val,

    this has been fixed already in the latest inofficial Release. See first post for a download link.

    Cheers
    Frank
     
  15. ennimann

    ennimann Registered

    Joined:
    Dec 28, 2011
    Messages:
    74
    Likes Received:
    2
    Hi Frank,

    wir haben in unserer neuen Liga nun auch erfolgreich Dein System installiert.
    Leider gibt es doch ein aber.
    Wenn "add_default_charset" ausgestellt ist, funktioniert die Anzeige im IE nicht, im FF aber ok.

    Hast Du dafür evtl. eine Erklärung?
    Vielen Dank schon Mal

    Gruß
    ennimann
     
  16. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    ... meinst du das: http://httpd.apache.org/docs/2.0/mod/core.html#adddefaultcharset

    und wenn ja, welchen Charset habt ihr angegeben und wie sieht die config des liveview diesbezüglich aus?

    Gruß
    Frank
     
  17. ennimann

    ennimann Registered

    Joined:
    Dec 28, 2011
    Messages:
    74
    Likes Received:
    2
    Hallo Frank,

    ja, geht um die Providereinstellung. Default ist da "add_default_charset = ON". Für das SLS System brauchen wir aber "OFF", dann klappt das mit den Umlauten besser. Aber dann sehen wir im IE beim liveview nur noch die Überschrift.

    Wir verwenden das letzte inoffizielle System von Dir.
    Standard config mit: "$siteCharSet = "windows-1252";"

    Reicht das als Angabe?
    Gruß und schon Mal lieben Danke
    ennimann
     
  18. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    In welcher IE-Version ist das so? In allen?

    Ist euer Provider Alfahosting?

    Probiert mal zu Testzwecken: add_default_charset = uft-8 (oder: utf8)

    Ansonsten alles im liveview auf UTF-8 umstellen (mysql db, charsets in der liveview config) ...

    Oder warten bis zum nächsten Release. Das kommt komplett umgestellt auf UTF-8 (Plugin, Loader, DB, PHP, Scripts)!

    Gruß
    Frank
     
  19. ennimann

    ennimann Registered

    Joined:
    Dec 28, 2011
    Messages:
    74
    Likes Received:
    2
    Du bist der Beste, ja Alfahosting und ja alle IE.
    Wir testen das mal so.
    Vielen lieben Dank Frank

    Gruß
    ennimann
     
  20. ennimann

    ennimann Registered

    Joined:
    Dec 28, 2011
    Messages:
    74
    Likes Received:
    2
    Hallo Frank,
    wir haben uns entschieden, das System erstmal so laufen zu lassen, wie es ist. Es funktioniert und viele arbeiten eh mit FF, da geht ja alles. Wir warten dann lieber auf Dein Update und machen dann klar Schiff.
    Vielen Dank noch Mal für die Klasse Sache hier.

    ennimann
     

Share This Page