VM LiveView Lite for rFactor & rFactor2

Discussion in 'Plugins' started by Frank Geyer, Feb 20, 2012.

  1. gagipro

    gagipro Registered

    Joined:
    Feb 26, 2013
    Messages:
    461
    Likes Received:
    0
    Cannot access the xml is strange, any idea Frank?
     
  2. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Permission !?!? File Lock !?!? Is the file system (partition) still OK (chkdsk /?) !?!? Gotta see the log file of the loader ...
     
  3. gagipro

    gagipro Registered

    Joined:
    Feb 26, 2013
    Messages:
    461
    Likes Received:
    0
    I thought about an antivirus perhaps... Really strange message.
     
  4. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Yeah might be an option too. Due to your log file the .xml file is in use by another process. Pls try Sysinternals Process Explorer http://technet.microsoft.com/de-de/sysinternals/bb896653.aspx to find out which process uses/locks the .xml file ...
     
  5. gagipro

    gagipro Registered

    Joined:
    Feb 26, 2013
    Messages:
    461
    Likes Received:
    0
    Perfect answer !
     
  6. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
  7. Valbuena72

    Valbuena72 Registered

    Joined:
    Dec 23, 2011
    Messages:
    194
    Likes Received:
    0
    Thank's Franck
    I do test now, the DLL is used by rFactor2 Dedicated
    I think the file was used by notepad + + that I had opened this time there.
    I close everything, we'll see. I test until tonight, tomorrow promises to be a great race (27 drivers) I prefer not to take risks
    But the plugin has crashed later time indicates the log.
    For now, I continued my test
     
  8. Valbuena72

    Valbuena72 Registered

    Joined:
    Dec 23, 2011
    Messages:
    194
    Likes Received:
    0
    Server not crash but "Cannot access the xml" reappeared in the log but LiveTiming work's always ! View attachment 11612 View attachment 11613 View attachment 11612
    So I guess the server will crash in a few minutes;

    I stop then reactivate rFactor SL
    and the message no longer appears in the log
     
  9. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    To a certain point those messages in the log file of the loader are "normal". When the Plugin writes the .xml file to a temp file (CurrentScoring.tmp) and then copies it to the actual file (CurrentScoring.xml) and the loader tries to access the actual file while the Plugin copies the file, the file is still in use by the Plugin so the loader throws this message. Nevertheless the loader tries to read the actual .xml on its next cycle. So far I never had the situation that either the Plugin or the loader completely locked the file causing the DS to crash. From the distance it is hard for me to tell what is causing this behavior on your system ... :/

    In fact I also used the live timing in a load balance and fail over scenario where three loaders from two separate remote machines and local used the same .xml file to serve a live timing for this particular event.

    What I can offer you is to take a look at your system and maybe find out what is going on, cause from here I am out of options and ideas ... sorry !!! :(

    Cheers
    Frank
     
  10. Valbuena72

    Valbuena72 Registered

    Joined:
    Dec 23, 2011
    Messages:
    194
    Likes Received:
    0
    Ok Frank, I will give you the ID and password of the server after you Wednesday to look at what is happening.
    Thank's I want this plugin works and it will work. We'll get there.
    They worked before!
     
  11. gagipro

    gagipro Registered

    Joined:
    Feb 26, 2013
    Messages:
    461
    Likes Received:
    0
    Sure ISI introduced a bug in recent builds!!
     
  12. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Ok, we stay in contact ...
     
  13. Valbuena72

    Valbuena72 Registered

    Joined:
    Dec 23, 2011
    Messages:
    194
    Likes Received:
    0
    Frank, you want me to reinstall a rFactor 2 with one mod?
    or you prefer to look on our current rfactor 2
     
  14. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Just leave it like it is, if it doesn't interfere with your future plans for your events ...
     
  15. Valbuena72

    Valbuena72 Registered

    Joined:
    Dec 23, 2011
    Messages:
    194
    Likes Received:
    0
    Thank's Franck,
    I sent you a PM
     
  16. myself9

    myself9 Registered

    Joined:
    Jan 7, 2013
    Messages:
    338
    Likes Received:
    30
    Hi Guys
    I'd like to give this plugin a try, but all this computer crap is a bit over my head :p

    I suppose the first order of business is to get an Apache/PHP/Mysql environment set up on my race server.
    Would using WampServer or XAMPP be sufficient?

    Any advice is MUCH appreciated!
     
  17. gagipro

    gagipro Registered

    Joined:
    Feb 26, 2013
    Messages:
    461
    Likes Received:
    0
    I'm using wamp for our league's Liveview

    No feedbacks from Frank & Val about the debuging?
     
  18. myself9

    myself9 Registered

    Joined:
    Jan 7, 2013
    Messages:
    338
    Likes Received:
    30
    Thanks for the info, gagipro!
     
  19. rigodon

    rigodon Registered

    Joined:
    Dec 26, 2012
    Messages:
    209
    Likes Received:
    9
    Hi, I had to reinstall my RF2 server (only software, I kept the data) and now plugin is not working, it doesn't create CurrentScoring.xml. Any ideas?
     
  20. gagipro

    gagipro Registered

    Joined:
    Feb 26, 2013
    Messages:
    461
    Likes Received:
    0
    You wiped out all your vmliveview config folders???
     

Share This Page