VM LiveView Lite for rFactor & rFactor2

Discussion in 'Plugins' started by Frank Geyer, Feb 20, 2012.

  1. Valbuena72

    Valbuena72 Registered

    Joined:
    Dec 23, 2011
    Messages:
    194
    Likes Received:
    0
  2. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Ok, which browser? What setting did u change?
     
    Last edited by a moderator: Mar 19, 2013
  3. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
  4. xoa

    xoa Registered

    Joined:
    Mar 11, 2011
    Messages:
    44
    Likes Received:
    0

    Chromium, latest version. I changed the browser language to Italian under "Language and input settings".
     
  5. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Can you pls browse this page ( http://vxracing.de/index.php ) and post the result here with your browser switched to Italien as your default browser language. The result should be something like this:
    Code:
    Welcome...
    
    Your browser accepts the following languages weighted by q = {1.0 - 0.0 (max - min)}:
    it-ch,it;q=0.9,fr-fr;q=0.8,fr;q=0.6,de-de;q=0.5,de;q=0.4,en-us;q=0.3,en;q=0.1 
    
     
  6. xoa

    xoa Registered

    Joined:
    Mar 11, 2011
    Messages:
    44
    Likes Received:
    0
    I get this as result:

    Code:
    Welcome...
    
    Your browser accepts the following languages weighted by q = {1.0 - 0.0 (max - min)}:
    en-US,en;q=0.8,it;q=0.6
     
  7. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    As you can see, even you changed your browser language to Italian, your browser still requests en-US with q=1.0 as the highest weighted default language en as 2nd and it only as 3rd. For in depth details visit this link: http://php.net/manual/de/function.http-negotiate-language.php

    To change this behavior you need to tell your browser that Italian is your most preferable default language. In general this can be accomplished by moving the desired language to the top in the list of a configuration dialog as you can see in the picture below exemplary
    for Firefox ...
     

    Attached Files:

  8. xoa

    xoa Registered

    Joined:
    Mar 11, 2011
    Messages:
    44
    Likes Received:
    0
    Ok, works now. In chrome you have to remove English completely to get it to work. Wouldn't it be easier to add a other radio-button? I know, the layout may get messed up a bit.
     
  9. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Strange. My favorite is Firefox but I just installed Chrome on a virtual box in its latest version just to be sure. When I add Italian and move it up to the top, it just works fine ... however, for now I am going to leave it like it is. But maybe when I find a better solution to provide languages in a drop-down-box, I am going to change it. Hope it is ok so far for you too?

    Cheers
    Frank
     

    Attached Files:

  10. xoa

    xoa Registered

    Joined:
    Mar 11, 2011
    Messages:
    44
    Likes Received:
    0
    For me this is no problem :)

    Maybe the language in Chrome depends also on the language of the OS. I use English as OS language.
     
  11. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    When it comes to IT one can't rule out anything, but in this case it is hard to tell. My virtual OS language is German and so is the browser's (Fox 19.2, IE 8.x, Chrome 25). When I added Italian and moved it up to the top it worked right away either way.

    But I am glad to hear that it is no problem for you with the current layout. :)
     
  12. Jean-christophe Pires

    Jean-christophe Pires Registered

    Joined:
    Nov 1, 2012
    Messages:
    34
    Likes Received:
    0
    hi,

    Iwould like to make an img by vehicule, how can i do it??
     
  13. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Hi Jean,

    I would like to answer your question, but I really don't know what u mean by that regarding the live timing.

    But guessing u might mean taking a picture In-Game, u can either hit the F12 key making a screen shot or u can use FRAPS.

    Cheers
    Frank

    ISI Readme
    Code:
    F12 - Takes a screenshot and stores it by default off the base rFactor directory as "UserData\ScreenShots\GRABxxx.JPG".
    
     
    Last edited by a moderator: Apr 7, 2013
  14. Valbuena72

    Valbuena72 Registered

    Joined:
    Dec 23, 2011
    Messages:
    194
    Likes Received:
    0
  15. Valbuena72

    Valbuena72 Registered

    Joined:
    Dec 23, 2011
    Messages:
    194
    Likes Received:
    0
  16. Valbuena72

    Valbuena72 Registered

    Joined:
    Dec 23, 2011
    Messages:
    194
    Likes Received:
    0
  17. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
  18. jcarrest

    jcarrest Registered

    Joined:
    Jan 11, 2012
    Messages:
    6
    Likes Received:
    0
    Hey, great job.

    A good system but I can not run with ubuntu.

    the "status.php" says online but hotlaps notes:

    LifeView VM Lite
    Database connection error.
    try again
    Version 2.0 beta [Build: 20120628]
    Copyright 2011 - 2012 Vortex-Motorsports

    ------
    Anything less indicates monitor.php:

    LifeView VM Lite
    -----

    The marquee.php course:

    No session

    ------

    Explained this, the big mistake that I have SL.exe according to the log, if I'm not mistaken, is the path to CurrentScoring.xml

    normal for a script in linux would be the following:

    .wine/drive_c/Archivos\ de\ programa/rFactor/VMHotlaps/CurrentScoring.xml

    please, tell me what I can do: (

    (BTW, I have thought to send the file to translate it into Spanish)

    tks!!!
     
  19. Valbuena72

    Valbuena72 Registered

    Joined:
    Dec 23, 2011
    Messages:
    194
    Likes Received:
    0
    If it bothers you, there are no worries for me to give up;)
    I block someone on worries yet very simple and (probably useless)

    - No links to drivers who have 0 tours in LAPS column (use IF conditions I think)

    - Switch between PITS & DNF (retired) as the original (Livetiming ALMS)
    If DNF = Red Square with R
    If in the stands with Blue Square = P (as at present)

    - Change the icons of class as the original
    -Add the following columns
    . BEHIND LEADER
    . BEHIND NEXT POS
    . BEHIND IN NEXT CLASS
    If the variables are available

    -Unable to retrieve the time spent in the pits?
    -Unable to retrieve the fastest driver?
     
  20. Frank Geyer

    Frank Geyer Registered

    Joined:
    Oct 5, 2010
    Messages:
    222
    Likes Received:
    3
    Don't worry, I am not worried ... ^^ *big grin* ... so do whatever u feel like to do.

    But I have one note to make. U gotta understand, that I cannot support the customization, when it exceeds a certain level of complexity away from default.

    You will find the fastest overall lap time in table `sessioninfos` as `TopS1`, `TopS2` and `TopLap`.

    Cheers
    Frank
     

Share This Page