Visibility problem of shadows

Discussion in 'Technical & Support' started by unrealnoise, Jun 20, 2018.

  1. unrealnoise

    unrealnoise Registered

    Joined:
    Dec 20, 2010
    Messages:
    38
    Likes Received:
    0
    Hi all!

    Sry for the new topic, but I can't see any solution for my promblem in the forum. Maybe you can help me!

    Starting from the 45th second my problem is "spectacular"...



    I tried so many settings, but these didn't changes nothing.
    I tried modification nvidia and rf2 settings, but the results are same...

    I didn't see any setting in player.json for my issues.

    This is a very big disappointment for me.

    my PC: i5 8600k - GTX 1060 3GB - 1080p
     
  2. xzess

    xzess Registered

    Joined:
    Oct 5, 2010
    Messages:
    37
    Likes Received:
    4
    No solution yet, one guy touched things in the Pc BIOS (cpu clocks), and shadows went back for him. For me and I know others there's no solution, just shadows appear in 20 meters in front of you, no progressive LOD no nothing...

    The worts is that is a known problem, and devs didn't say a word, not a good way to threat customers.
     
    UsedMomo likes this.
  3. unrealnoise

    unrealnoise Registered

    Joined:
    Dec 20, 2010
    Messages:
    38
    Likes Received:
    0
    Thx!

    But I tell some news: I check that's problem from different camera angles, and I saw this problem only in _cockpit_ view. The other views are good for me... Interesting...
     
  4. marvelharvey

    marvelharvey Registered

    Joined:
    Apr 25, 2013
    Messages:
    274
    Likes Received:
    92
    It's a problem that we've reported, but 397 are unable to reproduce their end. If they can't reproduce the problem, they won't be able to find a solution.
    Luckily, it you're not using VR, there's a stop-gap solution: https://forum.studio-397.com/index.php?threads/please-help-find-my-shadows.59891/page-2#post-944840

    Basically, you no longer user cockpit view, but rollbar/bumper cam. Then using a plugin, move the position of the 2nd camera to where the cockpit camera should be.
     
  5. unrealnoise

    unrealnoise Registered

    Joined:
    Dec 20, 2010
    Messages:
    38
    Likes Received:
    0
    Thank you very much!

    After reinstalled the win10 and after then clean steam and rF2 install I can tell that the problem not solved.
    I try still something new thing in the BIOS, OC, settings, anything else... If I can fix it I will write for the forum.

    And yes, I'n not using VR yet. :)
     
  6. xzess

    xzess Registered

    Joined:
    Oct 5, 2010
    Messages:
    37
    Likes Received:
    4
    Why you know they can't reproduce the problem?, they never said nothing in the forum, they never asked people with the problem, so I don't know how they can reproduce the problem. And also the shadows in non cockpit camera are short too, but longer than cockpit camera, in my case they are just a bit longuer, not a solution for me.
     
  7. Frankalexandre

    Frankalexandre Registered

    Joined:
    Jan 3, 2012
    Messages:
    97
    Likes Received:
    10
    Turning on hyperthreading solved it for me.
     
  8. marvelharvey

    marvelharvey Registered

    Joined:
    Apr 25, 2013
    Messages:
    274
    Likes Received:
    92
    Ah sorry, I had a long back and forth with @Christopher Elliott on Discord and no matter what he and others tried, they were unable to reproduce the shadow issue on their machines.

    I now run the game with no shadows at all :(
     
    Last edited: Jun 22, 2018
  9. xzess

    xzess Registered

    Joined:
    Oct 5, 2010
    Messages:
    37
    Likes Received:
    4
    I use AMD. And I tried different bios configs. Not solved.
     
  10. unrealnoise

    unrealnoise Registered

    Joined:
    Dec 20, 2010
    Messages:
    38
    Likes Received:
    0
    I bought a new card today. Now I use a GTX1070Ti. But the problem still on.
     
  11. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    2,763
    Likes Received:
    849
    @unrealnoise You may want to check with Nvidia drivers 388.71. I get no late appearing tree shadows and I have that driver version installed (shadow setting @ high). The running guardrail shadows I get, but it was a problem on Lime Rock even in DX9.
     
  12. UsedMomo

    UsedMomo Registered

    Joined:
    Jul 11, 2017
    Messages:
    86
    Likes Received:
    46
    In this market? Did you win the lottery? o_O

    All kidding aside, I also have the same problem. I usually keep shadows turned off anyway, for performance issues.
     
  13. unrealnoise

    unrealnoise Registered

    Joined:
    Dec 20, 2010
    Messages:
    38
    Likes Received:
    0
    I got tired of waiting. If I wait a lot of time I don't know to sell my previous card a "good" price...
     
  14. Amarildo Junior

    Amarildo Junior Registered

    Joined:
    Aug 7, 2017
    Messages:
    220
    Likes Received:
    140
    This is not a problem with the BIOS, or video drivers, or clocks, or Windows, or the GPU. It's something S397 introduced with the latest build of the game. The fact that suggestions to "solve" this are to do anything more than to wait for the devs to fix it is ridiculous, specially the ones that say "re-install Windows and the game". Some of us use our computers for content production, this is not and should not be an option.

    One more bug in rF2. G29 not working properly, buggy wipers, radioactive reflections/lights with no option to disable the bloom, and now this. It's just a shame.
     
    Mibrandt likes this.
  15. Frankalexandre

    Frankalexandre Registered

    Joined:
    Jan 3, 2012
    Messages:
    97
    Likes Received:
    10
    I repeat, this problem was solved for me when i turning on hyperthreading. I can reproduce the problem again turning hyperthreading off...it is very clear. Despite i made the post here and other threading nobody from Studio 397 contacted be asking for logs or other files where they can see what changes on my system when hyperthreading is on, so i can conclude they are not interested. I'm sorry for those who cant play with normal shadows, i know how irritating this bug is.
     
    UsedMomo likes this.
  16. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    626
    Likes Received:
    373
    Regarding the radioactive reflections/lights....bloom.
    Are you using DX9 content with the DX11 build?
     
  17. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    731
    Likes Received:
    374
    Not all computers have hyperthreading, so unfortunately it is not something everyone can test.
    Just remember also, it isn't an issue that makes rF2 crash or unplayable so the devs wouldn't have it as a top priority, unfortunately.
    I suffer from shadow redraw too, but in a race, it's the last thing I'm worrying about.
    It is important to report bugs and glitches but I sometimes think people forget it is a racing sim not a Sunday drive scenery tour.

    I've had shadow redraw issue before the last update.

    "radioactive reflections/lights with no option to disable the bloom"
    Sounds like you are using DX9 mods/locations.
    Have you tried different post effects or none at all?
    Just a few ideas. ;)

    edit: :oops: Sorry @lagg I overlooked your post.
     
    lagg likes this.
  18. Amarildo Junior

    Amarildo Junior Registered

    Joined:
    Aug 7, 2017
    Messages:
    220
    Likes Received:
    140
    Official Silverstone with official C6 ZR1.
     
  19. unrealnoise

    unrealnoise Registered

    Joined:
    Dec 20, 2010
    Messages:
    38
    Likes Received:
    0
    I tried the betas after probably I tried everything else. I check the older rF2, maybe it will be work fine. And YES! The simple 1109 (Not dx9!) is good for me! The shadows are back!

    But when I start the lastest beta (1110) the shadows are gone from cockpit view!

    I wrote that for the support.
     
  20. Dmitri

    Dmitri Registered

    Joined:
    Jul 4, 2018
    Messages:
    1
    Likes Received:
    0
    same shit here, from every on-board camera the difference only in distance.
    Win7 64
    i5 8400
    ASUS GT 1060 6g
     

Share This Page