UI no response with any input (mouse & keyboard) after click ESC

Discussion in 'Bug Reports' started by flyelfrick, Jun 21, 2020.

  1. flyelfrick

    flyelfrick Registered

    Joined:
    May 15, 2013
    Messages:
    14
    Likes Received:
    0
    The UI seems lost focus after click ESC key from track. Can see rF2 still running but just can't control it anymore.
    This issue happened after Windows 10 2004 upgrade, have done below steps but issue still happen.
    - Delete and re-install main program (also install all of in Support folder again)
    - Disable Windows gaming mode
    - Upgrade the latest Nvidia display driver
    - Test with single, online mode
    - Test both old & new UI
    - Test both full screen, window mode
     

    Attached Files:

  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,925
    Likes Received:
    3,419
    Nothing obvious in the trace files. I feel like this might be some obscure setting or background program affecting things rather than anything you're doing with the game or drivers. Hopefully someone can work it out (or knows from experience what might cause it).

    Try without your controllers plugged in.

    I'd also say remove any third-party plugins, and I guess you should just to be sure, but extremely unlikely the sharedmemorymap plugin will cause any problems like that. What are you using that with?

    Any other gaming/graphics related diagnostics or performance logging tools running? Chat programs, macro programs, controller related programs... this could be difficult to work out, if you're lucky you'll stumble across it.
     
  3. flyelfrick

    flyelfrick Registered

    Joined:
    May 15, 2013
    Messages:
    14
    Likes Received:
    0
    Thanks for feedback, its really stranger issue.
    When test, only lunch rF2 (clean install, no plug-in and 3rd-party apps running) and using mouse + keyboard to test.
    I have read trace log too, yes, not found any error in log file. Have Google this with several key words (freeze, no response, and etc) but seems not thing similar as what i have.
    Maybe this an new issue relative with Windows 2004, I really don't know.
    I also have AC, ACC and others sim racing game title, but only rF2 has this stranger issue~ really sadly.
    Hope Studio-397 can provide any suggestion for me, otherwise rF2 became not playable for me.....
     
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,925
    Likes Received:
    3,419
    The rFactor2SharedMemoryMap plugin isn't standard - what tool are you using with it?
     
  5. flyelfrick

    flyelfrick Registered

    Joined:
    May 15, 2013
    Messages:
    14
    Likes Received:
    0
    still happened after disable all of plug-in.
     
  6. flyelfrick

    flyelfrick Registered

    Joined:
    May 15, 2013
    Messages:
    14
    Likes Received:
    0
    Do another clean install (delete \Program Files (x86)\Steam\steamapps\common\rFactor 2 and re-download from Steam).
    And found the UI stop response even type text before enter track. More trace log files as attachment.
    rFactor2 2020-06-21 17-53-41-197.jpg
     

    Attached Files:

  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,925
    Likes Received:
    3,419
    The UI is just not responding to typing and clicking anymore, right? The time is still counting?

    Silly question, does alt-tab and alt-tab bring it back? (indicating just a loss of focus - in which case a tool like windows focus logger might be able to help. But I suspect this is deeper than that.)
     
  8. flyelfrick

    flyelfrick Registered

    Joined:
    May 15, 2013
    Messages:
    14
    Likes Received:
    0
    Yes, the time is still counting, and alt-tab not bring it back.
    Have tested with window mode, when click alt-tab, the rF2 window can't moving too. But can see rF2 still running.
    Have ask many friends that play rF2 on Windows 10 2004 too, no one have such issue.
     
  9. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    679
    You could try to set the following value in the player.json file to false
    "Pause If Focus Lost":true,
    Maybe that helps.
     
  10. lzylzylzy130

    lzylzylzy130 Registered

    Joined:
    Jun 27, 2020
    Messages:
    2
    Likes Received:
    0
    I got the same problem with Windows 10 20H2.
    Click any button on the keyboard will cause the UI to freeze.

    More information:
    Just purchased the game and had a fresh install. The version of the Windows is 20H2. The graphic card is 2070super with the latest driver. If I click any button on the keyboard, the game UI will freeze, but it’s still running. For example, I can see the broadcast image of the AI car is still alive. Other games didn’t have this problem. Any solutions?
     
    Last edited: Jun 27, 2020
  11. flyelfrick

    flyelfrick Registered

    Joined:
    May 15, 2013
    Messages:
    14
    Likes Received:
    0
    Hope Studio-397 will take a look with this issue. Finally I am not alone.
     
  12. yashiman

    yashiman Registered

    Joined:
    Jan 16, 2012
    Messages:
    44
    Likes Received:
    38
    I heard to my friends to same things after Windows10s 2020 May update(2004) .
    One of them tried rollback Windows and was successful.
    Did you try rollback after there?
     
    Last edited: Jul 6, 2020
  13. lzylzylzy130

    lzylzylzy130 Registered

    Joined:
    Jun 27, 2020
    Messages:
    2
    Likes Received:
    0
    It’s more than ten days after the upgrade so it’s unable to rollback windows.
    But I have a fresh install of windows and the problem is solved. It’s really annoying to reinstall all my softwares but the game runs normal after that.
     
  14. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    806
    Likes Received:
    494
    Do you run any other graphics programs in the background like afterburner? Only that I saw in another thread where someone had problems with things not working and they stopped afterburner stealth mode and solved their issue.
     
  15. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,245
    Likes Received:
    1,827
    I think these windows updates reset usb ports and such. I think someone had this same problem a year or two ago. Installing the latest motherboard/chipset drivers seemed to be the fix. (usb, sound, etc)
     
  16. norick

    norick Registered

    Joined:
    Feb 16, 2014
    Messages:
    5
    Likes Received:
    2
    When using some apps users of the Microsoft Input Method Editor (IME) for Chinese and Japanese might receive an error, or the app might stop responding or close when attempting to drag using the mouse.

    ***

    Select Start, type Settings and select it or press enter.
    Type IME settings into the search box within Settings and select the IME settings that are appropriate to your language, for example Japanese(or chinese) IME Settings.
    Select General.
    Turn on Use previous version of Microsoft IME.
    ***
    try this
     
    Last edited: Jul 17, 2020
    flyelfrick and yashiman like this.
  17. HUANGJIN169

    HUANGJIN169 Registered

    Joined:
    Dec 11, 2019
    Messages:
    4
    Likes Received:
    0
    I have the same problem
    Before entering the game, it is completely controlled
    After entering the game, press the ESC mouse and keyboard can not move
    Can't return to the lobby to choose other vehicles and tracks
    Can't do anything
    The computer is completely out of contro
     
  18. norick

    norick Registered

    Joined:
    Feb 16, 2014
    Messages:
    5
    Likes Received:
    2
    Japanese(or chinese)
    Turn on Use previous version of Microsoft IME.
     
  19. flyelfrick

    flyelfrick Registered

    Joined:
    May 15, 2013
    Messages:
    14
    Likes Received:
    0
    Thanks, the issue can be fixed with ur suggestion.
     
  20. HUANGJIN169

    HUANGJIN169 Registered

    Joined:
    Dec 11, 2019
    Messages:
    4
    Likes Received:
    0
    thank you for your reply
    Unfortunately
    I don’t know what Microsoft IME means or how to set it up
     

Share This Page