Trouble starting RF2 for first time

Discussion in 'Technical & Support' started by K3773R, Apr 3, 2020.

  1. K3773R

    K3773R Registered

    Joined:
    Apr 3, 2020
    Messages:
    1
    Likes Received:
    0
    When I try to launch single player from the launcher, I get the RF2 splash screen for about 15 seconds, and then it kicks me back to the launcher. I've verified game files as instructed. Trace file is attached.
     

    Attached Files:

  2. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,431
    Likes Received:
    673
    It seems in the trace file, as if the problem appears at the point when the shaders get loaded.
    Maybe the problem is caused by the windows user rights, that the shaders can not be extracted.
    Try this:
    Start steam as usual.
    Then go to the folder ..\Steam\steamapps\common\rFactor 2\Launcher
    Rightclick on the file "Launch rFactor.exe" and select "run as administrator".
    Does that help?
     
  3. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,995
    Likes Received:
    1,340
    Bang: 9th line: 1.21s osman.cpp 1024: exe is 32-bit
    Start the Launcher and make sure the Force 32-bit is not ticked.
    rF2 or Steam shouldn't need to be run as admin
    @K3773R what are your computer specs?
    launch.JPG
     
  4. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,431
    Likes Received:
    673
    But it can help to identify problems.
     

Share This Page