Trees

Discussion in 'Track Modding' started by Simon Peace, Mar 5, 2012.

  1. Simon Peace

    Simon Peace Registered

    Joined:
    Nov 10, 2011
    Messages:
    121
    Likes Received:
    0
    but in max the tree is in the correct orientation... in rF2 it is hanging from the sky... not a nice thing to have to have trees upside down in the model generating software... Ethone can you explain what you mean by using the mirror and or UVW Mapping to fix this issue. cheers
     
  2. Luc Van Camp

    Luc Van Camp Track Team Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    1,030
    Likes Received:
    14
    What he means is mirroring vertically, effectively putting the tree upside-down in 3ds Max, and then flipping the mapping to fix it again.
     
  3. ethone

    ethone Registered

    Joined:
    Nov 30, 2011
    Messages:
    1,153
    Likes Received:
    37
    Yep, mirror the whole object or the mapping vertically until it looks right in both 3ds max and when exported. I've only dabbled with the new billboard tree shader but when I set up my trees they consistently ended up with the the wrong side up in 3ds max 2011.

    In essence (and this might not matter at all for you Simon) when I draw a plane in any view the vertices are numbered wrong. I guess this is a new "feature" of 3ds max 2011. They're always top-right-to-bottom-left triangulated.
     
  4. Simon Peace

    Simon Peace Registered

    Joined:
    Nov 10, 2011
    Messages:
    121
    Likes Received:
    0
    ethone...

    I am using 2010 and my numbering of vertexes in a plane goes TL = 3, TR=4, BL=1, BR = 2.
    the triangulation was modified TL to BR (3 to 2)
    and according to "staff" think it was luc, the baseline is the important on vertex 1 -> 2
    my issue is that without the alpha vertex number being changed to make the bill board move, it appears in max the correct way and also exported... as soon as i change the alpha vertex number to 90 (as directed for no real reason but no default) the tree pops upside down.

    I have tried the mirroring and remapping but cannot seem to get that to work either.

    Is this actually an issue with the billboarding (alpha vertex related)?
     
  5. Simon Peace

    Simon Peace Registered

    Joined:
    Nov 10, 2011
    Messages:
    121
    Likes Received:
    0
    also (and yes i checked my units) the tree seems to be 50% of the size that I have it in max... this is when Alpha Vertex = 90 but not when they are set to 100...

    also the tree doesn't sit in the correct x y position when alpha vertex = 90 but is in the correct x y position when Alpha Vertex = 100...
    no other changes made when exporting the "tree"...
     
  6. ethone

    ethone Registered

    Joined:
    Nov 30, 2011
    Messages:
    1,153
    Likes Received:
    37
    Simon, I'm only guessing here but have you perhaps not set up the pivot correctly with the buttons at the bottom of the Screen-Aligned Quads section of the Instance tab?

    Could you perhaps post the .max file with just the tree that's causing you issues?
     
  7. Simon Peace

    Simon Peace Registered

    Joined:
    Nov 10, 2011
    Messages:
    121
    Likes Received:
    0
    View attachment 1626

    this is the max file... this is as close as I have got. Note that with the Alpha Vertex set=90, the tree is 50% of the size it is when alpha Vertex set to 100...

    note that the tree should be placed at the centre of the V letter... (from plan view point of view)
    with the AlphaVertex=90 it isn't at this position.

    (ethone, i have tried the other different pivot options, but obviously bottom is the one to use for this.)
    Max 2010 in use. Windows 7 64bit
     
  8. les

    les Registered

    Joined:
    Jan 19, 2012
    Messages:
    256
    Likes Received:
    1
    does anyone have a video showing how to set this up in max from start to finish im lost and more confused than ever i looked at joesville section and i have not been able to figure this out
     
    Last edited by a moderator: Mar 20, 2012
  9. les

    les Registered

    Joined:
    Jan 19, 2012
    Messages:
    256
    Likes Received:
    1
    i followed what i could of the tutorial and guess what the tree just disappeared lol i added the gmt its in there but its like the tree is not there

    in game it gone weird can someone make a quick video maybe showing what the settings are how to set it up
     
  10. ethone

    ethone Registered

    Joined:
    Nov 30, 2011
    Messages:
    1,153
    Likes Received:
    37
    I wrote up a short tutorial for the two of you: http://www.trackcreation.net/devdiary/?p=282

    My first guess with billboards that don't show up would be that the normals need to be flipped. To test, set vertex alpha back to 100 and see if the object appears. If it does, the object only disappears when billboarding is enabled and that's usually the case when the normals face the wrong way which with billboarding will mean the object will always be facing away from the camera.

    Hope it helps, if it doesn't just shout.
     
    1 person likes this.
  11. les

    les Registered

    Joined:
    Jan 19, 2012
    Messages:
    256
    Likes Received:
    1
    boy did that help yes thank you so very much
     
  12. Jka

    Jka Member Staff Member

    Joined:
    Jan 31, 2011
    Messages:
    917
    Likes Received:
    182
    yes, nice tutorial ethone. :cool:

    Cheers!
     
  13. les

    les Registered

    Joined:
    Jan 19, 2012
    Messages:
    256
    Likes Received:
    1
    ok question on the trees when i created the trees they work turn now as there suppose too but the shadows are the shape of the plane square i dont see leaves or shadows of the leaves what do i need to do to get those showing ??
     
  14. toebee

    toebee Member

    Joined:
    Oct 5, 2010
    Messages:
    382
    Likes Received:
    389
    Mark the gmt as a shadow caster and select textured.
     
  15. les

    les Registered

    Joined:
    Jan 19, 2012
    Messages:
    256
    Likes Received:
    1
    ok ill give that a try and see what happens ty
     
  16. les

    les Registered

    Joined:
    Jan 19, 2012
    Messages:
    256
    Likes Received:
    1
    ok tried and marked as texture but still getting the plane image square showing up not the shadows of the trees im using the t1 stamped vertex i think that is right going to experiment and see if i can get this figured out
     
  17. ethone

    ethone Registered

    Joined:
    Nov 30, 2011
    Messages:
    1,153
    Likes Received:
    37
    The shadow caster settings are not saved to the .gmt but to the .scn.
    So you need to re-generate the .scn file for the change to take effect.
     
  18. les

    les Registered

    Joined:
    Jan 19, 2012
    Messages:
    256
    Likes Received:
    1
    ok ill give this a try
     
  19. les

    les Registered

    Joined:
    Jan 19, 2012
    Messages:
    256
    Likes Received:
    1
    trees are now ready woo hoo shadows work thank you everyone for all the help
     
  20. les

    les Registered

    Joined:
    Jan 19, 2012
    Messages:
    256
    Likes Received:
    1
    i have another question in the way of vertex numbering on the tree billboards this is 3ds max related the vertex numbering is there a command to turn on the vertex numbers too see if there right
     

Share This Page