Track Pack (Nordschleif, Le Mans, Sebring) not working + 64bits version not loading

Discussion in 'Technical & Support' started by TheBlackPath, Aug 8, 2020.

  1. TheBlackPath

    TheBlackPath Registered

    Joined:
    Aug 8, 2020
    Messages:
    6
    Likes Received:
    1
    Hi! First post here (after looking for and trying solutions since friday.. spent 4 hours... today another 5 hours. I'm done and frustrated)

    From the beginning.. ...since 2009 I used to race a lot with Rf1.. a lot. With Rf2 not that much due to lack of time.. even though from times to times..

    Yesterday I decided for the first time to buy some content to be more motivated to race againg. Bought the offer for the 4 tracks and a GT3 cars pack.

    It happens that Le Mans, Nordschleiff and Sebring won't start. I get a message of "failed to alocate memory due to 32bits .. etc". Ok. I get to look and my system is really running the 32bits version (even though I never had any problem with the old Nordscheleiff or even Targa Florio)

    Unchecked the "force 32 bits" and the game doesn't load. Black Screen.

    Unninstalled everything... reinstall. The same.

    Tried everything.. admin rights.. non admin.. run missing components from steam.. reinstall.. win updates.. deactivate antivirues.. etc.

    My System:

    Win7 64bits
    AMD Radeon HD7850 2GB
    16Gb RAM

    Thanks!
     
  2. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,023
    Likes Received:
    327
    Does your video card support DX11? If not then oh dear.
     
  3. TheBlackPath

    TheBlackPath Registered

    Joined:
    Aug 8, 2020
    Messages:
    6
    Likes Received:
    1
    yes.. it supports.

    just to add... that this "memory problem" has never happened with any tracks. Just these new ones.

    and since it is possibly linked with me not being able to use the 64bits... . Since first install the game has always been working 32bits... with new install today, still no solution.

    thx!
     
  4. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,226
    Likes Received:
    1,821
    The video card is indeed your problem. It is just not large enough(i.e. has enough Vram) to load the modern tracks. Sure you got the old Nurb working, If you compare the difference between the two, you may understand why. All the newest Laser scanned tracks have a lot of detail that most older tracks didn't possess. The fact you had to run in 32bit shows part of the problem. 32bit limits your total memory to 4gb, that is for windows and the sim. So your 2Gb video card wasn't overstuffed by textures since Windows would not allow that much data to be used in the first place. (I think we had an unofficial patch for the rF1 based GTR2 that would allow more of your memory to be used, but I've never seen that for rF2.)
    Also, keep in mind, the last roadmap included some notes about S397 abandoning 32bit support completely. There are just too few users left using it. If you want to try Sebring again, pick just one car, the absolute minimum graphic settings for EVERYTHING and then choose the 2nd layout of Sebring. It has very little trackside graphics and can be used on some lower end systems. But even that may be beyond your system. Sorry to say, you will need a 64bit operating system, a video card with AT LEAST 4Gb,(8Gb preferred) but even then you are just delaying the same thing happening again, and a fairly recent Intel or AMD Ryzen cpu. Best of luck
     
    Grey likes this.
  5. TheBlackPath

    TheBlackPath Registered

    Joined:
    Aug 8, 2020
    Messages:
    6
    Likes Received:
    1
    thanks a lot! I will source for a new graphic card.

    Now.. you say " The fact you had to run in 32bit shows part of the problem." .. ... "Sorry to say, you will need a 64bit operating system"

    it is not that I HAD to run by choice.. but there is no way to start RF2 in 64 bits (my Win7 is 64bits). Whenever I unclick the "force 32 bits" it will crash.. not even the RF logo shows up.

    Is this - system preventing me to start in 64 bits - also related to the graphics card? Because I am afraid to buy a new graphics card and keep with the problem.. because the game won't start in 64bits. Thx!
     
  6. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,226
    Likes Received:
    1,821
    I'm pretty sure it's the Vram limitation. If your version of Win7 is 64bits then that should be ok. If you purchase a new card, 1st investigate the return policy. Know in advance if you can send it back without paying a restocking fee or other nonsense. Good Luck.
     
  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,909
    Likes Received:
    3,407
    Old 32 bit programs were limited to 2GB. The 4GB patch expanded that to - drumroll please - 4GB.

    32 bit rF2, like most more recent programs, was built to address 4GB from the start. So the patch isn't needed.

    Either way games these days need more, and 2GB is indeed insufficient for a video card. 8 would be a good minimum if buying a new one.
     
    davehenrie likes this.
  8. TheBlackPath

    TheBlackPath Registered

    Joined:
    Aug 8, 2020
    Messages:
    6
    Likes Received:
    1
    ok! Thanks guys!!

    But what can I do so that the game runs in 64bit? Any idea? I use Win7 Home Edition 64 bits.
    I have already reinstalled to no success. Tried several tips I found around in foruns etc...

    I didn't care before that it was loading in 32bits because for my use it was ok.. even with 2Gb GPU, no lags etc.. of course all graphics not maxed out. Since I care more for the physics than the visuals.. no big deal. But now considering that I would be buying a GPU just because of 2 tracks (LM and Nurb) I prefer before to solve this problem just to be sure that everything is fine (I am in Spain.. here is not so easy to buy a GPU and return it "just because"...)

    Thx a lot!!!
     
  9. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,023
    Likes Received:
    327
    Game runs in 64 bit mode as default
     
  10. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,226
    Likes Received:
    1,821
    Just make sure the 'force 32bit' check box is NOT checked. (in the video config tool)
     
  11. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,909
    Likes Received:
    3,407
    He knows how to run it in 64 bit. The issue is it doesn't work. :rolleyes: ;)
     
  12. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,181
    Likes Received:
    242
    I have a GTX760 with just 2 Gig of video RAM and can run S397's Nords and Sebring with low settings. I thinking getting your game working in 64 bit mode is your first step in getting the tracks working.

    Would you have any 3rd party plugin's in your Plugin folders that could be stopping your game working in 64bit mode? There are 2 plugin folders one in Bin32 and one in Bin64. I know you said you uninstalled everything, I can say uninstall does not uninstall 3rd partly items and they need to be cleared out manually.

    You could try making a Trace log, maybe that will show something if the above did nothing.
     
    TheBlackPath likes this.
  13. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,226
    Likes Received:
    1,821
    He has already been informed WHY it won't work in 64 bit, then he asked how to ensure 64 bit is working once he replaces his vid card. Clarification, that's all.
     
    TheBlackPath likes this.
  14. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,909
    Likes Received:
    3,407
    His video card won't stop 64 bit working.
     
  15. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,226
    Likes Received:
    1,821
    It will prevent rF2 working in 64 bits, especially with the DLC tracks.
     
  16. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,909
    Likes Received:
    3,407
    The game doesn't load. It's not failing to load the big DLC, it's not loading in 64 bit. That's what the posts above say.
     
    TheBlackPath likes this.
  17. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    795
    Likes Received:
    489
    Just make sure you've run all the redistributables in the support folder. No guarantee this is the problem but it can't hurt to give it a go.
     
    TheBlackPath likes this.
  18. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,226
    Likes Received:
    1,821
    yes, we continue to agree, as far as I can tell. the game won't load in 64 bit because his video card has insufficient vram to fully load the program. A vid card with 3Gb minimum, would most likely solve his problem until another round of new textures and cockpits are added and then 3Gb won't be enough either. If someone is buying solely to race rF2 into the future, 8Gb Vram should be the target, yes less will work but look ahead, not where you are standing. If S397 continues to develop the graphics of rF2, then more and more Vram will be needed. Nords with a full field of cars that have the cockpit detail of the Ferrari 488 GT3 will certainly stress even 6Gb cards.
    Now, back to what we agree on. It won't run in 64bit. BECAUSE a 2Gb card (which may be fully capable of running some 64bit programs) just doesn't have the room for rF2 in 64bit mode. If you can get 64bit rF2 to load with a 2Gb vid card, more power to you, but his hardware won't support anything above the bare min. that rF2 offers. Replace the card, and enjoy racing, until the cpu is overloaded. :)
     
    TheBlackPath likes this.
  19. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,909
    Likes Received:
    3,407
    @TheBlackPath I've seen similar a few times and just tried to find some threads, I've only got 1 and he had to reinstall windows in order to fix the issue - there was apparently some indication as other 64 bit games weren't working either.

    Here's the thread for reference, but not really any extra info in there: https://forum.studio-397.com/index....-but-im-on-w10-64b-i5proc-is-x64.63046/page-2

    Worth checking for stuff like rivatuner mentioned in that thread, anything 'extra' you have that might interfere with games in some way (frame counters, GPU overclocking/logging, antivirus with advanced scanning, etc).

    You could maybe try creating a trace file and attaching it here, but I'm not sure how much it'll contain when the game is crashing so early.

    Also check your windows event viewer in case there's a clue in the error generated when the game crashes.

    @davehenrie we don't agree, because even a 1GB card shouldn't stop the game loading up the menu, and 64-bit vs 32-bit shouldn't uncover some weird incompatibility with the GPU. I did find a thread with someone who had to change their GPU to get 64 bit working, but that was a different first GPU (nVidia even) and again it shouldn't happen - more likely a windows installation oddity like the thread I've linked above.
     
    TheBlackPath likes this.
  20. TheBlackPath

    TheBlackPath Registered

    Joined:
    Aug 8, 2020
    Messages:
    6
    Likes Received:
    1
    Hi!!! Thx to all.. lots of inputs!! I will take a look at the suggestions!

    Since sooner or later I will be obliged to upgrade from Win7 to 10.. I am considering doing this now just to see what happens. I'll let you know.
     

Share This Page