SOLVED Today's hotfix (v1130) hard crashes dedicated server

Discussion in 'Bug Reports' started by ELafrance, Sep 10, 2022.

  1. ELafrance

    ELafrance Registered

    Joined:
    Apr 4, 2022
    Messages:
    11
    Likes Received:
    1
    Seems to be caused when people have a big accident in a wall that used to make their client crash but now dedicated hard crashes itself. Can't find any way to rollback to v.1129 :(

    Edit: Enforcing damage (disabling allow invulnerability) seems to fix it, but AI also make server crash if they hit a wall. Not a valid option for Nordschleife-Traffic :p
     
    Last edited: Sep 10, 2022
    Shane Gilfeather likes this.
  2. Alex Sawczuk

    Alex Sawczuk Administrator Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    731
    Likes Received:
    769
    Hi,

    We will look into this. You can use previous-release branch if required. I doubt this is related to yesterdays hotfix but we will investigate.
     
    Last edited: Sep 10, 2022
    Lars and Corti like this.
  3. Shane Gilfeather

    Shane Gilfeather Registered

    Joined:
    Dec 19, 2019
    Messages:
    42
    Likes Received:
    8
    I am also getting this fault since i updated the HOTFIX last Night. Have not been able to run a server since. It crashes with only AI in Server. No Real Drivers. It also played up with my MAS.exe as i was unable to create any new packages until i started using the MAS2_x64.exe. My Server is still crashing since. I have added my Trace in the RF2 Discord Channel #support
     

    Attached Files:

  4. Alex Sawczuk

    Alex Sawczuk Administrator Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    731
    Likes Received:
    769
    Can you post complete details about what you are running when the server is crashing please?

    including which cars were you using? which tracks? what settings etc?
     
  5. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,235
    Likes Received:
    843
    Had a look at the trace file, the only thing that looks odd is where is the server installed, on E or D drive;
    Start of trace says E drive, but at the 5.21 second mark says D drive 449C6FDF-23D1-4566-8633-129F7A7828D2.jpeg

    80A83B91-9BF5-4538-8F7C-7AFE4112BBE3.jpeg
     
  6. delapecs

    delapecs Registered

    Joined:
    Feb 14, 2012
    Messages:
    223
    Likes Received:
    70
    Crashing here all night, my solution is go to bed :oops:
     
  7. ELafrance

    ELafrance Registered

    Joined:
    Apr 4, 2022
    Messages:
    11
    Likes Received:
    1
    I tried multiple tracks<->cars combos and they all end up crashing, if there are AI. No AI, even having a big wall crash like I had said, server stays rock solid. I also tried official Nurburgring with official Ligier P320 as a new mas file and with 30 AI it takes from 1 to 10 minutes to crash the server. Watching the replay, at least 1 AI car gets out of track then they all start to wiggle and server crashes. As for settings, they are different for each server I run, but one isn't out of the ordinary. This is Lafbros-Ford VS Ferrari '67 that is currently live running v1128. player and Multiplayer JSON files attached.
     

    Attached Files:

  8. Shane Gilfeather

    Shane Gilfeather Registered

    Joined:
    Dec 19, 2019
    Messages:
    42
    Likes Received:
    8
    OK. I have run the server again. It failed after 50mins. To be honest i have tried all my servers and content combos. ALL with the same result. Please see attachments.

    GOANNA........ Where would i go to trace that as i dont use E: Drive.
     

    Attached Files:

  9. Shane Gilfeather

    Shane Gilfeather Registered

    Joined:
    Dec 19, 2019
    Messages:
    42
    Likes Received:
    8
    Cont'd Server Settings.....sorry i couldnt upload individual files
     

    Attached Files:

  10. Shane Gilfeather

    Shane Gilfeather Registered

    Joined:
    Dec 19, 2019
    Messages:
    42
    Likes Received:
    8
    Trace from Todays Crash
     

    Attached Files:

  11. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,235
    Likes Received:
    843
    You starting your server from a shortcut? If so right click on it and select properties and check that the “target” and “start in” boxes both point to your D drive install.
     
  12. Shane Gilfeather

    Shane Gilfeather Registered

    Joined:
    Dec 19, 2019
    Messages:
    42
    Likes Received:
    8
    Wow........ Looking at it they are all wrong . I dont know how they worked in the first place. I only saw it when i copied the string to Notepad. (Hard to see when it in the small properties window)

    This is what it looked like;
    "D:\rFactor2_Dedi\Bin64\rFactor2 Dedicated.exe" E:\rFactor2\Bin64\rFactor2 Dedicated.exe +profile=BTCCLeague +trace=2 +traceFlush

    New String:
    "D:\rFactor2_Dedi\Bin64\rFactor2 Dedicated.exe" +profile=BTCCLeague +trace=2 +traceFlush

    Im starting a new server to test. Its been up for 10 mins so far but its around the 50min mark it usually crashes.

    Thanks @Goanna
     
  13. Shane Gilfeather

    Shane Gilfeather Registered

    Joined:
    Dec 19, 2019
    Messages:
    42
    Likes Received:
    8
    Server just Crashed again. Latest Trace file.
     

    Attached Files:

  14. ELafrance

    ELafrance Registered

    Joined:
    Apr 4, 2022
    Messages:
    11
    Likes Received:
    1
    Please disregard what I said about crashing in walls, seems like they were just many coincidences in a row. Here's my trace of my fastest crashing server w/o anyone logging in, only AI.
     

    Attached Files:

  15. Alex Sawczuk

    Alex Sawczuk Administrator Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    731
    Likes Received:
    769
    FYI this does not appear to be a 1130 player file that you have attached. If you could attach a file that crashes that would be great.
     
  16. Shane Gilfeather

    Shane Gilfeather Registered

    Joined:
    Dec 19, 2019
    Messages:
    42
    Likes Received:
    8
    Did you get my PLR files? Its in a ZIP above
     
  17. Alex Sawczuk

    Alex Sawczuk Administrator Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    731
    Likes Received:
    769
    Yeah I saw it, going through one thing at a time, also it's Sunday so not sure I'll get to yours today. Are you running official content though? (EDIT: Clearly you're not no)

    I currently have 32 Ligiers running at Nords 24h on my test server, I'll see if it crashes.

    If any of you have an rFmini.dmp in the userdata folder that could be useful too if you know it's from one of these crashes.
     
  18. delapecs

    delapecs Registered

    Joined:
    Feb 14, 2012
    Messages:
    223
    Likes Received:
    70
    I have been able to reproduce the problem with a clean install with the server on the same LAN.
    These are the steps I followed:
    - Clean install with steamcmd
    - Navigate to C:\Users\username\AppData\Roaming\ folder and delete all the .dat files
    - Install USF2000 + Toban, make mod with MASx64.exe
    - Serverkeys from the complete game installation
    - Change HTTP port 27013 in multiplayer
    - With ModMgr, manually install rfcmp from this tracks and cars:

    Barcelona2021 v1.23, Silverstone_2016_v2.16, rf2_Watkins_Glen_International_v1.15, sm_CTMP_v1.03, SpaFrancorchamps_2020_v1.15, Zandvoort_2020_v2.61

    Ferrari_488_GT3_2020_v1.45, McLaren_720S_GT3_2018_v1.75, Porsche_911_GT3_R_2018_v1.77

    - Make mod with MASx64.exe, start the server.
    - From the client machine I start rFactor2, multiplayer and connect to the server.
    - Activate the AI to see what happens.
    - Crash to desktop on the client with the game running in the background. Had to kill process. This happens always I quit the game lately.
    - Server already crash to desktop some time after.
     

    Attached Files:

    Last edited: Sep 11, 2022
  19. Shane Gilfeather

    Shane Gilfeather Registered

    Joined:
    Dec 19, 2019
    Messages:
    42
    Likes Received:
    8
    Something worth noting is that the Server seems to be ok with NO AI (Over an hour). As soon as you ad AI it crashes within 5 mins
     
  20. delapecs

    delapecs Registered

    Joined:
    Feb 14, 2012
    Messages:
    223
    Likes Received:
    70
    New logs from new attemp.
    This time in Silverstone, perfect during formation lap and then the servers crash.
    I have logs and config files from the server and the client side (no minidump file generated).
    Config of the server if it helps.

    1.jpg 2.jpg 3.jpg
     

    Attached Files:

    Last edited: Sep 11, 2022

Share This Page