Thrustmaster ts-pc driver crashing rf2

Discussion in 'General Discussion' started by hangon, Dec 12, 2017.

  1. hangon

    hangon Registered

    Joined:
    Aug 14, 2012
    Messages:
    57
    Likes Received:
    14
    New firmware just recently came out for the thrustmaster wheels{http://www.bsimracing.com/thrustmaster-new-firmware-updates-for-force-feedback-wheels/} ...I updated the firmware....now everytime I go to either detect or go to wheel and try to map left, or right, it crashes rf2. I can map my pedals fine{fanatec] but anything to do with the wheel immediatly crashes rf2? And yes, i have deleted json file and let rf2 make new one. Any other sims eg: Assetto, pc2 there is no problem...i still had to remap the wheel, but it reconized it..and remapped fine...so i'm assuming this is a rf2 issue?? I am not going to try to reinstall firmware to older version, it was somewhat a pain updating to new firmware..so..Rf2 is a non working sim untill they correct what is causing this...anyone else out there with the same wheel base{TS-PC Racer} have it working??please let me know if you do!!!
     
  2. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    3,778
    Likes Received:
    3,562
    I'm not getting any crashes on the v6.00 on the TS-PC.
    Can you try LOAD in controls, then pick 'Thrustmaster TS-PC Racer' and after if you need to try reassigning controls again.

    Also if you can give us more information, if there are any error messages, or beep or display anything that might indicate the firmware is indeed the issue.
     
  3. hangon

    hangon Registered

    Joined:
    Aug 14, 2012
    Messages:
    57
    Likes Received:
    14
    Hmmm..okay..working for you..so it is obviously on my end?? Yes, I click load and pick the TS-PC Racer....and i get this[attached screenshot} ...as soon as I try to map anything..eg: wheel rotation I get a "RF2 is no longer responding error..no beeps ..run out of ideas?? not sure what to try?? https://drive.google.com/open?id=1GkDRj5T9iqmfeqhXFpuQCGV3pvx_RbDV
     
  4. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    3,778
    Likes Received:
    3,562
  5. hangon

    hangon Registered

    Joined:
    Aug 14, 2012
    Messages:
    57
    Likes Received:
    14
    yes..i did that..said 2 files to be reaaqquired..did that..same thing still...but..I have made a little progress..unplug my pedals..my shifter...delete json..restart rf2..press detect..or load..finds my wheel no problem..map it..all fine..only problem now..i have no pedals ..or hshifter...I can go plug them into computer now..but obviously rf2 is still running..does not know they are there..shut down rf2...restart..rf2 has stopped working!!! This is so frustrating...obviously i had my wheel,pedals, shifter all working before i did this firmware update..so, they all did work at one time...this should not be this difficult!? In assetto..no problem ..reconized right away..remapped wheel..pedals all still worked ..is there a EXACT sequence I have to go through to get the wheel,pedals ,shifter all working???
     
  6. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    3,778
    Likes Received:
    3,562
    ok try this:
    1. Close rFactor 2
    2. Go into ....\Steam\steamapps\common\rFactor 2\UserData\player
    3. Find the file Controller.JSON, remove it from the folder
    4. Restart rFactor 2
    5. Try to LOAD 'Thrustmaster TS-PC Racer' profile again
    6. Re-assign all your controller mappings
     
  7. hangon

    hangon Registered

    Joined:
    Aug 14, 2012
    Messages:
    57
    Likes Received:
    14
    yes..been doing that..same old crap...it appears that when i have all my controllers plugged in there is some type of conflict?? sure i can load the TS-PC racer driver...but..as soon as i try to map the rotation rf2 crashes...pedals i can map..shifter I can map....if I press detect..it finds the pedals immediatly...unplug the pedals,shifter..delete controller json..restart rf2...press detect, it finds the TS-PC Racer immediatly..and like i had said..i can map the wheel..no crash....so...it appears as soon as there is another controller plugged in with the wheel ,it is only seeing that??? I've tried so many diffrent things...spent several hours ..i guess all i can do is go play a diffrent sim and hope the new ui might fix this mess??? Reinstalling rf2 i cant see making any diffrence...deleting the controller json should have worked..oh well..thanks for your help:(
     
  8. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    3,778
    Likes Received:
    3,562
    Can you send me your Controller.JSON
     
  9. hangon

    hangon Registered

    Joined:
    Aug 14, 2012
    Messages:
    57
    Likes Received:
    14
    okay ..here it is ..had to put it in zip file ..it said not allowable ext otherwise
     

    Attached Files:

  10. hangon

    hangon Registered

    Joined:
    Aug 14, 2012
    Messages:
    57
    Likes Received:
    14
    I think i got it narrowed down..Got rf2 working with wheel and pedals...as soon as I plug in the shifter and start rf2 and go to options/controls( try to map the shifter) rf2 crashes...or if I have it running...plug in the shifter..go to options/controls same outcome..rf2 crashes... the shifter is a Fanatec SQ 1.5 and using the Clubsport usb adapter{https://www.fanatec.com/au-en/sim-racing-hardware-accessories/clubsport-usb-adapter-au.html} since I'm not using a fanatec wheel. Though, I did have all working previously before the update...???
     
  11. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    3,778
    Likes Received:
    3,562
    Ok did you make sure your drivers and firmware are updated for the Fanatec USB adapter?
     
    Superdevil likes this.
  12. hangon

    hangon Registered

    Joined:
    Aug 14, 2012
    Messages:
    57
    Likes Received:
    14
    Thanx Chris..I never thought of that because the "other' sims worked ...but alas..sure enough, there was a new driver/firmware for Fanatec adapter...installed..WORKS!! ..Thank you Chris for all your help..appreciate it...for a bit there i was in despair thinking i was not going to be able to drive my beloved RF2 :eek:...everything is back to "normal" :)..and I can participate in my league race :D
     
  13. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    3,778
    Likes Received:
    3,562
    That's great, glad you got it sorted :)
     
    BigDuke6 likes this.
  14. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    5,012
    Likes Received:
    1,280
    @Kamran Khan That's quite a different issue (your rF2 isn't crashing) and Christopher's post here was back in December. You should just link to him from your thread, no need to post in this one.
     
  15. Kamran Khan

    Kamran Khan Registered

    Joined:
    Mar 8, 2018
    Messages:
    5
    Likes Received:
    0
    Noted, and deleted from here.
     

Share This Page