Thrustmaster Profile Settings?

Discussion in 'Technical & Support' started by Dady Cairo, Oct 20, 2020.

  1. Dady Cairo

    Dady Cairo Registered

    Joined:
    May 11, 2017
    Messages:
    243
    Likes Received:
    160
    Hey Ho!
    Can someone tell me what settings are the right ones for my TS-PC in the Profiler?
    I had it all on standard as a Dev from RaceRoom told me,that the game does it by itself when the function in game is there.
    So i use Damper at 100 and Spring at 100 ,wich i now have set to 5%.
    Gain is at 60% with the Sparco Addon wich is standard for that wheel.
    But when i set Damper to 0% then it is off,same as spring.
    What are the correct settings for RF2?
    Many Thanx
     
  2. doddynco

    doddynco Registered

    Joined:
    Dec 13, 2017
    Messages:
    572
    Likes Received:
    1,216
    Spring and damper do nothing in Rf2 - it doesn't use those channels. Leave the gain at default.

    Edit: If I remember correctly, the TS-PC hardware actually clips at around 75-80% in the profiler (assuming you have a 100% software signal). So it may be worth upping the gain a bit to feel for clipping.

    It's a good idea to get motec or simhub so you can see the ffb software signal.

    You should get the software signal correct first by tweaking the car specific ffb multiplier, then move on to tweak the gain in the profiler - between 60-80%.

    Also, you want tto make sure the damping and spring saturation are set to 0 in your controller json. These are completely separate and not related to the settings you can see in the Thrustmaster profiler. Under all circumstances they should be turned off though.
     
    Last edited: Oct 21, 2020
    Dady Cairo likes this.
  3. DrivingFast

    DrivingFast Registered

    Joined:
    Mar 1, 2018
    Messages:
    1,638
    Likes Received:
    1,083
    No.

    Gain (global forces in the profiler) to 100%
    Constant and periodical 100%
    FFB multi for each official S397 cars to max 65%

    In doing this you will avoid excessive software and hardware clipping.

    Spring and damper to 0%

    Check with damplugin and motec ("canal FFB output %) with a GT3 (not McLaren 650) if clipping is OK with 65%, if not 60%.
    For this test don't go on the vibrators and be fast. Use sebring for example.

    THEN add force min.
    Begin with 3%.
    Test with radical XX.
    When it begin to excessively vibrate (wheel), lower the force min to 0,5%.

    I have T300, I can't give you exact FFB multi + FFB min force settings.
     
    ayrtonforever and Dady Cairo like this.
  4. ayrtonforever

    ayrtonforever Registered

    Joined:
    May 31, 2017
    Messages:
    189
    Likes Received:
    79
    sorry for the little OT, I have a Logitech G29, using the ffb output channel in MoTeC i have ffb output channel always under 100 (max value 91%) even touching kerbs with FFB multi on 80% on the Ferrari 488 GT3. can i further increase the multi or better starting playing with other values? i have now smoothing on 7 and minimum torque on 7.0 which are the default values for the G29 profile built in rf2
     
    Last edited: Oct 21, 2020

Share This Page