The server does not download or update content

Discussion in 'Technical & Support' started by JParra, Jul 14, 2021.

  1. JParra

    JParra Registered

    Joined:
    Jul 13, 2017
    Messages:
    151
    Likes Received:
    34
    Hello, we have a CMD server for a long time and lately it is not downloading and installing content updates, it keeps indicating "downloading" 0% and at the end it shows an error and indicates that it should be done by hand.

    Can you tell me if this is a known bug that I can't do anything about or is there something I can do?

    Thanks and regards

    [​IMG]
    [​IMG]
     
  2. JParra

    JParra Registered

    Joined:
    Jul 13, 2017
    Messages:
    151
    Likes Received:
    34
    Hello again, I go back to the attack, but again with no results.

    Can anyone tell me if it is a server error or my steps wrong?

    It's for continuing to fight this or letting it go.

    The update is not very heavy, 18KB the rfmod and 84MB the rfcmp (rfcmp is who carries the skinpack)

    The rfmod is downloaded correctly, but the rfcmp update with the skins is what fails.

    Thanks and regards.
     
  3. JParra

    JParra Registered

    Joined:
    Jul 13, 2017
    Messages:
    151
    Likes Received:
    34
    I want to add that the rfmod downloads and installs it without problems and that therefore if users download and install the rfcmp update by hand, when entering the server the rfmod is downloaded, installed and entered without problems, so I rule out a problem of ports.

    If rfcmp is downloaded but not installed, it is not installed when entering the server, it must be installed manually on each client.

    And that in the multiplayer.ini I have these values:
    "Enable Autodownloads": true,
    "Enable Autodownloads #": "Whether to allow clients to autodownload files that they are missing.",
    "HTTP Server Max File Size": 1000,
    "HTTP Server Max File Size #": "Maximum file size, in MB, that the HTTP server will provide",
    "HTTP Server Send Rate": 56000,
    "HTTP Server Send Rate #": "EXPERIMENTAL Data rate (kilo bits per second) at which internal HTTP Server will delivery content",
     
  4. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,019
    Likes Received:
    738
    @JParra And the Port, that is defined in the Multyplayer.JSON in the Line:
    "HTTP Server Port":XYZ,
    is open in the Firewall?
    What you can do, is to include the Content of the rfcmp into the virtual Mod (rfmod) for the Server.
    If the Download of the virtual Mod works as you have said, it will work with that Method (if nothing has changed).
     
  5. JParra

    JParra Registered

    Joined:
    Jul 13, 2017
    Messages:
    151
    Likes Received:
    34
    The port is correctly opened and redirected, in fact, the rfmod is downloaded, in the same way that the skintransfer works when we enable it.

    I have not tried to put the rfcmp in the rfmod, it is something that we do not usually do, but I will try it, thanks.
     
  6. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    532
    Likes Received:
    128
    @JParra
    I have downloaded the ROC Alpine SuperCup files. You need to get a big stick and beat the person who created the rfmod, and selected the SRC Indianapolis update mod.

    1.The rfmod seems to be corrupt (caused by the src mod)
    2.You have left spaces in the rfmod name, you should always use _ (underscores).
    3.You cannot use track updates, (src) for autodownloads. you need to repack the track, so all the files are in the one rfcmp.
     
  7. JParra

    JParra Registered

    Joined:
    Jul 13, 2017
    Messages:
    151
    Likes Received:
    34
    Greetings and thanks for responding.

    I will look for that big stick but I will be benevolent, because the creator is still learning.

    1. The rfmod does not give me as corrupt, if I install the rfcmp manually, it downloads and installs without problems and lets me enter the server.
    2. The rfmod name does have spaces, we will solve it. But the name of the problem rfcmp is Alpine_RSC.rfcmp and it has no spaces.
    3. The problem with Indianapolis is that we want that version in our circuit pack, but we never download the circuits automatically from the server, as there are usually 10 or 11, we always make a pack and upload it to Mega.
    Now, the error or problems are not given by the rfmod, if not the rfcmp, but if you think that the Indianapolis update may be the problem, we will try to make a full version for the next time, because now it is too late. The tracks have been distributed for a long time and it would be counterproductive to do that job again, so that the drivers automatically download the update of the cars, when they will have to manually download the new circuit pack.

    Thank you very much for your help, I will have everything present in the next update, to see if the rfcmp download problem is solved.

    Greetings.
     
  8. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    532
    Likes Received:
    128
    Not sure why your arguing when I've just told you, I have downloaded and checked your files, and it's wrong.
    ROC.png

    1. It is completely irrelevant that you can install the RFCMP's, as the fault is with the RFMOD !!! which is stopping the auto download and installation.
    2. The RFMOD naming is wrong, should not have spaces, must have underscore.
    3. The Auto Download will not work, with the SRC Indianapolis update !!! Your rFmod is only supplying the SRC update files, it does not include the base version 2.05 what it requires. We are on version 1.12 of Indianapolis, thus the SRC update mod will stop the whole download and update.

    There is no bug with autodownloads, as I already said, it is your rfmod and SRC Indianapolis.
     
  9. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,237
    Likes Received:
    309
    I think it's also wise to make the server mod with only one track that you are driving this week and not 20 (unless you have a reason for this?). Make a new server mod each week for each new track. Even if you get the above working, it's a lot for someone to download all in one go.
     
  10. JParra

    JParra Registered

    Joined:
    Jul 13, 2017
    Messages:
    151
    Likes Received:
    34
    I understand what you tell me Mangoletsi, but in our community we have the habit of preparing a download from Mega with everything necessary for the entire competition, because the drivers prefer it that way, rather than, due to some urgency, entering the race at the last minute and having to wait for a download.
    Therefore, the full version and the Indianapolis update is in that pack that everyone already has and is not in the Mod.
    Anyway, I understand that it is worth putting version and update in the rfmod to avoid problems.

    Djcruicky for the same reason that I mentioned to Mangoletsi, we have it all in one pack. In the past we have tried, but the slow download of the server, makes people who are late for a race, have to wait for the download.

    Anyway, I'm going to try as you tell me and apart I'll create that circuit pack as always to download from Mega, so the server only has to check if the Packages exists and install it at most, without having to download it.

    Thank you very much for your help, I will keep you informed of how things are progressing.
     
  11. JParra

    JParra Registered

    Joined:
    Jul 13, 2017
    Messages:
    151
    Likes Received:
    34
    Hello again.

    I have repackaged the Mod with a name without spaces and I have tried to put only the update of the cars and the track of Mills Metropark

    It has not worked.

    Then I tried the same thing, but putting the update of the cars in the Mod (checking the check in the left column) as suggested by Redapg.

    It has worked, I have downloaded the rfmod, rfcmp and it has installed everything correctly entering the server without problems or warnings in the Mod Manager.

    Finally, I have tried to create an rfmod with Indianapolis, only selecting the 2.0510 update and the rfcmp update, putting the latter in the rfmod.

    And it has worked too.

    Obviously, if you do not have previously downloaded the circuit pack and the Base version of the rfcmp of the cars that we have on our website, it will not work for you, because you will be missing the Indianapolis base and the cars.

    In the end I deduce that some problem I have on the server with the download of the rfcmp, but if putting them in the rfmod works, problem solved.

    Thank you all for participating.
     

Share This Page