The second update - Build 68

Discussion in 'General Discussion' started by 88mphTim, Mar 15, 2012.

Thread Status:
Not open for further replies.
  1. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    124
    Hi folks,

    Thanks again for being testers. :)

    Here is my post on the previous update, if you wanted to read that first.

    Build 68 is available on the auto updater. Bit of a stress test for that updater. ;)

    A torrent, if you wish to download and install manually, is available here. You will also notice a torrent for the GT rfmod in the same place.

    The GT mod has some known issues, none of which affect what we need testing, so we have released it as-is and will tidy up soon with an update.

    Plugins have a crashing issue. We have posted an updated interface which plugin builders will have to use and should fix crashes. If rF2 is crashing, disable plugins until they are updated or until we fix the issue elsewhere.

    Fresh bug reports forums have been put up with the older ones again placed in a sub forum of those forums.

    Thanks,

    Tim
     
  2. Marco Bijl

    Marco Bijl Registered

    Joined:
    Dec 23, 2011
    Messages:
    283
    Likes Received:
    8
    Great work again Tim!!! Thanks a lot mate!

    Updating all servers now, and downloading the content :p Gotta love this :p
     
  3. Hoschi

    Hoschi Registered

    Joined:
    Nov 18, 2011
    Messages:
    94
    Likes Received:
    0
    Hi Tim, thanks for the update !

    We have problems to connect our build 68 Servers ! The said mod is not installed ! In the singleplayer i can drive the not installed mods with all tracks and cars, but not with a serie !

    Mod "F1_2012_v2.1 2.1" references an non-existent component "TMTires 1.0b".
    Mod "F1_2012_v2.1 2.1" references an non-existent component "rF2 Showrooms 1.0b".
    Mod "F1_2012_v2.1 2.1" references an non-existent component "rFactor2 UI 1.0c".
    Mod "F1_2012_v2.1 2.2" failed to verify, removed from inventory
    Mod "Intel BMWF108 +Ferrari08 0.8" failed to verify, removed from inventory
    Mod "Formula Renault 3.5 1.1" is an update to a non-existant base mod, removed from inventory.
    Mod "Megane_at_SearspointRW 1.3" is an update to a non-existant base mod, removed from inventory.
     
  4. Marco Bijl

    Marco Bijl Registered

    Joined:
    Dec 23, 2011
    Messages:
    283
    Likes Received:
    8
    Almost the same here. Can't join, as it says the mod is not installed. When I go to the Mod Manager, I see them as installed. No complaints about server/client mismatch, or errors
     
  5. NightSt@lk3r

    NightSt@lk3r Registered

    Joined:
    Jan 10, 2012
    Messages:
    55
    Likes Received:
    0
    I cant even install this update, it just gives me an error saying "This update cannot modify the current version"
     
  6. kro388th

    kro388th Registered

    Joined:
    Jan 10, 2012
    Messages:
    646
    Likes Received:
    31
    Can you guys join the other standard mods that come with the beta ? megains, 60's rf3? I see in your list they are all addons ..being beta with changes being made the user created mods might need some edits for new build ? IDK just guessing here .. ??
     
  7. Marco Bijl

    Marco Bijl Registered

    Joined:
    Dec 23, 2011
    Messages:
    283
    Likes Received:
    8
    Will try that now.

    Yep.. It's just the custom content that does not work anymore. At least the vmods aren't working. Have not tried the modified components yet.
     
  8. mclaren777

    mclaren777 Registered

    Joined:
    Oct 5, 2010
    Messages:
    546
    Likes Received:
    14
    Last edited by a moderator: Mar 16, 2012
  9. kro388th

    kro388th Registered

    Joined:
    Jan 10, 2012
    Messages:
    646
    Likes Received:
    31
    Thanks Marco !!
     
  10. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    124
    Are the mods properly packaged as rfmod files, etc? I remember seeing some posts advising modifying and placing of files into the core directory, and that's baaad. :)
     
  11. Hoschi

    Hoschi Registered

    Joined:
    Nov 18, 2011
    Messages:
    94
    Likes Received:
    0
    Yes, all were rfmod files and all installed over launchmanager-->manage Mods, the same thing with the 1960 F1 , connect to a server one time, after that mod is not installed, but here says the Mod Manager, is installed !
     
  12. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    124
    You need to explain fully where it's saying this. Where is it saying it's not installed, etc? The bug forums are also there now for this to be posted.
     
  13. Marco Bijl

    Marco Bijl Registered

    Joined:
    Dec 23, 2011
    Messages:
    283
    Likes Received:
    8
    Yes Tim, they where packed in the correct way.

    I just repacked 1 vmod, and resubmitted it as version 1.2. Now it works like a charm again.

    It goes for all the vmods I made, which are a few already since we run several events already :). After repacking and resubmitting, it works fine.

    I have to upload the new version so other members can use it as well. When done, I shall put the download links here as well, so you can check for yourself is something was wrong if thats ok by you?

    [edit]
    This is the one that does NOT work anymore.
    http://www.mediafire.com/?3ax7b7hum2h6epr

    And the revised version, 1.2, which DOES work.
    http://www.mediafire.com/?3xct72czdhtt7l9
     
  14. Cangrejo

    Cangrejo Registered

    Joined:
    Dec 24, 2010
    Messages:
    399
    Likes Received:
    148
    With this new update the game crashes me constantly and the image freezes. I have to watch what happens

    Basically my pc

    I5 2500K
    SLI GTX 560 Ti OC
     
  15. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    124
    Interesting, thanks. Something could have changed on the back end that wasn't documented.
     
  16. francotopa

    francotopa Registered

    Joined:
    Jan 12, 2012
    Messages:
    11
    Likes Received:
    0
    i installed the update, and lost about 20 fps.
    phenom II x4 965 , 4gbram, ati 5770
     
  17. Marco Bijl

    Marco Bijl Registered

    Joined:
    Dec 23, 2011
    Messages:
    283
    Likes Received:
    8
    No problem, thats why you use us as testers right :)

    I have removed the password from the server in case you want to test something. RACEDEPARTMENT.COM TEST is the server name. It's running version 1.2 now.

    Please note the 1.2 is NOT an update, but a seperate build! I just needed to test it. Shall we move further conversation to the bug reports?
     
  18. Marco Bijl

    Marco Bijl Registered

    Joined:
    Dec 23, 2011
    Messages:
    283
    Likes Received:
    8
  19. mclaren777

    mclaren777 Registered

    Joined:
    Oct 5, 2010
    Messages:
    546
    Likes Received:
    14
    1 person likes this.
  20. smartin13

    smartin13 Registered

    Joined:
    Dec 23, 2011
    Messages:
    85
    Likes Received:
    0
Thread Status:
Not open for further replies.

Share This Page