[REL] The New UI is Here! (Instructions on How to Opt-in)

Discussion in 'News & Notifications' started by Christopher Elliott, Dec 19, 2019.

  1. ayrtonforever

    ayrtonforever Registered

    Joined:
    May 31, 2017
    Messages:
    163
    Likes Received:
    74
    just opt out beta, start rf2, wait for package install and then opt in again
     
  2. delpinsky

    delpinsky Registered

    Joined:
    Jan 12, 2012
    Messages:
    4
    Likes Received:
    1
    @ayrtonforever
    It seems like it's working, completely uninstalling rF2... it's now installing correctly the packages one by one
     
  3. CrimsonEminence

    CrimsonEminence Registered

    Joined:
    Jun 18, 2019
    Messages:
    230
    Likes Received:
    223
    Don't know if already reported:
    -remaining session time is not clear for me in session menu, have to go into the cockpit, do i miss it?
    -rF2 doesn't start anymore into the old UI here (launcher works fine, game itself not, black screen and CTD/Launcher)
     
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,082
    Likes Received:
    2,863
    From my short test I believe it's up the top. Took me a while to find it.
     
  5. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,808
    Likes Received:
    1,225
    Try verifying game files.
     
  6. CrimsonEminence

    CrimsonEminence Registered

    Joined:
    Jun 18, 2019
    Messages:
    230
    Likes Received:
    223
    That's the problem with it. But i didn't find it at the top in qualy for example...just the laps remaining.
    It's the next step on the plan, but i don't bother to waste any time on it right now, i will do it, when i decide to revert to the old UI...right now, the new UI is way more stable, than it was at release and i quite like its capabilities in session observation in some areas (the fullscreen view is a HUGE improvement, for example), so it's fine for me for the moment and i finally see it worthy to have some acclimatization to it.^^
     
  7. karlisss

    karlisss Registered

    Joined:
    Apr 4, 2019
    Messages:
    55
    Likes Received:
    10
    how to get new UI to work?
    i lounch latest public beta and game never loads up, no interface nothing, only black screen... forever.. til ctr+alt+del to get out
     
    mister dog likes this.
  8. CrimsonEminence

    CrimsonEminence Registered

    Joined:
    Jun 18, 2019
    Messages:
    230
    Likes Received:
    223
    You probably have to wait quite a bit, especially for the first time
     
  9. karlisss

    karlisss Registered

    Joined:
    Apr 4, 2019
    Messages:
    55
    Likes Received:
    10
    30min is not quite a bit?
     
  10. CrimsonEminence

    CrimsonEminence Registered

    Joined:
    Jun 18, 2019
    Messages:
    230
    Likes Received:
    223
    30 minutes is definetly too much!
    Try opting out of the beta, starting the old launcher, starting the game, then quitting and opting in again and try another start. Also verfication of steam files..the default procedures...
    My rF2 wasn't starting with the old UI anymore, for example...black screen and CTD.
     
  11. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    2,549
    Likes Received:
    1,499
    Click somewhere near the center of your screen, see if that gets things moving. Try to alt-tab and see if some dialog now is waiting for some action. In steam, verify your files.
     
  12. karlisss

    karlisss Registered

    Joined:
    Apr 4, 2019
    Messages:
    55
    Likes Received:
    10
    Solved:
    I reinstalled game. it seems there was Reshade who "reshade" game and UI screen, cos new UI layout screen was seen only on top right corner, under yellow fps digits (a very small area where player name appears) everything else was black.
    So now with clean installation and no reshade pack, everything is ok
     
  13. djvicious

    djvicious Registered

    Joined:
    Jan 17, 2012
    Messages:
    117
    Likes Received:
    79
    Very sorry if I'm repeating things in my comment S397, as I love what you're doing with the new UI. I have opted out at this time simply because you're so hard at work releasing content updates and the package install is so slow in the new UI, that it's easier to opt out. An issue to be looked into for sure, but I'm not complaining because I appreciate the content updates!

    My big request would be an option to switch cars in a session, if the game code allows for this. We have a slew of incredible 3rd party and dev content, and sometimes I want to test out different cars at the same circuit with opponents. It would be a lot easier if this feature was available, akin to an online session.
     
  14. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,808
    Likes Received:
    1,225
    That is something that should be looked into.
    You can make a "race event" that can be used in both single and multi play and you can go to the next track with one or two clicks in-game also.
    I would be very interested in hearing why in single player you can't change cars in-game like in multi.
     
    buzz hornet and djvicious like this.
  15. João Silva

    João Silva Registered

    Joined:
    Nov 2, 2018
    Messages:
    6
    Likes Received:
    1
    EDIT: FIXED! see the bottom of the chat

    I have tried public-beta builds since last year. ive tried like 4 times, in separate months, since its available. Never worked.

    today i've uninstalled the game, and installed again on a new location. signed-up for public-beta. doesnt work. i also unsubscribed all the items in steam workshop. no dice.

    i've tried everything (except re-installing Windows) to try to get public beta working. can anyone help me? when I run the game, there's a white screen for some seconds, and then comes back to the desktop, and rfactor2 process is closed.

    I've followed these instructions to check the logs:

    https://docs.studio-397.com/users-guide/diagnosing-issues-using-logging
    Diagnosing issues using logging - Users Guide

    The result is attached. i found no major problem, but there may be.

    I've also checked Windows Event Viewer. no details on the crash
    upload_2020-3-24_13-10-21.png




    I've invested many hours in this. there's no clue about what goes wrong. can anyone help??
    my system:
    single monitor full hd, GTX 960, i7-7700k

    thanks


    EDIT: now it works! a guy in discord recommended the following:
    1) install the beta,
    2) rename the USERDATA folder to OUSERDATA.
    3) run the integrity check from within steam to check the files.
    4) start rfactor2 and don't touch it until it finishes.
     

    Attached Files:

    Last edited: Mar 25, 2020 at 10:28 AM

Share This Page