[REL] The New UI is Here! (Instructions on How to Opt-in)

Discussion in 'News & Notifications' started by Christopher Elliott, Dec 19, 2019.

  1. mb24064

    mb24064 Registered

    Joined:
    May 2, 2017
    Messages:
    11
    Likes Received:
    6
    From a VR standpoint, the loading times in between clicks is not great causes freezing of the screen/flickering if I move my head at all. Got stuck in showroom with no way to exit so had to kill the app.

    I think the default view of cars/tracks etc I do not care for the bottom menu, prefer either the list or grid, once you select the way you want to view the list does it remember this or a way to save that as default view?

    Just having AI filter on multiplayer is a big plus!

    I did try loading with VR disabled and got some memory allocation error every so often and crashes.

    After getting into the menu via non-VR I just wanted to get a feel for navigation, and overall I think once things get a bit smoothed out its not bad.

    Have now switched back to old UI for now until I see some updates on the VR front. I think the freezing etc is similar to the early VR implementation of the old UI. I don't think I will try again for a while, to be honest I did expect a slightly smoother experience.
     
    Last edited: Dec 19, 2019
    Numrollen likes this.
  2. dazzer

    dazzer Registered

    Joined:
    Feb 3, 2018
    Messages:
    328
    Likes Received:
    968
    any suggestions? I uninstalled and deleted all the folders the game, I reinstalled from scratch, but when I open the game the old isi logo comes out and then it sends me to the desktop, the game according to steam is running but does nothing
     
  3. Ciccina2016

    Ciccina2016 Registered

    Joined:
    Mar 25, 2018
    Messages:
    138
    Likes Received:
    34
    exactly the same for me.. any ideas?
     
  4. Tomislav Leskovic

    Tomislav Leskovic Registered

    Joined:
    Apr 14, 2019
    Messages:
    28
    Likes Received:
    20
    You're probably aware of the bug....I can't add more than 19 AIs when trying to add ai manually in the session. As soon as the list has more than 19 AI's, pressing either add ai button or to some entry (name) in the list does nothing.
     
    Emery likes this.
  5. nonamenow

    nonamenow Registered

    Joined:
    May 3, 2017
    Messages:
    602
    Likes Received:
    318
    Was doing that for me, I deleted cbash and shaders and rebooted and all is well now.
     
  6. AMillward

    AMillward Registered

    Joined:
    Apr 4, 2017
    Messages:
    1,680
    Likes Received:
    1,596
    I've got it working. Mileage may vary but changing both the dx11config.cfg and config.cfg to borderless then trying multiple times to re load the sim worked.
     
  7. Mcc457

    Mcc457 Registered

    Joined:
    Feb 25, 2015
    Messages:
    1
    Likes Received:
    2
    Run rF2 from steam, choose config and change from fullscreen to borderless. I had the crashing issue too, and this fixed it.

    I like the new UI and I know it's meant to focus on multiplayer and eSports, but it still has the same problem that rF1 had. There are too many mods out there and you still can't download the mods the server needs easily. If there was a way to filter servers by the content I currently have, it would be much more convenient.
     
    Thaichang and Alex72 like this.
  8. Ginmile

    Ginmile Registered

    Joined:
    Jan 17, 2015
    Messages:
    56
    Likes Received:
    4
    Where i find dx11config and config.cfg?
     
  9. PAL

    PAL Registered

    Joined:
    Nov 30, 2017
    Messages:
    8
    Likes Received:
    7
    Mmmh, I checked file integrety, deleted dx11config, switched back to check if the normal game loads, yes, but still it crashes after the old rf2 logo. Now I cannot even download the public beta, its says "no folder rights"
    EDIT: At least its starting to download now, as I deleted rfactor2.exe

    EDIT2: Ok, got it working, by deleting the rfactor2.exe then switching to the beta got the job done.
    Looking nice, but the menu seems very slow like 10fps, eventhough steam shows 1400 fps in the topright corner :D
     
    Last edited: Dec 19, 2019
  10. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,633
    Likes Received:
    3,222
    Try a reboot, it may help.
     
  11. Slamfunk3

    Slamfunk3 Registered

    Joined:
    Jan 6, 2012
    Messages:
    270
    Likes Received:
    126
    When I first start rF2 I get a message from steam about the app trying to launch with extensions, it pops up in the background and I have to click "yes" to continue. Perhaps for some the pop up is invisible

    TK
     
  12. Travis

    Travis Registered

    Joined:
    Dec 7, 2012
    Messages:
    179
    Likes Received:
    192
    I've found changing the GPU from auto to my actual 1070Ti results in the UI loading fine.

    The problem I've always had is the config always reverts back to auto for some unknown reason.
     
    patrickkluiters and 2ndLastJedi like this.
  13. Novotny

    Novotny Registered

    Joined:
    Dec 19, 2019
    Messages:
    2
    Likes Received:
    1
    When I launch, the following error pops up in a steam window:
    Allow Game Launch?
    rfactor 2 is attempting to launch with the optional parameters below:
    " +path=".." +workshopsync "
    If you did not request this launch or do not understand these options, select Cancel.​

    If I select OK, it the errors again but with parameters listed twice, and so on.

    What's that all about?
     
  14. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    2,972
    Likes Received:
    1,701
    mine defaulted to auto. Be sure to run the configuration tool.
     
  15. svictor

    svictor Registered

    Joined:
    Jan 20, 2019
    Messages:
    77
    Likes Received:
    272
    I found a few problems in the new replay system.
    First, new replay's seek bar can't be fast dragged with mouse like the old one. It now simply jumps from one point to another after releasing mouse button (and nothing will happen if i drag the bar and don't release mouse).
    Second, the replay list doesn't self update any more like the old one. If I rename/delete some replay files directly through explorer, the replay list won't update until I restarted the game.
     
  16. AMillward

    AMillward Registered

    Joined:
    Apr 4, 2017
    Messages:
    1,680
    Likes Received:
    1,596
    Steam > Steamapps > Common >rFactor2 > UserData
     
  17. Dean Hayes

    Dean Hayes Registered

    Joined:
    Apr 20, 2019
    Messages:
    11
    Likes Received:
    4
    I haven't been able to get into the game yet. Once I click play button in Steam I get a message saying rfactor 2 is attempting to launch with the optional parameters "path=".."workshopsync". No idea.
     
  18. Pales

    Pales Registered

    Joined:
    May 9, 2017
    Messages:
    307
    Likes Received:
    290
    Jesus christ, how can you get the launch of a beta so wrong that 90% of your playerbase cannot even open the game, despite following the exact steps described in your post. It is laughable honestly. Did you not beta test this? Oh wait, we're beta testing a beta, but we can't actually open the beta to test the beta.
     
  19. MrMaverick

    MrMaverick Registered

    Joined:
    Feb 20, 2012
    Messages:
    107
    Likes Received:
    15
    Looks good, had to try and start RF2 a few times as it would ctd after getting to the rf2 loading screen, working now though.
    Noticed no tire temps in car setup to help adjust cambers, perhaps not included yet?
    The mas file program for skins? is that not available yet with this UI version yet? or do I need to go back to original UI to use it?
    Will take a bit of getting used to. I Like the drivers name ticker at the top of the screen when watching cars out on the track, any chance of having a mode that automatically changes to other cars like the TV mode in GP4?

    Merry Christmas guys,nice work, you did it.
     
  20. Mark Fuller

    Mark Fuller Registered

    Joined:
    Dec 10, 2016
    Messages:
    303
    Likes Received:
    92
    @davehenrie I know that I should know this, but where do I find the configuration tool when using the new UI. At least with the old one you could select the video settings button and change form auto to your graphics card.
     

Share This Page