[REL] The New UI is Here! (Instructions on How to Opt-in)

Discussion in 'News & Notifications' started by Christopher Elliott, Dec 19, 2019.

  1. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,290
    Likes Received:
    5,936
    Here it is the long anticipated NEW UI --- here for you to test out!

    This is a beta and you will need to simply opt-in to the public beta steam branch

    Instructions
    Step 1
    In your Steam Library find rFactor 2 and right click it in the list.

    image1.JPG
    Step 2
    Select Properties from the drop down
    image2.jpg
    Step 3
    Got to the tab BETA
    In the top drop down select the beta:
    public-beta

    image3.jpg
    And that's it! Wait a few secs for it to download and your ready to try out the UI!

    Please report any issues or feedback here!

    Enjoy! :)

    Latest Chaneglog
    - Fixed sporadic crash on start up
    - Removed old logo on start up
    Steam Public Beta Branch
    Build ID
    Client: 4512910
     
    Last edited: Dec 20, 2019
  2. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,613
    Likes Received:
    1,109
    Thank you. :)
     
  3. LokiD

    LokiD Registered

    Joined:
    May 3, 2017
    Messages:
    1,180
    Likes Received:
    1,096
    Thanks...
     
  4. mesfigas

    mesfigas Registered

    Joined:
    Oct 15, 2015
    Messages:
    1,287
    Likes Received:
    646
    Happy new Ui !!!!!
     
  5. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,613
    Likes Received:
    1,109
    Very impressed at the quick click around.
    Everything is well laid out and the different listing layouts for tracks is a great improvement.
    So far, 11 rubber chickens out of 10.
    Now to go update the cockpit.

    I quickly found out Santa thought I'd been a bad boy.:cool:
    That's my Christmas gone.
     
    Last edited: Dec 20, 2019
    bwana and F1Aussie like this.
  6. mesfigas

    mesfigas Registered

    Joined:
    Oct 15, 2015
    Messages:
    1,287
    Likes Received:
    646
    i use lastest AMD gpu drivers and i cannot log into RF2
     
  7. AMillward

    AMillward Registered

    Joined:
    Apr 4, 2017
    Messages:
    1,623
    Likes Received:
    1,508
    Getting CTDs after the old ISI splash screen.
     
  8. tafkams

    tafkams Registered

    Joined:
    Jan 13, 2015
    Messages:
    43
    Likes Received:
    8
    Sadly not working for me. Starting with new rf2 logo then it switches to a ISI logo and then CTD. And i don't see any logfiles i could deliver.
     
  9. AMillward

    AMillward Registered

    Joined:
    Apr 4, 2017
    Messages:
    1,623
    Likes Received:
    1,508
    Yeah, exactly what’s happened to me.
     
  10. Ginmile

    Ginmile Registered

    Joined:
    Jan 17, 2015
    Messages:
    47
    Likes Received:
    2
    When load old ISI image rf2 come back to steam
     
    dazzer likes this.
  11. Donat

    Donat Registered

    Joined:
    Jan 7, 2019
    Messages:
    23
    Likes Received:
    120
    The UI is great, but not perfect. I have some problems. When I start the game and when the game goes into fullscreen, an old ISI rFactor 2 logo shows up. When I want to go and setup a singleplayer race, it tries (and fails) to load my favourite servers (I don't have any). I also wanted to take a look on the awesome new Audi R8 LMS EVO (one of my favourite racecars, thanks S397!), I went to preview it in the garage (you know that big hangar) and all I could see is just the car and it's sorroundings, no UI, the only way to exit was to shut down rF2 via task manager. And the last problem is: my favourite non-Studio397 free mod, VLN 2018 Liverypack by simskin.de doesn't seem to work with the new UI, I even tried reinstalling it. Other than that, I am very much enjoying the new beta UI. Thank you very much, guys!
     
  12. baked bean

    baked bean Registered

    Joined:
    Jan 17, 2012
    Messages:
    1,297
    Likes Received:
    47
    Same thing here to, crash after the ISI logo.
     
  13. krusti

    krusti Registered

    Joined:
    Apr 20, 2016
    Messages:
    616
    Likes Received:
    533
    I don't see a plugins menu, where i can manage them, turn off-on etc, has it been removed?
     
    Emery likes this.
  14. Rastas

    Rastas Registered

    Joined:
    Feb 17, 2017
    Messages:
    404
    Likes Received:
    819
    Not loading here too.....
     
  15. ChiefWiggum

    ChiefWiggum Registered

    Joined:
    Nov 29, 2016
    Messages:
    677
    Likes Received:
    5,562
    yeah. I have also the old ISI loading screen and then CTD
     
  16. Ginmile

    Ginmile Registered

    Joined:
    Jan 17, 2015
    Messages:
    47
    Likes Received:
    2
    I try a files check
     
  17. Rastas

    Rastas Registered

    Joined:
    Feb 17, 2017
    Messages:
    404
    Likes Received:
    819
    Correction,it starts via Steam,rFactor2 right click,play :)
     
  18. senormen

    senormen Registered

    Joined:
    Apr 20, 2015
    Messages:
    191
    Likes Received:
    784
    guys having crash after isi screen . . . set to 'borderless' in config . . . worked for me at least . . .

     
  19. GT_ONE

    GT_ONE Registered

    Joined:
    Dec 25, 2011
    Messages:
    267
    Likes Received:
    9
    restart your computer after the game this starts
     
  20. pascom

    pascom Registered

    Joined:
    Feb 5, 2013
    Messages:
    357
    Likes Received:
    322
    I had same CTD and i continue start UI.
    Lol old ISI loading! :D

    I have update packages and restart UI several times.
     

Share This Page