Released The 2022 UI Update

Discussion in 'News & Notifications' started by Paul Jeffrey, Jan 27, 2022.

  1. Alejandro Diaz Reina

    Alejandro Diaz Reina Registered

    Joined:
    Jan 11, 2012
    Messages:
    35
    Likes Received:
    29
    I know that these requests depends on the system core, but:

    We need an actual Relative, not the Standings that we have now. To really know who is ahead and behind you, how far, and if they are lapped cars, other category, etc.

    And please, we need to update the in game HUD. Give it the same feeling that the Broadcast overlay have, maintain a common theme. The blackbox looks pretty old, and doesn't match with the new colors (yellow text, get rid of it, please).

    When loading a session, it could be possible to load the cars "behind the scenes"? It is prettly ugly seeing cars overloading at the same spot, and when all the cars are loaded, the camera change to the pitlane. It is not possible to do this during the circuit load, or something?

    Thank you
     
    Kahel, r00b Driver and Havner like this.
  2. djvicious

    djvicious Registered

    Joined:
    Jan 17, 2012
    Messages:
    219
    Likes Received:
    214
    This is a really goofy question, but does anyone with an Oculus Rift know how to reset the viewing position? I can reset the view in the UI and in the cockpit, but on the track load screen, it's always pointing around 10 o clock. I'm baffled by how to fix it. I've tried to reset the view in Steam VR but nothing works!
     
  3. burgesjl

    burgesjl Registered

    Joined:
    Feb 2, 2013
    Messages:
    258
    Likes Received:
    461
    There's bugs everywhere in the UI regarding weather conditions in Single Player.

    My defaults are to use the Preset: heavy setting. Inexplicably, this appears in the list after Preset: Light and before Preset: Medium.

    When you first go into the main Single Event screen, it'll show which sessions are enabled (Practice, Qual, Race). In my case, Praccy only. . They all show random selections for the weather. Usually it'll select Preset:Light (one value less than actually selected). Go into the actual settings screen, look at Practice, it'll display Preset:Heavy. Come back out to the event screen, it shows Preset:Heavy. Now actually go into the session. The session screen only shows the temps for Race, not the current session (Practice) and does so in deg C never mind I've set it to F which is what the prior screens show. When I exit the session, the Single Event screen now shows another random value, sometimes Preset: Light, sometimes not.

    I'm pretty sure its doing something similar with the AI parameters as well. I can't be bothered to document these. There seem to be global defaults, obtained from who knows where, and then session values which may or may not be different.

    The old new UI, also had these same issues of random/incoherent selection of settings, that didn't stay set as you'd done them. Same with the new new UI.
     
  4. bobbie424242

    bobbie424242 Registered

    Joined:
    Oct 17, 2017
    Messages:
    246
    Likes Received:
    338
    ^

    I noticed configured weather slots not always apply in-game.
    For example: 1st slot = heavy rain, 100% rain. 2nd slot = Sunny.
    => Weather never changes to sunny.
     
  5. Alex Sawczuk

    Alex Sawczuk Registered Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    599
    Likes Received:
    604
    Real road Presets are listed alphabetically.

    If you set to an extreme weather change in a very short time the weather won't have time to change in short sessions.

    (Both of these are not really related to the new ui)
     
  6. Hazi

    Hazi Registered

    Joined:
    Jan 15, 2012
    Messages:
    884
    Likes Received:
    132
    Somehow I lost the ability to change AI strength during singleplayer session - could swear it was there before and worked after restart weekend - but after going to multiplayer and joined my own server and then switched back to single player and switched back to All Cars and tracks series the menue in single player states in below session options menue - voting ...- and the AI strength is not shown - just AI agression - seems like multiplayer session menue is there instead of singleplayer - tried restarting few times but no change....
     
  7. Alan.RJ.Smith92

    Alan.RJ.Smith92 Registered

    Joined:
    Mar 27, 2020
    Messages:
    15
    Likes Received:
    6
    I'm having issues when loading replays. The game will begin to load then not progress to the track loading screen, instead hanging on the "loading replay, please wait" text. Waiting whilst tabbed in produced no loading screen for about 5 minutes. On the day of the races I was able to load the replay within 2 minutes. Is this something that can be investigated in future?
     
  8. Paul Jeffrey

    Paul Jeffrey Administrator Staff Member

    Joined:
    May 21, 2016
    Messages:
    492
    Likes Received:
    2,700
    Hello

    I have an ultrawide monitor and it works perfectly here - can you elaborate please on what you mean by 'made to work adequately'?

    Cheers
     
  9. Flaux

    Flaux Registered

    Joined:
    Oct 5, 2010
    Messages:
    990
    Likes Received:
    406
    I think he means a fullscreen version without the black borders left and right. Right now it is only a 16:9 UI and I'm not even sure if it is 4k. Could well be 1080p. But it is a lot better then the old one on 3440x1440.

    I can live with it as it is.
     
  10. nolive721

    nolive721 Registered

    Joined:
    Jan 2, 2016
    Messages:
    222
    Likes Received:
    107
    hello. I might not be doing things right but I have a problem with updating controller set profiles.

    I have created one for my TSPC wheel and CSL pedals, its working fine no problem.But if I want to make an update like changing a key bidding, it seems it doesn't save under the same name automatically and I cant see in the UI any save button to click for proceeding manually.

    the workaround I found is to then create a new controller set profile with the same name that will supersede the existing one but that's really not user friendly.

    again, I might be missing something obvious so any help appreciated

    thanks
     
  11. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    5,888
    Likes Received:
    3,429
    That is a known issue, it is listed on the official web release listed in the first post. You have found the work-around.
     
    Lars and nolive721 like this.
  12. nolive721

    nolive721 Registered

    Joined:
    Jan 2, 2016
    Messages:
    222
    Likes Received:
    107
    damn, you are right. really hard to understand why its an issue though.anyway self workaround for now indeed
    • There is currently no way to overwrite a custom controller profile.
    • There is currently no way to remove a custom controller profile.
     
  13. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    5,888
    Likes Received:
    3,429
    That was my first thought when i read that section. IF THEY WERE KNOWN...why weren't they fixed? I'm sure it is more difficult than just editing a line or two of html, But hopefully the next release in May will contain those fixes.(and more!!!)
     
    nolive721 likes this.
  14. nolive721

    nolive721 Registered

    Joined:
    Jan 2, 2016
    Messages:
    222
    Likes Received:
    107
    maybe not as simple as editing html but then it was working in the previous UI iteration right so what is so hugely different now that could explain such basic thing is not working anymore?
     
  15. lamck

    lamck Registered

    Joined:
    Jun 9, 2013
    Messages:
    46
    Likes Received:
    2
    I'm using 3 21:9 monitors. When they are in multi-view mode, the car image/icon (and at show room) is a bit stretched horizontally, the wheels are not of circle.
    In driving mode, the e.g. frame rate information is left-edge of left monitor, it is preferable at middle monitor.

    It works fine at single monitor.
     
    Last edited: Feb 19, 2022
  16. Balazs Magyar

    Balazs Magyar Registered

    Joined:
    May 8, 2017
    Messages:
    255
    Likes Received:
    211
    I have three normal monitors with wideview setting, The UI is only on the middle monitor, but the showroom is still stretched.
     
  17. Gupster

    Gupster Registered

    Joined:
    May 19, 2013
    Messages:
    410
    Likes Received:
    27
    Loving it! Bought the Q-1 carpack because who doesn't like saving 5 bucks!?!?!
    Thanks again team for the best driving sim!
     
  18. Bernat

    Bernat Registered

    Joined:
    Jun 15, 2020
    Messages:
    111
    Likes Received:
    100
    I select the profile from the list of profiles and then click "Save Profile". If you put your profiles alphabetically at the start of the list it's just one extra click.

    I think the real issue is that when changing tabs in the control settings the profile name gets deleted and thus the save button is disabled.
     
    nolive721 likes this.
  19. nolive721

    nolive721 Registered

    Joined:
    Jan 2, 2016
    Messages:
    222
    Likes Received:
    107
    thank you I will try this
     
  20. nolive721

    nolive721 Registered

    Joined:
    Jan 2, 2016
    Messages:
    222
    Likes Received:
    107
    I am having a weird issue

    When I try a single player race, the Dpad on my TSPC wheel works fine to emulate the mouse so I can move the pointer across the screen and select whatever I want in the Event settings screen

    That screen
    upload_2022-2-24_19-49-3.png


    now after I click Start racing the track load and I reach the RACE screen, the Dpad is not functional anymore. I need to use my physical mouse to move the pointer

    upload_2022-2-24_19-47-30.png


    anyone experiencing the same issue?

    thanks
     

Share This Page