[SOLVED] T500 RS incorrectly detected

Discussion in 'Technical & Support' started by Balazs Magyar, May 8, 2017.

  1. Balazs Magyar

    Balazs Magyar Registered

    Joined:
    May 8, 2017
    Messages:
    153
    Likes Received:
    127
    Hi All
    Since the new DX9 update my T500 RS wheel is detected (incorrectly) as joy3 instead of joy1 (which was the case previously and that was correct). This is my only game controller. Pedals (defaults for the wheel) are also incorrectly detected.
    If I set the controls manually the force feedback effects work badly. The wheel generates negative(ish) forces.
    DX11 version is the same. Other games work well.
    I reinstalled rFactor 2 completely, and nothing changed.

    Thanks for your help.

    Balázs
     
  2. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,351
    Likes Received:
    6,782
    Instead of using 'detect', can you try loading a controller profile:
    1. In controls tab click "LOAD"
    2. Choose Thrustmaster T500 RS Racing wheel
     
  3. Balazs Magyar

    Balazs Magyar Registered

    Joined:
    May 8, 2017
    Messages:
    153
    Likes Received:
    127
    I've tried it. It loads the same profile which was loaded after auto detection. Is there something wrong with the json file? Was it changed in the updated rFactor 2 versions?
     
  4. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,351
    Likes Received:
    6,782
    Are you using the F1 rim addon?
     
  5. Balazs Magyar

    Balazs Magyar Registered

    Joined:
    May 8, 2017
    Messages:
    153
    Likes Received:
    127
    Nope. Default rim.
     
  6. Pales

    Pales Registered

    Joined:
    May 9, 2017
    Messages:
    310
    Likes Received:
    293
    I have a T300RS and it detects it as a T500RS with the incorrect settings (as advised above).
     
  7. Balazs Magyar

    Balazs Magyar Registered

    Joined:
    May 8, 2017
    Messages:
    153
    Likes Received:
    127
    My T500RS is detected as T500RS :(
     
  8. Red Time

    Red Time Registered

    Joined:
    Feb 27, 2016
    Messages:
    9
    Likes Received:
    0
    On my T500RS the brakes do not work! It recognises the brake pedal being pushed in Settings but no brake effect in-game
     
  9. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,996
    Likes Received:
    1,341
    I would delete (or move it to somewhere else like the desktop) the Controller.JSON found in \steamapps\common\rFactor 2\UserData\player.
    When you restart the game it will write a new Controller.JSON file.
    Then do the Detect or load the preset profile like Christopher mentioned.

    The wheel generating negative forces is because in the Controller.JSON file there is a line in the Force Feedback section: "Steering effects strength":
    For the Thrustmaster wheel the strength number has to be a negative number, default is -10000

    I would also look in \steamapps\common\rFactor 2\UserData\Controller
    Open the T500 JSON and check if that steering strength number is a negative.

    With the controllers listed as joy1 or joy2 etc, the number is where it is listed in Windows game controller screen.
    My button box is first in the list so it is joy1, my Thrustmaster H patter gear shifter is 5th on the list and is joy5.
     
  10. Balazs Magyar

    Balazs Magyar Registered

    Joined:
    May 8, 2017
    Messages:
    153
    Likes Received:
    127
    I'll give it a try, thanks. I reinstalled the whole game though.
    A strength is not fully negative, but just feels too light after a point when I turn the wheel. It felt much more realistic before.
    My wheel is the only game controller in Windows.
     
  11. Balazs Magyar

    Balazs Magyar Registered

    Joined:
    May 8, 2017
    Messages:
    153
    Likes Received:
    127
    I've tried several cars recently, and the FFB feels OK. Maybe it was just a specific car. But the original issue - the incorrect detection of the wheel - still stands.
     
    Mydriaz likes this.
  12. Balazs Magyar

    Balazs Magyar Registered

    Joined:
    May 8, 2017
    Messages:
    153
    Likes Received:
    127
    still doesn't work :(
     
  13. Balazs Magyar

    Balazs Magyar Registered

    Joined:
    May 8, 2017
    Messages:
    153
    Likes Received:
    127
    The newest update solved the problem! Thank you, Dear Developers.
     

Share This Page