[SOLVED] Strange slipstream effect when a car is FOLLOWING me

Discussion in 'Technical & Support' started by Eric Moinet, Jul 18, 2017.

  1. Eric Moinet

    Eric Moinet Registered

    Joined:
    Jul 18, 2017
    Messages:
    44
    Likes Received:
    11
    You can't there is a fence :D
    But I understand I was not in the same line as the other laps so I could have hit a bump there. Anyway, I'm afraid it's not the good track to show clearly the issue I have, because of the bumpiness affecting every movement on track. I'll go for another try at a flat track tonight where I've had the same issue for sure.

    Thank you very much Lazza and Spaskis, and others, to take a bit of your time to help me.
    To be continued...
     
    SPASKIS likes this.
  2. Raintyre

    Raintyre Registered

    Joined:
    Jul 28, 2013
    Messages:
    147
    Likes Received:
    84
    As far as i know, some cars and mods do include a small of effect of pushing the vehicle in front when you are drafting at very close distance. But it is a small effect on speed increase, nothing so weird as you describe.
     
  3. toebee

    toebee Member

    Joined:
    Oct 5, 2010
    Messages:
    380
    Likes Received:
    389
    You can view the DRAG effects of cars in DEVMODE by pressing CTRL+Z (check screenshot below). While it doesn't show DOWNFORCE effects it should give you an idea of how a individual mod uses the air, and how it can effect a car in front. No offense to the OP but I don't see this being the problem, unless they are very close. I am curious if you turn off the mirrors and spotter so you have no idea who is around you or how close they are do you still have the same problem? Could it be your subconscious saying, "get out of the way someones behind you". :p
     

    Attached Files:

  4. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    285
    Thanks for that hint! DidnĀ“t knew that.
     
  5. Eric Moinet

    Eric Moinet Registered

    Joined:
    Jul 18, 2017
    Messages:
    44
    Likes Received:
    11
    Agreed Raintyre, and I'm aware of that. That's why I decided to ask for help, this is not normal situation.

    toebee, my subconscious may play a role but because of the issue, not causing it. I'm aware of that too and as stated above sometimes I don't even know there is someone behind me.

    ----------------------------------------

    Anyway, so obviously when you try to replicate an issue it doesn't happen, but eventually after several tries we have a winner :)
    No spins though, sorry.

    Here is a zip file with datas from a 30 mn practice session as a reference file and a 90 mn race with AIs and three pictures (inboard and settings) if of any help : http://www.mediafire.com/file/muobucqunaj1hhk/logs&screenshots.zip

    20 AIs, I'm starting from last by design. A picture from the start, you can see FPS and CPU are okay (I think), and I have a question : how the hell did I put auto clutch off ??? o_O
    [​IMG]

    So, to sum it up, you can jump straight to 24th lap when I 'm affected by the effect. Don't take in account the mistake I made at the Mistral chicane, I misjudged my braking point. But you can use it as a starting point.

    I catch up two LMP2s at the end of the straight and pass one of them the next turn. At that point I have a massive understeering at every turn and a massive overheating of the front tyres, mainly the one with weight transfer (obviously), unable to take the turn and the AI passing me back, then I pass it again and so on for two or three laps. At that point I stay behind the AI car for a couple of laps and my car behaves as it normally should.

    Thanks for your input and help
     
    SPASKIS likes this.
  6. Eric Moinet

    Eric Moinet Registered

    Joined:
    Jul 18, 2017
    Messages:
    44
    Likes Received:
    11
    It's nice to have some likes but it would be nice to have some feedback too. This is not directed upon Spaskis (but you can add your input too). Everyone asked for evidences, now that I've provided some I'd like to have your thoughts and, moreover, fix the issue.

    Thanks in advance.
     
    SPASKIS likes this.
  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,719
    Likes Received:
    3,288
    I had a quick look but it was difficult to pinpoint the lap you were referring to. Tyre temps didn't escalate at any portion, though did stay lower on some laps.

    Did you have replays enabled? A replay would help.

    If you do more tests try turning on all the data channels in the DAMPlugin.
     
  8. Eric Moinet

    Eric Moinet Registered

    Joined:
    Jul 18, 2017
    Messages:
    44
    Likes Received:
    11
    Thanks Lazza for answer. No replay unfortunately, I've switched that off recently because I've heard it could be too demanding for processor. That said it didn't change anything :p

    I won't be able to do another test before this week-end. I'll add replay and all channels in DAMPlugin (I'm pretty new to this)
     
  9. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    I'll try to take a look tomorrow. I am usually out of my house during summer so it is a bit difficult meanwhile.
     
    Eric Moinet likes this.
  10. CamiloNino

    CamiloNino Registered

    Joined:
    Apr 5, 2017
    Messages:
    153
    Likes Received:
    131
    If your FPS are good and your input lag is good too ( BTW have you tested with a proper PC monitor? ) and you say it doenst change when turning mirrors off then Im not sure what could be the cause, speaking of a technical issue.

    The fact that it happens for you both in rF1 and rF2, no matter the mod or track, regardless of the wheel or pedals used, across different hardware, and that is an issue no body else has reported ( that I know of ) leaves me with the conclusion that the only common factor here is you.

    I don't mean to offend, and I say this without looking at your data (I don't have time for that honestly) but if I had to bet right now, I would put my money on this whole issue being entirely in your head.

    The only "test" I could think of right now is: get a friend who is used to driving in rF2, and invite him to your place and test your setup, see if he has the same problem.

    Good luck, I hope you find the cause, if there is one.
     
    Ho3n3r likes this.
  11. Eric Moinet

    Eric Moinet Registered

    Joined:
    Jul 18, 2017
    Messages:
    44
    Likes Received:
    11
    Prepare your cheque. I accept credit card too.:D

    And my computer if you don't mind.
    And this too, even if it shouldn't have such a strong effect on my car :
    Those lines in rF1 .hdv files if I'm not mistaken :
    Code:
    DraftBalanceMult=0           // effect of draft on aerodynamic downforce balance of car (bigger numbers exaggerate the effect)
    BodyDraftLiftMult=1.00          // effect of draft on body's lift response
    ...
    BaseDropoff=0.085               // RFM Drafting override: Higher number -> more drafting effect (default=0.185)
    LeadingExponent=6.6            // RFM Drafting override: Higher number -> lower effect on leader (default=2.0)
    FollowingExponent=2.2          // RFM Drafting override: Higher number -> lower effect on followers (default=2.0)
    
    I understand it's hard to believe it and I probably wouldn't if I were in your shoes. But I've been struggling with that issue for 3 years now trying everything I could find to fix it on my own. I ran out of idea, I don't have all the technical knowledge you guys have on how to set up a rig or hardware or software to have the best experience in game, hence why I'm here asking for your help. But I'm good enough to know if it is a human mistake or not, and if it is a technical issue what is its origin. When I had a FFB issue with my steering wheel during my first year of simracing, I knew it was the wheel sending irrelevant FFB inputs from the game and not a driving skill issue or anything else (and nobody trusted me at that time :rolleyes:). I don't pretend to be the best driver on track, nor the fastest, I don't pretend I don't make mistakes but when I do make a mistake I know that it is a driving mistake and I know which mistake I have done. As well when I say it has something to do with an added effect from the car behind (or drafting effect to quote the .hdv file term) it has something to do with that, whatever it could be. And that's that whatever I'd like to fix.

    I'll make a test with a PC monitor, but that's not as easy as just plug the screen and drive. And to be honest I don't see why it should make a difference. I'm not questioning your saying but I don't see how a graphical output could add physical effects on my car, and ONLY when a car follows me, NEVER when I follow that same car (and not at any other time). I get the idea of added lag but it should be all the time, or at least every time there are cars around me, right ?

    Thanks for your input anyway these are useful tips to check.
     
  12. CamiloNino

    CamiloNino Registered

    Joined:
    Apr 5, 2017
    Messages:
    153
    Likes Received:
    131
    About those lines in the hdv file, the reason I don't consider them a factor is because you have this problem with every mod, across two games. If you only had this problem with a particular mod, or even type of car I would look into that, but since the mod doesnt matter, that leaves me with two options. That either both game engine uses that parameter improperly, and considering its been 12 years, I think this issue would have been spotted by now if it were in the game engine ( maybe you can ask clarification from S397 about what exactly those lines do). Or that every single modder (Including ISI and S397) has put wrong values there. Again, I think after 12 years, this would have been noticed.

    The other factor you mention is your computer, and that I agree, that's why I suggested getting someone else to test it. But again I think that it is unlikely, because thinking about it, what could be different about your computer that creates an issue on a specific game, on a specific situation that nobody else reports? We know from your input that it is not a dip in FPS as I thought initially, and you already tested two different cards right? Maybe you are getting stutters only when a car is following you, but why would it be only then? People who report stutters report them happening basically at random points, at race start or after restarting a race a lot, but not just when there is a car behind. It just doesn't make any sense to me.

    About the monitor, I suggested it when I thought you were having input lag issues compounded by a dip in FPS caused by the car in the mirrors. Since you say mirrors don't make a difference and FPS sre fine, then I don't suggest that as a solution anymore. I still asked because TVs can add a lot of input lag (some in the order of tents of seconds) and reducing input lag will help your driving in general, so it is something you should consider in general. Just make sure that if you test a PC monitor, it is one with low input lag (or a TV with proven good input lag).

    I worked in technical support for about 6 years, and that has made me skeptical of a lot of bug reports. You would be surprised how many issues are actually just perception from the user, users who were dead sure it wasn't them. That's why I'm telling you this, it is a real possibility and you should consider it among the possible causes for this.

    I'm not claiming I'm right, I don't know. I'm just saying that right now I think that is the most likely explanation for me. But if you end up finding a technical cause for it then I would be very interested to learn about it, would be a very interesting case.
     
  13. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,082
    Likes Received:
    1,744
    Back when 3d racing was brand new.....indycar2...I had a system that just barely was fast enough to support 3d gaming.(the good ol Rendition 3d card) Certain cars in ICR2 excelled at certain tracks, for the super speedways like Michigan, the Buick engined cars(Heck Buick might be ICR1. old am I) usually were tops. I'd qualify on pole, rocket away, 10 or 15 laps later I'd come up to the tail enders, my fps would tank and I'd crash within seconds. Happened over and over. FPS drops were killing me. That's my only advice, ensure your fps are consistent. Best of luck.
     
    Eric Moinet likes this.
  14. Eric Moinet

    Eric Moinet Registered

    Joined:
    Jul 18, 2017
    Messages:
    44
    Likes Received:
    11
    I didn't say that. I was just pointing what part of the files is *maybe* related to the issue I have for some reason on my computer. I would like everyone focus on that reason instead of my driver's behaviour or what else, even if it makes no sense. It happens. Period.
    (And I'm with you as a technical support. You'll be surprised how many times I solved an issue just saying 'Plug the plugs')

    I'm off for two days so won't answer anymore before... hem, two days.
    Thanks for your help everyone.
     
    SPASKIS likes this.
  15. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    I have been checking your logs and what I have found is the until lap 23 your braking was very consistant. Most laps seem a copy one to the other. In laps 24 and 25, mainly, your braking was much more anticipated with respect to previous laps. In the image below you can see how in 4 consecutive turns you brake earlier in lap 24 with respect to lap 23 which is a good lap. Lateral g forces are equivalent in both laps.

    Tire temps are actually lower in laps 24 and 25 compared to lap 23. There is no massive front understeering at all as you claim. It would seem that the more conservative braking might be cooling your tires too much that you might feel some understeer.

    What I see is different driving on those laps due to the need to defend and attack from opponents. As Lazza pointed out, if you do more tests please include the replay so that we have a bit more information on what is going on with opponents. If you could also enable all channels being logged in motec_plugin.ini we could better analyse the telemetry. There are several channels not being logged.
    upload_2017-7-28_20-6-46.png
    upload_2017-7-28_20-15-26.png
     
    Last edited: Jul 28, 2017
    Eric Moinet, peterchen and kro388th like this.
  16. Eric Moinet

    Eric Moinet Registered

    Joined:
    Jul 18, 2017
    Messages:
    44
    Likes Received:
    11
    Thank you Spaskis for taking the time to look into my files.

    I'm surprised with this because I ran wide at least twice during these laps because I was unable to turn the wheel. Not questioning, just surprised.

    I'll provide more files with replay and channels added. Thank you anyway, your help is much appreciated.


    EDIT :
    I might have been wrong on the laps involved because of the missing replays. It might have been laps 26 & 27 on Motec where my lap times are lower. My fault, sorry.
     
    Last edited: Jul 29, 2017
    SPASKIS likes this.
  17. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    Don't worry Eric. I have been further looking at the pictures and my perception could also be a bit distorted. I used meters to compare laps but I think the on track overlay is not perfect with it. I can see that turning the wheel also came ahead so probably my conclusion could be incorrect. A replay would have been very helpful were you could exactly pinpoint at the "replay position".

    However, I would have liked to have access to the rest of the telemetry channels in order to better check tire behaviour. Were you using motec or dam plugin? I recommend uding DAM plugin with all physics channels enabled.

    Hopefully next test would be successful!
     
  18. Eric Moinet

    Eric Moinet Registered

    Joined:
    Jul 18, 2017
    Messages:
    44
    Likes Received:
    11
    That was DAMplugin but I'm pretty new to it. Enabled all channels and replay for next test and trying to use MSI Afterburner as well for ingame cockpit view replay, but again I'm pretty new to it.

    Thanks again
     
    SPASKIS likes this.
  19. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    It is easier to create videos afterwards watching the replay file where, pressing the enter key, the overlay with throttle brake and steering appears and helps syncrhonizing with motec file. For my purposes, don't worry creating the video. Just upload the vcr file.
     
    Eric Moinet likes this.
  20. Eric Moinet

    Eric Moinet Registered

    Joined:
    Jul 18, 2017
    Messages:
    44
    Likes Received:
    11
    Hi again, and sorry for the silence, busy week and not able to reproduce the issue in an obvious way.

    So I'm back with a file from a race at Norisring a week back where I gave up after five or seven laps out of frustration because the car was impossible to drive.
    https://www.mediafire.com/file/116b992e48lwyce/MotecLogs.zip
    Added the video and my plug-in settings to the Motec files. If someone is kind enough to give his input on what happened there, I'd be more than grateful cos I'm at lost there.

    On a side note, I will make a try with an other rig to test if it happens also with this one or, hopefully, not. That's a rather old rig but it will be good enough to test at least on rF1 with a bunch of AIs. I'll report back later after some tests.

    Thank you again for your help.
     

Share This Page