Strange lighting effect

Discussion in 'Track Modding' started by vicent-sollana, Oct 25, 2012.

  1. vicent-sollana

    vicent-sollana Registered

    Joined:
    Jan 21, 2012
    Messages:
    416
    Likes Received:
    17
    Hi guys

    In the walls I find that the lights hits the walls in a strange way. What could it be?


    View attachment 4433
     
  2. Luc Van Camp

    Luc Van Camp Track Team Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    1,030
    Likes Received:
    14
    Try welding all verts (0.001m), make sure all polys have a Smoothing Group assigned to them, and then detach each SG to a new Element?
    Or it could be a bug in the exporter ... I experienced a similar effect which was caused by dodgy tangent basis calculation. Not sure if that's fixed in the tools that came with 118 though. I doubt this is the case though, as the object itself isn't very complex. It looks like some tris have no smoothing.
     
  3. vicent-sollana

    vicent-sollana Registered

    Joined:
    Jan 21, 2012
    Messages:
    416
    Likes Received:
    17
    I've detached the polys in order to create cmwalls objects,Now i'm going to check the smoothing groups and try the welding.

    Thanks luc.
     
  4. RMachucaA

    RMachucaA Registered

    Joined:
    Oct 5, 2010
    Messages:
    80
    Likes Received:
    2
    This could also happen if those polygons are duplicated on ontop of another (z-fighting). I doubt its that but its worth to mention just incase.
     
  5. Mario Morais

    Mario Morais Member

    Joined:
    Oct 26, 2010
    Messages:
    1,465
    Likes Received:
    169
    Can do all with one click! "Fix smooth" button in my Gmaterialtool script :) Weld verts and create smooth group and detach Elements for all selected objects!
     

Share This Page