Strange lag even though FRAPS shows 90 FPS?

Discussion in 'Technical & Support' started by Racefreak1976, Oct 18, 2015.

  1. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    10,483
    Likes Received:
    5,318
    That's normal, because the player physics aren't running anymore. But hopefully taking the wheel out does help (not because I think you should race with a keyboard, but because at least it would provide something to target :))
     
  2. Led566

    Led566 Registered

    Joined:
    Jan 25, 2012
    Messages:
    358
    Likes Received:
    24
    Yes, this happens to me also.
    But please try with the keyboard, you should see the effect just after going out of the box no need to even exit the pit lane;)
     
  3. whitmore

    whitmore Registered

    Joined:
    Feb 26, 2012
    Messages:
    551
    Likes Received:
    140
    I did not get to try key board but I have had some success I believe. First I tried turning off Hyper threading in the BIOS this did not help, but another setting in the BIOS is "Intel Speed Step". Some research had identified this as problematic for other game titles and so far after turning this off I have completed three sessions without the lag. Fingers crossed but I just don't understand why now has been ok all the way through the builds so far.
     
    Last edited by a moderator: Nov 4, 2015
  4. Led566

    Led566 Registered

    Joined:
    Jan 25, 2012
    Messages:
    358
    Likes Received:
    24
    I'm happy for you...;)
    but I have an AMD FX...still scratching my head.
     
  5. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    10,483
    Likes Received:
    5,318
    Although your CPU may be able to switch speeds, which rF2 as far as I know isn't really very happy with, the fact your symptoms disappear without the wheel plugged in do point to that being the issue. Still, if you can nail the CPU down to a single, unchanging, frequency that would help eliminate it at least. (i.e. turn off Turbo or whatever it's called)
     
  6. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    LG W2453V
    Analog : VESA 1920 x 1080 @60 Hz
    Digital : VESA 1920 x 1080 @60 Hz

    You monitor is 60 HZ and can only display 60 FPS.
    Edit this line ("Max Framerate":0,) in you player.JASON file like this ("Max Framerate":60,) and you have silky smooth gaming experience.

    :)
     
  7. whitmore

    whitmore Registered

    Joined:
    Feb 26, 2012
    Messages:
    551
    Likes Received:
    140
    Sorry whiteshadow wished it was that easy. I did that a long time ago but for me problem srill existed until i turned off intel speed step. Even now have had a couple of instances of the lag but way less than before.
     
  8. rogue22

    rogue22 Registered

    Joined:
    Jan 14, 2012
    Messages:
    261
    Likes Received:
    18
    So a simpler solution would be to go into your power settings and set the CPU to run at 100% min and max. I'll try that first, then I'll unplug my wheel if the former shows no difference, I'll report back here.

    EDIT:
    I disabled Speed steping, no fix from that. Then I unplugged my Wheel as well. Watched a few replays and made an attempt to drive with the keyboard. No beneficial results from that either.


    Are you guys on AMD or nvidia cards? Maybe its driver related. Although I have issues doing the driver dance because I don't have a proper away to disable automatic driver support in Windows 10. I have the Home version 64 bit. The fix for the pro doesn't work on the home edition.
     
    Last edited by a moderator: Nov 6, 2015
  9. nipzon

    nipzon Registered

    Joined:
    Dec 23, 2011
    Messages:
    247
    Likes Received:
    35
    Does anyone notice the lag appearing the moment they come in contact with another car?

    I did an endurance and did about 15 laps with smooth lapping, no lag, when I started catching up to a back marker. The moment I caught up to him my lagging started. The green bar increased to about three quarter with dots and spikes, and the purple bar same.

    I have an AMD FX CPU and nvidia GTX780Ti.
     
  10. rogue22

    rogue22 Registered

    Joined:
    Jan 14, 2012
    Messages:
    261
    Likes Received:
    18
    Just wanted to say after the latest patch the stuttering issue I had is now gone. The sim is running smoother than its ever been. No more random pausing happening. Also I'm now seeing 99% GPU utilization on both GPU cores, and about 40 to 50% utilization on cores 3 and 4 on the CPU, no more spikes. A first for me as well. I really don't get what made the difference.

    I went ahead and set my CPU back at 4.7Ghz and my GPU cores back at 1150/1575. Sim is running really smooth, unbelievable.
     
    Last edited by a moderator: Nov 14, 2015
  11. whitmore

    whitmore Registered

    Joined:
    Feb 26, 2012
    Messages:
    551
    Likes Received:
    140
    A new beta AMD driver released a few days ago. Installed and so far no lag. GPU runs at 100% CPU purple bar at 30 to 40%with actual CPU utilisatuon at max 20%

    EDIT. Update after using new beta driver , problem still happening. It did take some time but now same as before. Stuttering and max purple CPU indicator at random times.
     
    Last edited by a moderator: Nov 16, 2015
  12. rogue22

    rogue22 Registered

    Joined:
    Jan 14, 2012
    Messages:
    261
    Likes Received:
    18
    That could have been it as well. I'm on Windows 10, so my graphics driver does what it wants. I did notice the other day I had to redo my catalyst control settings again.
     
  13. Araripe

    Araripe Registered

    Joined:
    Nov 16, 2015
    Messages:
    17
    Likes Received:
    9
    I am experience the game kind of error here. The counter shows 60 fps, the game runs perfect for a while, then starts to stutter (but the counter locked at 60 fps). Figured out it's a Force Feedback issue, but nothing could fix it from now. Changing the FFB update rate from 0 to 3 helps a little bit, but it starts to stutter after a few mins. I've tried every single thing and nothing helps.
     
  14. whitmore

    whitmore Registered

    Joined:
    Feb 26, 2012
    Messages:
    551
    Likes Received:
    140
    Using new beta driver problem has started again. Stuttering & max cpu purple bar indicator.
     
  15. Vintook

    Vintook Registered

    Joined:
    Jan 15, 2012
    Messages:
    51
    Likes Received:
    0
    I was also experiencing this issue, I found the fix (at least for me). I turned off Hyper-threading, Turbo and the Enhanced Intel SpeedStep Technology. Now my CPU purple bar only goes to about 50% instead of maxed out with a full 42 car field in the Nascar mod. One or all of those settings fixed mine, I'm thinking it may have just been the Hyper-threading, I'll have to enable them one at a time to narrow it down.
     
    Last edited by a moderator: Nov 17, 2015
  16. peevee

    peevee Registered

    Joined:
    Oct 15, 2013
    Messages:
    160
    Likes Received:
    18
    I am getting what appears to the same issue as others in this thread since the latest build. Before rF2 was running silky smooth.
    Now it appears that there is some sort of lag - graphics seem to jerk along no longer smooth - and occasional stutter which amounts to a half second pause. Very strange. All I did was update to latest build. Seems worse when using BES mod, but also happens with Megane Trophy although less intense.

    My specs are:
    Windows 7
    Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz (8 CPUs), ~3.6GHz
    Memory: 32768MB RAM
    Card name: NVIDIA GeForce GTX 970
    Monitor Model: SAMSUNG SAM0A7A LED display

    Fraps showing steady 60FPS with sync on and with it off steady 80 FPS - but for sure it is not steady what I am seeing on the screen.
    I am assuming something with the new build has caused this and suggestions for fix or workaround would be cool.
    Any ideas?
    BTW: Other sims not affected
     
    Last edited by a moderator: Nov 18, 2015
  17. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    10,483
    Likes Received:
    5,318
    Can you advise whether you've tried disabling the various CPU options mentioned in the post above yours? rF2 can be sensitive to CPU speed changes, and it's not necessarily reflected in FPS or overall CPU load. The CPU graphs (Ctrl-C by default) will indicate this, the purple horizontal bar shouldn't be approaching the far right end at all.
     
  18. peevee

    peevee Registered

    Joined:
    Oct 15, 2013
    Messages:
    160
    Likes Received:
    18
    Took the plunge updated to Windows 10 and all got sorted
    In fact everything running much better with almost double the frame rates with everything maxed out in all sims.
    PS: Anyone sitting on the fence regarding upgrading to Windows 10 - no worries it works more than fine and hassle free, might resolve your problems...
     
  19. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    287
    LOL! Looks more like your old system was screwed-up completely!
     
  20. nipzon

    nipzon Registered

    Joined:
    Dec 23, 2011
    Messages:
    247
    Likes Received:
    35
    @Spinelli can you please have a look at this problem and give us your expert advise. The powers to be (ISI) seems to be ignoring this problem.
     

Share This Page