Steering wheel rotation problem

Discussion in 'General Discussion' started by Juppo126, Jul 4, 2014.

  1. Juppo126

    Juppo126 Registered

    Joined:
    Jul 3, 2014
    Messages:
    7
    Likes Received:
    0
    Briefly, the steering wheel rotation setting does not work.

    I have G27 and i have checked the box "let the game change settings" or whatever it says in English in the profiler. whatever car i drive my wheel rotates 900 degrees and the in-game rotation setting doesn't do anything.

    I prefer to have my in game wheel on with no hands. because i am used to it i'd rather not turn it off and its kind of disturbing to have it rotating differently than the wheel in my hands.

    So does anyone else have this problem and is there a solution?
     
  2. BillyBl4ze

    BillyBl4ze Registered

    Joined:
    Feb 10, 2013
    Messages:
    44
    Likes Received:
    0
    Same problem here; both checked the profiler (with 900 degrees) and "vehicle set" in game.
     
  3. P.S.R.

    P.S.R. Registered

    Joined:
    Jun 15, 2014
    Messages:
    1,794
    Likes Received:
    4
    Yep. Not with all vehicles though
     
  4. Miro

    Miro Registered

    Joined:
    Jul 14, 2012
    Messages:
    1,357
    Likes Received:
    108
    It probably would help if you could post a screenshot of your logitech profiler settings and the ingame controller settings page.

    Edit: here are mine, works fine here.

    [​IMG]

    [​IMG]
     
    Last edited by a moderator: Jul 4, 2014
  5. Juppo126

    Juppo126 Registered

    Joined:
    Jul 3, 2014
    Messages:
    7
    Likes Received:
    0
    No need to. I have the same settings as you with the exception that i have 100% overall FFB force in profiler. I have played around with the settings in game and really the problem is that rotation setting doesn't have an effect on anything except the in game wheel.

    I'm starting to think that i have misunderstood what the in game setting is supposed to do because it sure does not change the max rotation of the physical wheel, just the virtual wheel.
     
  6. BillyBl4ze

    BillyBl4ze Registered

    Joined:
    Feb 10, 2013
    Messages:
    44
    Likes Received:
    0
    The logitech profiler and the in game settings are ok. Here is the situation: if I set the profiler to 900 degrees and the in game rotation to 100 (for example), my result is that to do 50 degrees in game (turn left or right) I have to rotate my physical wheel of 450 degrees. So, I'm forced to reduce the profiler's degrees to 300 - 400, otherwise I can't play.
     
  7. Bungle

    Bungle Registered

    Joined:
    May 10, 2012
    Messages:
    6
    Likes Received:
    0
    If your running windows 7, be sure that both rf2 and the profiler have admin rights. I had the same issue with the G25 until I ran both with admin rights.
     
  8. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    32
    I've never had a problem with this until the other day. My step kids are here for the summer and they had several instances of rFactor running under two different usernames. I killed every instance and then started a fresh one but the game still wouldn't set the wheel. So then I closed rf and also killed the little Logitech helper/profiler app and then relaunched rF and finally it was working again. Basically a reboot would have accomplished the same thing.
     
  9. jimcarrel

    jimcarrel Registered

    Joined:
    Jan 15, 2012
    Messages:
    1,720
    Likes Received:
    24
    And I thought I was the only one always trying to protect computer from grandkids, etc.:)
     
  10. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    32
    Hahaha.. I actually had to disable the power button on my machine because my son would push it at random while I was racing. He's older now so it isn't an issue. But yeah kids find ways to break everything. :)
     
  11. BillyBl4ze

    BillyBl4ze Registered

    Joined:
    Feb 10, 2013
    Messages:
    44
    Likes Received:
    0
    Thank you both Noel and Bungle! I followed your suggestions and it worked!
    Actually I tried the same tricks months ago but nothing happened; this time the process was successful and I am now a very happy user. Thanks thanks thanks!
     

Share This Page