[SOLVED] Steam VR Steals focus

Discussion in 'Technical & Support' started by JimmyT, Aug 15, 2018.

  1. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    265
    Likes Received:
    121
    I seem to be having an issue with my rF2, I'm running in VR and use an Oculus Rift, I don't have the Oculus software open but Steam VR is running minimised.
    My hardware in i5-6600 3.3gh, Gigabyte Z270 HD3 Mobo, Gigabyte GTX1070 8Gig, 32g Ram and windows 10 (64bit). Fabnatec v2 wheel and v2 pedals, next level racing motion platform. Running sim commander 4 for the buttkicker, also have crew chief running and the motion platform software.
    Everything has been going reasonably smoothly until recently when my rF2 will start to shudder visually randomly then I get the screen that says rF2 is loading VR content and the game crashes leaving the sound playing and the wheel turning in one direction until I turn it off to stop it. Sometimes while the shuddering (visual like micro sleeps) is going on the mirrors on the car stop rendering or have a still image on them of the view just prior to the shudder. I ran my windows focus logger program to see if it could capture anything snatching focus and lo and behold it seems to be steam VR.

    1: has anyone else had this issue?
    2: does anyone have any ideas on how to stop this? I have to re-boot to get everything to run again (not much fun when you've put in 19 of 20 laps and have to re-start PC).

    I appreciate any help you can give
    Thanks in advance

    JT
     
  2. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,076
    Likes Received:
    1,478
    Try these:
    - Make sure you're not running SteamVR Beta, opt out of any Beta and just run the standard program and then verify SteamVR.
    - Verify SteamVR anyway if you're not on a Beta
    - Make sure your Rift USBs are connected to 3.0 ports
    - Make sure your Sensor is not too far away or being obstructed by anything whilst driving.
    - In your player.json search for the following and change 'true' to 'false', it might not help but may be worth a try:
    "Pause If Focus Lost":true,
    "Pause If Focus Lost#":"whether to automatically pause if window loses focus (single-player only)",
    - Run another VR game/app/demo that uses SteamVR, if you're getting the same issues then at least you know it's a SteamVR/Other issue besides RF2.

    God Luck :)
     
    Jego, The Iron Wolf and JimmyT like this.
  3. Booth_doberman

    Booth_doberman Registered

    Joined:
    Oct 5, 2015
    Messages:
    75
    Likes Received:
    30
    I have an RX 480 with an I7 4770. I have a Lenovo headset. I have seen this. I'll be racing and after an hour of so, I'll see the Loading overlay splash on the screen for a couple of seconds, there will be a moment of stutter and then it's back to normal. I run the steam beta, so I guess I could try it with the stock build, but it happens so infrequently and after a long time from starting a session and it doesn't do it every time that I'm not sure I could determine anything.
     
  4. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,298
    Likes Received:
    741
    Ive posted so many times about a issue that I feel is rF2 losing focus in VR and Alt Tabbing after every mouse click is the only way to get smooth VR .
    I get really bad stutters and pauses that can last 30 seconds , some with the rF2 loading screen unless i Alt Tab after every mouse click !
    Ive had no official help , Ive clicked the support button in the launcher and made a post there but nothing has come from it .
    I have had some of the community offer suggestions but none have been able to solve my issue .
    I hope you have more luck solving your problem .
    I haven't heard of that pause if focus lost tweak so I will be trying that next time .
     
  5. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    265
    Likes Received:
    121
    Thanks Mark, will give that a run over the weekend. :)
    Yep, mine is intermittent as well but has become more frequent since recent steam VR update. :(
    Well I hope this thread helps you as well. :)
     
    2ndLastJedi likes this.
  6. ayrtonforever

    ayrtonforever Registered

    Joined:
    May 31, 2017
    Messages:
    23
    Likes Received:
    7
    yes, i had this issue several times after recent updates
     
  7. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    265
    Likes Received:
    121
    @MarcG Thank you sir, I tried those tips and so far it seems to be working. 2 hour drive last night on the track that was more prone to this issue and no trouble.
    I thought I'd already disabled the beta but it was on (again?) verified files and adjusted the player.json :cool::D
     
    MarcG likes this.
  8. jonrarit

    jonrarit Registered

    Joined:
    Jan 17, 2012
    Messages:
    64
    Likes Received:
    7
    I had this issue too. I7 with a 1080Ti running fine for months then all of a sudden complete lock ups with the VR content loading screen. I was using steam VR at the time so disabled it and reverted to the Occulus Tray Tool ...problem instantly solved for a couple of weeks until this evening. Ran an hours race last night online no problem. Fire up tonight and RF2 is mirrored on the monitor ok but the rift head set is black. Oculus home works ok in the headset but RF2 now wont. Tried with steam VR again but its just the same....has there been an update of some kind in the last 24 hours?

    any help appreciated
     
  9. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,076
    Likes Received:
    1,478
    Did the Oculus Software update to v1.31 by any chance? Same issues for me but no time this evening to track the issue down, I've uninstalled all Oculus Software for now and will return to it another time.
     
  10. The Iron Wolf

    The Iron Wolf Registered

    Joined:
    Feb 20, 2016
    Messages:
    692
    Likes Received:
    496
    Why did you uninstall oculus software, does OOVR works without it?! Just curious (I wish) :)

    Recent update seems to broke our workaround of requiring home to have admin privileges, so now on my computer I have to run Home for SVR to work :(
     
  11. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,076
    Likes Received:
    1,478
    it was affecting some important work so just uninstalled for now.
     
  12. MileSeven

    MileSeven Registered

    Joined:
    Apr 1, 2014
    Messages:
    19
    Likes Received:
    2
    Oculus v1.31 issues here too.

    I had to run the race jonrarit referred to with Oculus Home active *and* SteamVR - the HMD blacked out with either just SteamVR or the OTT way of doing things.

    Judging from the Oculus forums, v1.31 is causing some issues with third party content and a Home 2.0 is problematic too. Several users on SteamVR forum are also having black-screen HMD issues.

    For clarity, the headset still works (for me) if Oculus Home is running, so it’s not an NVidia driver issue (i’m Running the latest drivers on an RTX 2080Ti ).
     

Share This Page