Sparks on Pimax VR

Discussion in 'Bug Reports' started by McFlex, Mar 29, 2023.

  1. McFlex

    McFlex Registered

    Joined:
    Feb 23, 2012
    Messages:
    1,031
    Likes Received:
    317
    I recently got a Pimax VR Headset. Coming from a Samsung Odyssey Plus VR Headset which i used for the last years i can surely say that i got quiet a good amound of experience with VR settings.

    From the beginning on i knew that i have to enable parallel projection (PP) mode either in the PiTool or in rF2. At first i activated it in both rF2 and PiTool until i noticed that enabling it in PiTool cost a lot of performance due to a increase in horizontal render resolution (9100x4400 with PP / 7100x4400 without PP). Disabling PP in the PiTool had no impact on the rendered image of rF2 so i kept using this settings UNTIL i saw some sparks coming up. I made some short videos which clearly shows that there is something wrong with the sparks in relation to the PP setting of rF2. The fist video show the sparks when PP is enabled in rF2 but not in PiTool. The second video show the sparks when PP is enabled in rF2 and in PiTool. It seems that the rF2 PP setting does something wierd to the sparks :D

    I hope this bug can be fixed easy.



     
  2. 3NPV5IRR

    3NPV5IRR Registered

    Joined:
    Feb 27, 2014
    Messages:
    123
    Likes Received:
    56
    I have the same issue from the first introduction of sparks.
     
    juanchioooo likes this.
  3. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    2,242
    Likes Received:
    1,649
    Yes, I have the sparks disabled because I see it as in the first video, I only use the pp activated in rfactor 2, because the performance drops too much if I activate it in pitool

    so special effects on low, it doesn't bother me not to see them
     
  4. AKR

    AKR Registered

    Joined:
    Oct 26, 2022
    Messages:
    131
    Likes Received:
    49
    Also no special effects in VR for me, they look ugly. Btw: how do you set PP in Rf2? I only know to set it in Pitool and fortunately a few years ago Studio397 made a change to the game so that we, Pimax users, don't need to use PP anymore. So I disabled it in Pitool right away of course. But you say that there is also an option to enable PP in rf2 itself? How?
     
  5. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    2,242
    Likes Received:
    1,649
    Projection Mode 0 ----------in player json the parallel projection must be at 1
     
  6. McFlex

    McFlex Registered

    Joined:
    Feb 23, 2012
    Messages:
    1,031
    Likes Received:
    317
  7. McFlex

    McFlex Registered

    Joined:
    Feb 23, 2012
    Messages:
    1,031
    Likes Received:
    317
    Bump
     
  8. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    2,242
    Likes Received:
    1,649
    ????
     
  9. Smeghead

    Smeghead Registered

    Joined:
    Dec 31, 2011
    Messages:
    158
    Likes Received:
    207
    no, the option in player file changes the projection mode for canted displays so that parallel projection is not needed in pitool, so it will be the same as in iracing . (as above i think the parameter is projection mode = 1).

    However if you use this mode the sparks are completely wrong, but you get the fps boost from not having to run parallel projection mode and thus a higher resolution.
    You can leave the projection mode in the player.json as 1 but still enable parallel projection in pitool and you will get sparks working just fine, however the resolution will be bumped up as before so you will get a fps hit probably. (ie running parallel projection in pitool makes the player.json setting do nothing, either 1 or 0 will give same result)

    I reported this as a bug ages ago, with images of the sparks but obviously it has not been addressed
     
    juanchioooo likes this.
  10. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    2,242
    Likes Received:
    1,649
    deactivate the sparks, which is only a graphic effect, to deactivate the sparks in special effects, you have to set it to low
     
  11. McFlex

    McFlex Registered

    Joined:
    Feb 23, 2012
    Messages:
    1,031
    Likes Received:
    317

Share This Page