[SOLVED] Some questions regarding 3ds max and materials

Discussion in 'Track Modding' started by SLK, May 18, 2020.

  1. SLK

    SLK Registered

    Joined:
    Nov 20, 2017
    Messages:
    33
    Likes Received:
    3
    Hello,

    I have encountered a few problems with 3ds max, trying to get my content into the game. Maybe someone with more experience could help me out.
    The first thing is the 'Top level must be Multi/Sub.' -error message. Sometimes exporting an object works fine, and sometimes it doesnt.
    This is my material: [​IMG]
    My second issue is that I cannot get the alpha channel of my texture working.
    [​IMG]
    This is the alpha channel in photoshop.
    [​IMG]
    I tried quite a lot and I'm stuck here for a few days already. Just let me know, if you need any further screenshots. Would be nice, if someone could help me out.
     
  2. DaREALMastaD

    DaREALMastaD Registered

    Joined:
    Sep 27, 2015
    Messages:
    89
    Likes Received:
    32
    Are you not seeing the transparency in game or in 3dsMax? I believe from what I can remember, you won't see the effects of the transparency in 3dsMax for the plugin. I believe you have to check it out in game or 3dSimED. Not sure about the other issue you're having, as long as the top level is Multi/Sub.
     
  3. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,478
    Likes Received:
    1,298
    Are you using the slate material editor? If so, you have to use the old one. If not, then maybe the right material isn't applied to the object.
     
  4. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,431
    Likes Received:
    673
    And when i'm not totally wrong, two sided material should not be used anymore in rfactor 2.
     
  5. SLK

    SLK Registered

    Joined:
    Nov 20, 2017
    Messages:
    33
    Likes Received:
    3
    Both. The block I managed to export earlier was looking identical in 3ds max and the viewer from the moddev folder. Unfortunately I cannot try it again with another object, since I still receive the multi/sub error.
    I am using the compact version.
    I have disabled it now.
     
  6. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,431
    Likes Received:
    673
    @SLK Which version of 3dsmax do you use 2012 or 2017?

    EDIT And as @Coutie has said already. Ensure that the rfactor 2 shader(s), that are sublevels of a multi/sub main level, are attached to the whole object.
    Just 1 poly/triangle, that don't uses such a shader, causes the error message that you get.
     
    Last edited: May 19, 2020
  7. SLK

    SLK Registered

    Joined:
    Nov 20, 2017
    Messages:
    33
    Likes Received:
    3
    I am using 3ds Max 2017. I just made another Plane and attached a new material to it. And it worked! I think, I must have either made a mistake somewhere in the process, which I havent realized or the two sided material was the issue. Big thanks to you, guys!
     
    Bernd likes this.
  8. SLK

    SLK Registered

    Joined:
    Nov 20, 2017
    Messages:
    33
    Likes Received:
    3
    Well, I have checked my object in the viewer and it is only visible from one side. I think that was the reason why I ticked the 'two sided'-box initially. In 3dsimed everything looks fine, however. When I rotate the object in 3ds max, the other side of the object is black. Any suggestions what could be the cause?
     
  9. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,431
    Likes Received:
    673
    Sometimes it's just the settings of the viewport lighting and shadows.
     
  10. SLK

    SLK Registered

    Joined:
    Nov 20, 2017
    Messages:
    33
    Likes Received:
    3
    Just to clarify: With 'viewer' I meant the 'Viewerx64Release DX11.exe'. Do the viewport settings have an impact on the rendered object?
     
  11. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,431
    Likes Received:
    673
    Only on how they are displayed and i remember that a viewport lighting/shadow setting made the backwarded from the light source side of the objects looking completely black.
    But i can't remember exactly which setting(s) it was.
     
  12. SLK

    SLK Registered

    Joined:
    Nov 20, 2017
    Messages:
    33
    Likes Received:
    3
    Okay, I was testing a few more settings and it turned out that enabling 'two sided materials' fixed my issue. Furthermore, I realized that dragging the multi-sub object first and then applying the material is required to avoid that error message box.
     
  13. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,431
    Likes Received:
    673
    As said, "2 sided material should not be used anymore" is a statement from the rfactor 2 devs, that i mean to remember.
    And which issue did you fix with it?
     
  14. SLK

    SLK Registered

    Joined:
    Nov 20, 2017
    Messages:
    33
    Likes Received:
    3
    [​IMG]
    I try to add some 2d grass. The old issue was that it was only visible from one side and invisible from the other side. Unfortunately, the textures seem to overlap each other now completely.
     
  15. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,431
    Likes Received:
    673
    What do you think about to use billboard gras?
    With that you could use a one sided material again and it is always visible for the player.
    I think that 2 sided material has a bad influence somehow.
    But i can not tell you in which way.
    Maybe another user knows it?
     
  16. SLK

    SLK Registered

    Joined:
    Nov 20, 2017
    Messages:
    33
    Likes Received:
    3
    I've added a shell modifier to the object and now it renders both ways without a two-sided material. It doesnt seem to be a good solution performance-wise tho. I don't know what billboard grass is, but I'm assuming that it is an image, which is always rotating to the perspective of the player? I'm unsure, if that would work with objects, which are close to the player, because the rotation might be visible. I just discovered another problem, where my grass-objects arent receiving any shadows from other objects. Do you have possibly an idea, what could cause this?
     
  17. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,431
    Likes Received:
    673
    @SLK What is a shell modifier? Does rfactor support that?
    To see if the rotation of a billboard object is noticable when you are close to it, just try it out. ;)
    And the shadow problem is a bit strange.
    It should work automatically.
    For cars, i can use tags in the gen files instance entries, like shadowreceiver=true or =false to define it, but i have never seen that in a track scn file.
    Can you post a screenshot of your exporter settings?
     
  18. SLK

    SLK Registered

    Joined:
    Nov 20, 2017
    Messages:
    33
    Likes Received:
    3
  19. SLK

    SLK Registered

    Joined:
    Nov 20, 2017
    Messages:
    33
    Likes Received:
    3
    I just noticed, that the hat and collide boxes shouldnt be ticked, but removing those didnt help unfortunately.
     
  20. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,431
    Likes Received:
    673
    @SLK Would you mind to upload that plane and the textures that it uses, packed in a zip file, here?
    I could put it on the joesville track and test it then.
    Also to compare it with an own plane.

    EDIT Thanks, now i know what the shell modifier is doing.
     

Share This Page