SOLVED - Yet another Dedicated Server Problem but with a twist

Discussion in 'Hosting Help' started by Joel.Brown, Sep 14, 2023.

  1. Joel.Brown

    Joel.Brown Registered

    Joined:
    Jan 16, 2012
    Messages:
    107
    Likes Received:
    88
    I have a dedicated rack mount server just for rfactor and nothing else. It currently has the full install of rfactor2 on it. I switch to the oldUI to download and install content, can't do the new UI on this machine it won't handle it, then run the Dedicated Server that comes with the full install. Everything works great.

    There are no firewalls, no anti-virus s/w, all ports are open in the router. Re-installed all the runtimes multiple times.

    I want to get rid of the full install and just use the SteamCMD Dedicated Server. Installed it, downloaded content to it, used the same ports as the existing server I use, fired it up as the ONLY thing running on this box, it says Matcher Status: Not Connected To Steam and nobody can see it. Direct connect works fine.

    So I downloaded the installation to my home computer to try and debug it. Same error. So I tried my existing installation of Steam Dedicated Server that has worked for the past year. It now says Matcher Status: Not Connected To Steam. I verified the ports are open and direct connect works.

    This is beyond frustrating.
     
  2. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,987
    Likes Received:
    1,023
    Probably doesn't matter that all ports are open, you need to PORT FORWARD to correct ones for your Steam CMD install. Have you been through the user guide?
     
  3. mschreiner

    mschreiner Registered

    Joined:
    Oct 5, 2010
    Messages:
    390
    Likes Received:
    262
    I have been helping him. It has been port forwarded as well. Firewall on and off no differences. Anti-virus turned off as well. We are both really good a networking, so this is beyond frustrating.
     
  4. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    3,875
    Likes Received:
    2,681
    Another User reported the same Thing, that the Server was not getting connected to Steam.
    But he disappeared, without to report if the Problem was solved.
    The Anti Virus Software that gets used, which one is it and is it a free Version?
    Sometimes you have to completely uninstall such Software, to get rid of blocking something.
    Did you also try that?
    I have never seen my Server not being connected to Steam, so that sounds a bit strange for me, when all Ports are opened, forwarded, .... set up properly.
     
  5. trichens

    trichens Registered

    Joined:
    Nov 2, 2020
    Messages:
    208
    Likes Received:
    148
    There's a comment on a Steam rF2 forum message from 2017 that says
    "Matcher Status will always show an error on the dedicated server, the matching server is no longer used."
     
  6. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    3,875
    Likes Received:
    2,681
    It's not the Matcher, it's the Message in the Dedicated Server Window, that it is connected to Steam.
     
  7. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    694
    Likes Received:
    201
    Hello. Make sure your internet provider have no limitations.
    Here in France with some providers like Free we need to get the "Full IPv4" to get some ports working or it is controlled/blocked by them via their box.
    You are totally unable to check their side unless you can make some traceroute and see if everything is fine.

    Next, did you make sure the Server has always the same Lan IP ? Sometimes DHCP allocates another ip and the forwarding is not working anymore after a PC restart for example. Make sure you have a static LAN IP on the server.

    As last use the DMZ option and see if issue is still there.

    And maybe use some external tools to check the forwarding ... https://canyouseeme.org/
     
  8. mschreiner

    mschreiner Registered

    Joined:
    Oct 5, 2010
    Messages:
    390
    Likes Received:
    262
    The main box does not have anti-virus. This is a dedicated 2012 Server OS
     
  9. Joel.Brown

    Joel.Brown Registered

    Joined:
    Jan 16, 2012
    Messages:
    107
    Likes Received:
    88
    Let me make this simpler.

    The server box has a full install of rFactor2 and the Dedicated server that comes with the full install works great. When I installed the SteamCMD version of the Dedicated Server into a completely different folder and use the same ports as the one that works, it says Not Connected To Steam. And yes, I don't try to run them both at the same time.

    This is what's driving me crazy. The Dedicated Server that comes with the full licensed installation works. The SteamCMD Dedicated Server doesn't.

    There is no firewall, no anti-virus, has a static IP, fully exposed to the internet exactly as if it was a DMZ machine. We've been running servers for years, we just want to switch to the SteamCMD version of Dedicated servers.
     
  10. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,404
    Likes Received:
    948
    Try changing the webUI port in the server’s player.json file. I know if I have server on same computer here I need to change the webui port, generally though I have both game and server running, so may not fix things for you, but hey it’s rF2 :)
     
  11. Joel.Brown

    Joel.Brown Registered

    Joined:
    Jan 16, 2012
    Messages:
    107
    Likes Received:
    88
    Even though I did that, it's not needed because the only thing running is the SteamCMD Dedicated Server on a dedicated server computer. This is only needed if you want to run the client and server on the same box. But thanks for the response.
     
  12. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    3,875
    Likes Received:
    2,681
    @Joel.Brown In the opening Post you write "Direct connect works fine".
    Just to be clear: Also Clients can connect to the Server by using Direct Connection Links, it is just not listed in the in Game and Steam Server List?
    Do you see the Server being listed on my Server List Website?
     
  13. Any chance to update the 2012 version to any newer (or is it just a typo and 2022 is running)? It is not needed, but I have experience running rf2ds on 2019 and 2022.

    Also I would recommend not to use the installation directory of the full install you've done before (but you wrote it is a fresh install of SteamCMD and rF2).

    The documentation of setting up a rF2ds is a lil' outdated IMHO ... we still need the ServerUnlock file, the actual dedicated server executable seems not to create userdata\<profilename> folder (and therefore json files are not created - the rf2ds will start, but not connect to any ports outside).

    Of course if the machine is running behind kind of modem or router port forwarding needs to be enabled (enter IP of the machine as target, because e.g. some routers will store different IPs for same hostname if they are running short duration DHCP leases).

    And yes, IMHO a IPv4 connection (provided by internet provider) will solve most problems.
     
    Last edited by a moderator: Sep 15, 2023
  14. Joel.Brown

    Joel.Brown Registered

    Joined:
    Jan 16, 2012
    Messages:
    107
    Likes Received:
    88
    It's just not listed in Multiplayer and your Server list too.
     
  15. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    694
    Likes Received:
    201
    At some point i also made an error causing that kind of issue ..
    Right forwarding :
    UDP+TCP 54297
    TCP 64297
    UDP 64298
    UDP 64299

    I was using UDP 64297 and 64298 instead of 64298 and 64299.

    Must be adapted to the ports you use ...
    TCP : Port N
    UDP : Port N +1 and N + 2 ...

    Maybe you also have made such error. Check it again ...
     
  16. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    3,875
    Likes Received:
    2,681
    @Joel.Brown I agree with @DanRZ
    If you and the other Clients too, can join the Server by using a Direct Link Shortcut and the only Problem is, that the Server is not showing up in the in Game, Steam and also not my Server List, there must be something being set up wrong with the Ports, if they don't get blocked by a Firewall.
    As he did say, recheck everything, that you really have the ones in the MultiplayerJSON used and the other necessary Ports opened and forwarded.
    When i did have that Problem, @StoneRacing suggested to forward ALL used Ports (which was not necessary in the Past) and then it worked.
     
    DanRZ likes this.
  17. Joel.Brown

    Joel.Brown Registered

    Joined:
    Jan 16, 2012
    Messages:
    107
    Likes Received:
    88
    I'll be using Wireshark to packet sniff what's going on sometime later this week when I get time. Thanks for all the responses.
     
  18. Joel.Brown

    Joel.Brown Registered

    Joined:
    Jan 16, 2012
    Messages:
    107
    Likes Received:
    88
    I found a tool called UDP Test Tool v3.0 that is both a client and a host. It sends UDP packets from one computer to another on user configured IP addresses and ports to test if routers and firewalls are configured correctly. I ran it on 2 different computers at 2 different locations to test to see if ports were open in both directions, since both of these computers are going to be servers. It said the ports 64298 and 64299 were functional and other ports, such as 64300, that were not supposed to work, were blocked. I've tested 64297 and 54297 by using Direct Connect from a client machine to the server and it worked.

    The big kicker is: One of the servers has all ports open, no firewall, no anti-virus and has a full install of rFactor2. The Dedicated Server in the full install of rFactor2 works great. The Steam installed Dedicated Server, using the default or exact same ports as the full install server, will not connect to Steam and can't be seen in Multiplayer. THIS IS ON THE SAME COMPUTER. And yes, I didn't try and run both at the same time.

    The UDP ports are working. btw - this UDP Test Tool 3.0 should be referenced in the Dedicated Server documentation as a way of verifying UDP ports. It's an easy-to-use free tool.

    I also used Wireshark on one of the servers and never saw a UDP packet with a port of 64298 or 64299 being sent or received.

    I'm at a loss.
     
    Last edited: Sep 25, 2023
  19. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    3,875
    Likes Received:
    2,681
    That is really strange.
    I also have Steam, a full Install of rFactor 2 and the Steam Command Dedicated Server on the same Machine.
    When i only start the Steam Command Dedicated Server, it gets connected to Steam after 1-2 Seconds.
    I have no Idea anymore why that doesn't work for you, when you have the described Configuration and all Ports are accessible.
    BTW I just tested where my Server is visible and it is very inconsistent.
    Now i see only ~60 Server in the in Game and Steam Server Lists and i don't see my own One there, but i see 458 Server on my own Web-Server-List and i see my own One there too.
    The Question really is, why your Steam Command Dedicated Server doesn't connect to Steam.

    EDIT On which Partition(s) are your Steam Program/rFactor 2 and the Steam Command Dedicated Server installed?
    I mean to remember, that there were Problems with "higher" Partition Letters than H.
     
    Last edited: Sep 26, 2023
  20. Joel.Brown

    Joel.Brown Registered

    Joined:
    Jan 16, 2012
    Messages:
    107
    Likes Received:
    88
    On one server they are all on the C: drive. The other server, they are on the D: drive.
     

Share This Page